Bluebeam Account Shows as Unpaid

Applies to:

  • Basics
  • Core
  • Complete

Problem

You’ve purchased a Bluebeam Plan, but Revu still displays your account as “Package: Unpaid” or “Package: None”.

Cause

Your account could display as “Unpaid” or “None” for the following reasons:

  • You’ve been invited as an end user, but haven’t accepted the email invitation and activated your account.
  • You’re the Org Admin, and haven’t assigned yourself as an end user.
  • Your computer has Windows 7 installed. Revu 21 isn’t compatible with Windows 7.

Solution

You haven’t accepted the email invitation

You’ll need to check your inbox for an email titled “You’ve been invited to a Bluebeam account”, and click Accept Invitation.

You haven’t assigned yourself as an end user

Org Admins must set themselves as an end user if they want to sign in to Revu 21 and Bluebeam Cloud. See our Subscription Management Guide for steps on adding an end user.

Your computer has Windows 7 installed

Revu 21 is compatible only with Windows 10 and Windows 11. To sign in to Revu 21, upgrade to a compatible version of Windows.

 

Revu 21

Troubleshooting

Subscriptions

You’ve purchased a Bluebeam Plan, but Revu still displays your account as “Package: Unpaid” or “Package: None”.

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