“Error creating new contact, error duplicate record. Contact already exists.”

Applies to:

  • Basics
  • Core
  • Complete

Problem

When you use the Bluebeam Subscription Management portal to add an end user to a subscription account, you receive the following message, “Error creating new contact, error duplicate record. Contact already exists.” 

Cause

This issue could be the result of the end user already being listed in your account.

Solution

Contact Technical Support with the following information:

  • The name and email address of the person you want to add
  • The name of the account in which you’re trying to add the person

Related Articles