Error: “File is locked by another user. Would you like to open a read-only copy of this file?”

Applies to:

  • Revu 21
  • Revu 20
  • Revu 2019
  • Revu 2018

Jump to other versions:

Problem

When attempting to open a PDF file, an error says:

Error Opening File: “File is locked by another user. Would you like to open a read-only copy of this file?”

Cause

This happens when Windows doesn’t have a built-in PDF viewer for displaying files in the preview pane. Instead, Windows uses a third-party PDF viewer to mark the file as locked, or in use.

Solutions

Change the default PDF viewer

Revu includes a PDF previewer for Windows Explorer that doesn’t mark files as in use. The PDF previewer is activated when Revu is set as the default PDF viewer in Windows.

  1. Open Revu.
  2. Select Revu > Preferences.
  3. Select Admin from the left-hand menu.
  4. Select Open Default Programs.
  5. When the Settings window displays, complete these additional steps:
    1. Select Choose default apps by file type.
    2. Scroll through the list of file types until you reach .pdf, and double-click the current default app.
    3. Select Revu from the list of applications.

Edit your Revu preferences

You can also edit your Revu Preferences, as described below:

  1. Go to Revu > Preferences.
  2. Select General from the left-hand menu.
  3. Select the Document tab.
  4. Clear the checkbox for Prompt user if file is locked.
  5. Select OK.

If you’re previewing the file within the Windows preview pane, you may not be able to save it in Revu. You may see this error: “The document could not be published. The process cannot access the file because it is in use by another process.”

You can select a different file in the file Explorer or close Explorer, and try saving the document you were originally working with.

Files stored on a server

If this error appears when opening a file stored on a server, it’s possible that another user has the same document open. Some network processes, such as backup or synchronization utilities, may also mark files as in use.

Troubleshooting

Revu 2018

Revu 2019

Error Message

Studio

Revu 20

Other versions of this article

Revu 2017 and older

Problem

You’re receiving a message when attempting to open a PDF file that says:

Error Opening File: “File is locked by another. Would you like to open a read-only copy of this file?”

Cause

This happens when Windows doesn’t have a native PDF viewer for displaying files in the preview pane. Instead, Windows uses a third-party PDF viewer to mark the file as locked, or in use.

Solution 1: Change the default PDF viewer

Revu 9.5 and above includes a Bluebeam “previewer” for Windows Explorer that doesn’t mark files as being “in use”.

Revu 9 users running version 9.0 to 9.2.1 can download and install this free update from our Downloads & Updates page.

Once you’ve confirmed that Revu 9.5 or above is installed, you can set Bluebeam as the default PDF viewer by following the steps listed below:

  1. Open Revu.
  2. Click Help > Administrator.
  3. Click the Revu tab in the Administrator.
  4. Click the Use as default PDF viewer check box.
  5. Click OK.

Solution 2: Edit your Revu preferences

You can also prevent this message from appearing by turning it off in the Revu Preferences as described below.

Depending on your version of Revu:

  1. Click Edit > Preferences, or use keyboard shortcut Ctrl+K.
    A list of Revu keyboard shortcuts is available in the Revu Help menu and on our website.
  2. Click Document on the left.
  3. Clear checkbox for Prompt user if file is locked.
  4. Click OK to save the setting and close Preferences.

You won’t be able to save a file if it’s marked as “in use by” in the Adobe previewer. An error will appear saying, “The document could not be published. The process cannot access the file because it is in use by another process.”

To get around this, you’ll need to select a different file in Windows Explorer to preview the file, and then try saving the document you were originally working with.

A Note about Files Stored on a Server

If this error appears when trying to open a file that’s stored on a server, it’s quite possible that someone else may actually have the document open. Another thing to consider is that some network processes, such as backup or synchronization utilities, may also mark files as “in use”.

Troubleshooting

Revu 2017 & Below

Error Message

Studio

This error occurs when Windows doesn’t have a built-in PDF viewer for displaying files in the preview pane.

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