Applies to:
- Revu 21
- Revu 20
- Revu 2019
- Revu 2018
Jump to other versions:
Problem
When attempting to open a PDF file, an error says:
Error Opening File: “File is locked by another user. Would you like to open a read-only copy of this file?”
Cause
This happens when Windows doesn’t have a built-in PDF viewer for displaying files in the preview pane. Instead, Windows uses a third-party PDF viewer to mark the file as locked, or in use.
Solutions
Change the default PDF viewer
Revu includes a PDF previewer for Windows Explorer that doesn’t mark files as in use. The PDF previewer is activated when Revu is set as the default PDF viewer in Windows.
- Open Revu.
- Select Revu > Preferences.
- Select Admin from the left-hand menu.
- Select Open Default Programs.
- When the Settings window displays, complete these additional steps:
- Select Choose default apps by file type.
- Scroll through the list of file types until you reach .pdf, and double-click the current default app.
- Select Revu from the list of applications.
Edit your Revu preferences
You can also edit your Revu Preferences, as described below:
- Go to Revu > Preferences.
- Select General from the left-hand menu.
- Select the Document tab.
- Clear the checkbox for Prompt user if file is locked.
- Select OK.
If you’re previewing the file within the Windows preview pane, you may not be able to save it in Revu. You may see this error: “The document could not be published. The process cannot access the file because it is in use by another process.”
Files stored on a server
If this error appears when opening a file stored on a server, it’s possible that another user has the same document open. Some network processes, such as backup or synchronization utilities, may also mark files as in use.
Troubleshooting
Revu 2018
Revu 2019
Error Message
Studio
Revu 20
Other versions of this article
Revu 2017 and older
Problem
You’re receiving a message when attempting to open a PDF file that says:
Error Opening File: “File is locked by another. Would you like to open a read-only copy of this file?”
Cause
This happens when Windows doesn’t have a native PDF viewer for displaying files in the preview pane. Instead, Windows uses a third-party PDF viewer to mark the file as locked, or in use.
Solution 1: Change the default PDF viewer
Revu 9.5 and above includes a Bluebeam “previewer” for Windows Explorer that doesn’t mark files as being “in use”.
Once you’ve confirmed that Revu 9.5 or above is installed, you can set Bluebeam as the default PDF viewer by following the steps listed below:
- Open Revu.
- Click Help > Administrator.
- Click the Revu tab in the Administrator.
- Click the Use as default PDF viewer check box.
- Click OK.
Solution 2: Edit your Revu preferences
You can also prevent this message from appearing by turning it off in the Revu Preferences as described below.
Depending on your version of Revu:
- Click Edit > Preferences, or use keyboard shortcut Ctrl+K.
A list of Revu keyboard shortcuts is available in the Revu Help menu and on our website. - Click Document on the left.
- Clear checkbox for Prompt user if file is locked.
- Click OK to save the setting and close Preferences.
You won’t be able to save a file if it’s marked as “in use by” in the Adobe previewer. An error will appear saying, “The document could not be published. The process cannot access the file because it is in use by another process.”
A Note about Files Stored on a Server
If this error appears when trying to open a file that’s stored on a server, it’s quite possible that someone else may actually have the document open. Another thing to consider is that some network processes, such as backup or synchronization utilities, may also mark files as “in use”.
Troubleshooting
Revu 2017 & Below
Error Message
Studio
This error occurs when Windows doesn’t have a built-in PDF viewer for displaying files in the preview pane.