Applies to:
- Revu 21
- Revu 20
- Revu 2019
- Revu 2018
Problem
When you attempt to log into Studio or access the Bluebeam Gateway with your Bluebeam ID (BBID), you receive the following error message:
Sorry, this combination doesn’t look right. Things you can check: your email, password, or regional selection.
Cause
You could be receiving this error message for the following reasons:
- Your BBID email address was entered incorrectly.
- Your Bluebeam ID has not been created yet.
- Your account remains in a pre-created status.
- Your account has been deactivated.
Solution
Create an account and try again.
If you continue to receive this error after resetting your password and/or validating your account, check that you’ve selected the right server region and entered your email correctly.
If none of the above resolves the issue, please contact support@bluebeam.com and request account reactivation.
If your BBID account was deactivated at the request of your company, Bluebeam Technical Support will need approval from the original authority who requested the deactivation.
Revu 21
Revu 20
Revu 2019
Revu 2018
Troubleshooting
Error Message
Studio