Error: “We can’t log you in… contact your Salesforce administrator.” | Bluebeam Subscription Management

This article applies to:

  • Revu 21

Problem

When attempting to log into the Bluebeam Subscription Management Portal (i.e., Org Admin Portal) and/or the Bluebeam Webstore, you receive the following error message:

Error message: We can't log you in in...contact your Salesforce administrator

Cause

If you’re using a bookmarked link and/or a link in which the server region isn’t cached, you can’t access your account.

Solution

Use the following links for Bluebeam account management. When prompted, select the correct server region for your account(s).

Before signing into the Bluebeam Webstore, be sure to choose the Location/Currency and Server Region from the dropdowns at the top of the page.

For more information about managing your subscription seats, please visit the Bluebeam Subscription Management Guide. If you need to access purchase information for your subscription(s), click here. To learn more about upgrading/downgrading your subscription plan(s), see this article.

Bluebeam Cloud

Revu 21

Troubleshooting

Subscription Management

Subscriptions

If the maximum number of seats has been exceeded in Revu 21, manage your subscription account to fix it and get access.

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