Getting started in Bluebeam Studio with a trial of Revu

Applies to:

  • Revu 20
  • Revu 2019

Bluebeam Studio makes it simple to collaborate on documents, even if you don’t own a license of Revu. With a 30-day free trial, you’ll have access to all of the features in Revu, and you can continue to collaborate in View Mode after your trial expires. Here are some tips to get you started in Studio using a free trial of Revu.

Install Revu

First, download the free trial and install it on your computer. During the installation, when Revu asks you to enter your serial number and product key, select Use as Trial. This will activate a 30-day trial of Revu, granting you full access to the software. When your trial expires, Revu will automatically switch to View Mode. View Mode allows you to use Measurement tools, join Studio Sessions, and view documents. 

Getting started in Studio

Before using Studio, you’ll need to set up your Bluebeam ID (BBID).

To set up your Bluebeam ID

  1. Open Revu.
  2. Click the Studio  icon (Alt+C), on the left of the interface by default.
  3. Click the Sign in button.
  4. Select Create Account and fill out all fields.
    The Bluebeam Display Name is the name that your colleagues will see when you make changes to a document.
  1. You’ll be sent a verification email for your Studio account. Open the email and click Confirm My Bluebeam ID. Once your account has been verified, you can sign in to Studio with your BBID.

Studio Sessions and Studio Projects

There are two components of Studio: Studio Sessions and Studio Projects. While both of them enable you to collaborate with others, they each have distinct features and applications. In short, Studio Projects are for cloud-based file storage and document management, whereas Studio Sessions are for adding markups to PDFs in real time with colleagues. Learning the difference can help you understand how and what you’re able to edit in Studio.

Studio Projects

Getting to know Studio Projects

To find Studio Projects, open the Studio panel and then select Projects .

A Project is an online storage and document management system. Projects can store many different types of files — even non-PDF documents — that can be edited in other programs. To ensure that participants don’t write over each other’s changes, documents must first be checked out before they can be edited. Checking out a document means that nobody else will be able to edit the document until you check it back in. 

Using Projects

The main workflow for Projects is to check out a document, make changes to it, and then check it back in as a new revision. This process is slightly different depending on whether you’re editing a PDF document or a non-PDF document. 

To edit PDF documents

  1. Open the Studio panel and select Projects .
  2. Right-click on the file and select Check Out . The file will now be listed in the Pending section of the Project with a blue icon next to it.
  3. Right-click on the file again and select Open . The PDF will load in a new tab in Revu.
  4. Make any desired changes to the document, and go to File > Save to save them.
  5. Go back to the Studio Project tab. Right-click on the file listed in the Pending section, and select Check In .

During the check-in process, you’ll be prompted to add comments. These comments will be added to the document’s Revision History. To view the Revision History, right-click on the document and select Revision History.

Please note that PDF markup and editing in a Project is restricted after the free trial has expired.

To edit non-PDF files

Other file types — like Excel® spreadsheets and Word® documents — can also be added to Studio Projects. These files can be checked out and edited locally using an appropriate program, then checked back into the Project.

  1. Open the Studio panel and select Projects .
  2. Right-click on the file and select Check Out . The file will now be listed in the Pending section of the Project with a blue icon next to it.
  3. Right-click on the file again and select Open . This will open the file with its associated application. (For example, opening an Excel® spreadsheet will launch Microsoft Excel®.)
  4. Edit the document in its associated application. When you’re finished, save your changes as you normally would.
  5. Go back to the Studio Project tab. Right-click on the file listed in the Pending section, and select Check In .

Studio Sessions

Getting to know Studio Sessions

To find Studio Sessions, open the Studio panel and then select Sessions .

Studio Sessions are for PDF-based online collaboration. While in a Studio Session, any user running in View Mode will have access to all of the markup and tool set features normally reserved for licensed users of Revu. This means that you can take measurements, add comments and place markups on PDFs to share your thoughts with others participating in the Studio Session with you, even if your Revu trial has expired.

How Sessions Work

While in a Session, you don’t need to check files in and out. All you need to do is click on a PDF to open it, even if other users have the PDF opened. That’s the benefit of Sessions: real time collaboration. All users in the Session mark up the document, and everyone can see what others are adding or have added. There’s also a Record that captures what each user added, modified or removed from the PDF. To maintain user accountability, markups in Sessions can only be edited or removed by the user who initially created them.

Automatic cloud backup

All markups are added in real time and uploaded to the cloud as you add them to the PDF, so even if you lose connection to the Session, your markups are safely stored within that Session. Revu will even remember which PDFs you had open and will restore them for you automatically, so you can pick up right where you left off once internet connectivity is restored.

While in View Mode, you will be unable to add files to a Session, even if your account has permission to do so.

Joining a Session or Project

If you’ve been invited to a Studio Session or Project

You can join the Session or Project directly from the invitation email.

  1. Open your invitation email and click Accept Invitation.
  2. You’ll be asked whether you want to open in Revu or Drawings Web, choose Revu.
  3. Revu should automatically open and load the Session or Project from the invitation.

If Revu doesn’t open automatically or if you need to join the session manually, you can also use the Session or Project ID in that email to join the session.

If you’ve been sent a Session or Project ID

You can join a Project or Session using its 9-digit ID number if you’ve been invited to it, or if access is unrestricted.

  1. In Revu, click Studio  to open the Studio panel.
  2. Click Sign in if you haven’t already.
  3. Click the Add button in the Studio panel and select Join.
    The Join dialog box appears.
  4. Enter the 9-digit ID number and click OK.

Related Articles