How to save and create title block templates for sketches

This article applies to:

  • All versions of Revu

If you need to create a drawing on the fly without access to AutoCAD, you can use Revu to sketch proposed layouts and details. By utilizing PDF title block templates, you can standardize your sketches and sketching processes.

Title Block Example
Title blocks include pertinent drawing information such as legal disclaimers, approvals, dates, your organization’s logo, and more.

In this article, we’ll go over how to save and create title block templates for easy access when sketching in Revu.

Use an existing document as a title block template

If you already have a standard title block to work with, you can open it in Revu and add it to your list of templates for a digital sketching workflow.

Scan hard copies as PDFs

If you only have access to a printed drawing with your title block, you can scan it to your device as a PDF. There are a couple ways to do this:

  • Go to File > Create > From Scanner or Camera.
    This method only works if your device is directly connected to a scanner.
  • Scan the drawing as a PDF and either send it to your email or a shared drive.

After scanning the document, open the PDF in Revu to edit content and save it as a template for future use.

Open PDF versions of drawing files

If you have access to digital drawings with a title block, you’ll need to make sure they’re PDFs before opening them in Revu. For more information about this, see How to convert DWG files to PDF.

Once the CAD drawing is converted, open it in Revu to start working with it:

  • Go to File > Open and select the PDF from the File Explorer.

Now you’re ready to edit the file for use as a sketch template.

Convert a drawing into a sketch template

To create a sketch template for future use, you’ll need to remove any PDF content outside the title block. To do this:

  1. Go to Edit > PDF Content > Erase Content.
  2. Click-and-drag around the content you’d like to erase, leaving the title block intact.
    To edit existing project information inside the title block, use the Typewriter (W) tool.
  3. Next, go to the File Properties panel and update the Title. The title of the file is what will appear in the template dropdown list.
    File Title in File Properties panel
  4. To save the document as a new template, go to File > New PDF from Template… > Save as Template.
  5. Enter a new file name in the File Explorer dialog box and click Save.

Now your new title block template should appear in the dropdown list when you navigate to File > New PDF from Template… to create a new sketch.

To make any edits to your new template in the future, highlight it from the dropdown list and select the pen icon on the far right side of the menu.

Edit title block template GIF

Create a new title block template

If you don’t have access to an existing title block, you can create one directly in Revu using markup tools.

To use any custom markups saved to a toolset when creating your title block, be sure to open the profile associated with that toolset after launching Revu.

Create page border and title block section

  1. Go to File > New PDF. A dialog box will appear.
  2. Edit the page size, orientation, and etc. according to your standard drawings. For Style, Blank is recommended.

    New PDF dialog box

  3. Click OK.
  4. Go to View > Show Grid (Shift+F9).
  5. To ensure straight lines while sketching, go to View > Snap to Grid (Ctrl+Shift+F9).
  6. Next, select Tools > Markup > Rectangle (R) and draw a border around the perimeter of the page.
  7. With the new border selected, open the Properties panel to edit the line color, line width, and more.
  8. Select Tools > Markup > Rectangle again to draw the section(s) for your title block.
  9. As with the page border, select the new title block section(s) and go to the Properties panel to edit the appearance.

Customize your title block

After outlining your title block, you can add more content to it using tools in Revu.

  • To add a logo, go to Tools > Markup > Image > From File.
    If your device is connected to a scanner, you can also scan a logo from a hard copy by selecting From Scanner.
  • To add lines, go to Tools > Markup > Line (L).
  • To add text go to Tools > Markup > Typewriter (W) or create a text box by selecting Tools > Markup > Text Box (T).

Save a new title block template

To use your new title block for future sketches, you’ll need to save it as a template.

  1. Before saving the new PDF template, flatten the document to ensure the title block can’t be edited while sketching. Go to Document > Flatten (Ctrl+Shift+M).
  2. You can select whether or not to Allow Markup Recovery (Unflatten). Enable this setting if you’ll need to edit the title block in the future.
    Allow Markup Recovery
  3. Click Flatten.
  4. Go to the File Properties panel and give the document a Title. This is what will appear in the template dropdown menu.
  5. Next, select File > New PDF from Template… > Save As Template.
  6. Enter a file name into the File Explorer dialog box and click Save.

Now your new title block will be available when you navigate to File > New PDF from Template… to start a new sketch.

For more information about how to save a new template to a shared drive, please see this article.

How-To

Revu 20

Revu 2019

Revu 2018

Revu 2017 & Below

Tips & Tricks

PDF Management

Drawing Management

In Revu, AEC professionals can create and save title block templates for easy access when creating new sketches.

Related Articles