Rendering issues in Revu

This article applies to:

  • Revu 21
  • Revu 20
  • Revu 2019

Problem

When working in Revu, the program crashes, freezes, or the document tab appears blank.

Cause

Revu 2019 introduced hardware-accelerated rendering for 2D drawings, which is the default rendering engine in Revu.

Issues can occur when:

  • a computer’s graphics processing unit (GPU) doesn’t meet our minimum hardware requirements
  • a GPU driver is out of date.

Solutions

Confirm that your GPU meets our minimum hardware requirements. Visit your GPU or graphics card manufacturer’s website to ensure it supports OpenGL 3.2 (or above) or OpenGL ES 3.0 (or above).

If your hardware meets requirements

Update the GPU drivers if the manufacturer provides one with OpenGL support. If you’re still experiencing rendering issues, please contact us.

If your hardware does not meet requirements

Set the Revu rendering engine to Software; this will use the Skia Graphics engine instead of the GPU.

To set rendering to Software:

  1. Open Revu.
  2. Go to Revu > Preferences (Ctrl+K).
  3. In the sidebar, click Advanced and then 2D Rendering at the top.
  4. Click Rendering Engine and select Software.
  5. Click OK.

If you’re still experiencing issues, please contact us.

Troubleshooting

Revu 2019

Revu 20

Revu 21

Performance

When working in Revu, the program crashes, freezes, or the document tab appears blank.

Related Articles