Revu for iPad Compatibility

Software compatibility

Revu for iPad requires iPadOS 9.0 or later.

On iPadOS 14.2 and later, Revu for iPad won’t open after being deployed through mobile device management (MDM) tools, such as Jamf or AirWatch. This is a known issue with Xamarin and MDM deployments on iPadOS 14.2. Users who need to deploy Revu for iPad are urged not to upgrade to iPadOS 14.2 at this time. Learn more in this help article.

Hardware compatibility

The following devices are compatible with Revu for iPad. This chart includes all WiFi, cellular, and screen size variations of each iPad.

iPad iPad Air iPad Mini iPad Pro
iPad (8th generation) iPad Air (4th generation) iPad Mini (5th generation) iPad Pro (4th generation)
iPad (7th generation) iPad Air (3rd generation) iPad Mini 4 iPad Pro (3rd generation)
iPad (6th generation) iPad Air 2   iPad Pro (2nd generation)
iPad (5th generation)     iPad Pro (1st generation)

Related Articles