Revu hangs or freezes when opening a PDF

This article applies to:

  • Revu 20
  • Revu 2019
  • Revu 2018

Problem

Revu hangs, freezes, or causes UI problems on some Dell/Alienware computers running the Alienware Command Center (AWCC) application. This issue is most likely to occur on machines equipped with an external graphics card (e.g. NVIDIA GeForce) and an external monitor set as the non-primary display.

Users running the Alienware Command Center application might also be experiencing graphical issues, such as blurred and garbled text, or certain elements skewed out of proportion. If you’re experiencing such issues, please see Graphical issues in Revu menus and interface.

Cause

At this time, our investigation has found that these issues are most likely related to how the Alienware Command Center interacts with graphics card drivers. Monitoring and/or performance hooks may be injected into the graphics card drivers, which cause rendering or graphical issues on secondary monitors. 

Solution

Update to latest version of AWCC

Launch the AWCC application on your system. You should be prompted to install the latest update. After updating, reboot your system and note if the issue persists. 

Uninstall AWCC from your system

If updating to the latest version of AWCC did not resolve your issue, consider uninstalling the AWCC application from your system. When uninstalling, be sure to uninstall Alienware Command Center, Alienware Command Center Suite, and Alienware OC Controls (as shown in image below).

After uninstalling the AWCC application(s), reboot your system and note if the issue persists.

Enable Software Rendering

If the problem continues after attempting the solution(s) above, enabling Software Rendering may resolve this issue. Revu can render documents using Software Rendering and Hardware Rendering. Because Hardware Rendering generally offers better performance, it’s enabled by default. For this reason, we don’t recommend disabling Hardware Rendering in most cases.

To enable Software Rendering:

  1. Go to Revu > Preferences (Ctrl+K).
  2. Click Advanced in the sidebar. 
  3. In the 2D Rendering tab, select Software from the Rendering Engine dropdown menu, and press OK.

If neither of the suggested workarounds solve this issue, please contact us.

If Revu is hanging, freezing, or has UI issues, read this article to learn about a workaround.

Troubleshooting

Revu 20

Revu 2019

Revu 2018

Performance

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