“Keep me signed in” is no longer an option in Studio

Applies to:

  • Revu 21
  • Revu 20
As of June 28, 2023, support for Revu 2019 & below has reached End of Life. Having trouble accessing Studio? Click here to find out more.

Problem

“Keep me signed in” / “Remember me” is no longer available when you log into Studio.

In the latest version of Revu, Studio users accessing the U.S. server (studio.bluebeam.com) will automatically stay signed in. If you’re working with an older version of Revu or in a region outside the U.S., you’ll need to reenter your BBID credentials when re-accessing Studio.

Cause

We recently updated the BBID sign-in page and removed the “Keep me signed in” / “Remember me” option. This is due to updates in our user-identity service, which required implementation of the latest authentication protocols. Now, client-side Revu updates are required to maintain and refresh authentication tokens to Studio, which will ultimately allow you to stay signed in.

Revu 20.2.60 and onward will include the necessary client-side support for our new authentication protocols, and users can remain logged into Studio securely when accessing it from the same device.

Due to these required updates, Revu 20.2.50 & below won’t automatically authenticate you on subsequent logins or retain your credentials.

Currently, there’s no function to disable automatic re-authentication in the latest version of Revu. If you and your team work within stricter security settings where staying logged in may not be favorable, we recommend manually signing out of Studio when finished.

Troubleshooting

Revu 2017 & Below

Revu 2018

Revu 2019

Revu 20

Revu 21

Studio

“Keep me signed in” is no longer an option when signing in with a BBID, meaning Studio will not login automatically.

 

Related Articles