The edge is cut off when creating PDFs from AutoCAD | Revu 2017 & below

Problem

When creating PDFs with the Bluebeam® plugin for AutoCAD®, the PDF edges are clipped.

Relevant Products

Bluebeam® Revu® CAD and eXtreme

AutoCAD®


Why is this happening?

The printable area for each page size is defined in the .pc3 files of the Bluebeam plugin, which may not be set correctly for your PDF. These settings can be changed using the AutoCAD Plotter Configuration Editor.

Although it isn’t recommended that you modify these files, the advanced user may choose to do so. We strongly recommend backing up the original .pc3 files before making any edits.

The .pc3 files for the Bluebeam plugin for AutoCAD were created using the AutoCAD Plotter Configuration Editor. These .pc3 files were created specifically for the plugin and cannot be used from the AutoCAD Print dialog. The files included with Revu are listed below:

Plugin using Printer Driver
AutoCAD 2010 and above Bluebeam PDF10 Printer HighRes.pc3, Bluebeam PDF10 Printer MedRes.pc3
Plugin using Heidi Driver
AutoCAD 2010 and above Bluebeam PS10 HighRes.pc3, Bluebeam PS10 MedRes.pc3
Plugin creating DWF output
AutoCAD 2010 and above Bluebeam DWF10.pc3
Folder containing PC3 files
Revu 2016, 2017, and 2018 C:\ProgramData\Bluebeam Software\Bluebeam Revu\2018\Pushbutton PDF\AutoCAD\PC3 (where 2018 is the Revu version)
Revu 10 to 2015 C:\ProgramData\Bluebeam Software\Bluebeam Revu\Pushbutton PDF\AutoCAD\PC3
Revu 9 and previous C:\Users\All Users\Bluebeam Software\Pushbutton PDF\AutoCAD\PC3

The ProgramData folder is normally hidden by default. Please do the following if you don’t see it:

In Windows 10 and 8.1 – Click the View tab in Windows Explorer and fill in the Hidden items checkbox. When the Folder Options dialog opens, click the View tab and then enable the “Show Hidden Files, Folders and Drives” option.

In Windows 7 SP1 and Vista – Click Organize > Folder and Search Options. When the Folder Options dialog opens, click the View tab and then enable the “Show Hidden Files, Folders and Drives” option.

To Make Changes:

  1. Edit the PC3 file.
    1. Exit AutoCAD.
    2. In Windows Explorer, navigate to the folder containing the .pc3 files (see above).
    3. Double-click on the .pc3 file you want to edit, and the Plotter Configuration Editor will open.
    4. Click the Device and Documentation Settings tab.
    5. In the list, click Modify Standard Paper Sizes (Printable Area).
    6. In the Modify Paper Standards list, select the page size to edit.
    7. Click Modify, and change the values.
    8. Click Next, then Finish.
    9. Repeat for the other page sizes.
    10. Click OK to save the changes and close the Plotter Configuration Editor.
  2. Rebuild the AutoCAD page sizes.
    1. Go to Start > All Programs > Bluebeam Software > Bluebeam Administrator.

      In Windows 10 and 8.1, click or press Start  and type Bluebeam Administrator.

      -Or-

      Go to Help > Administrator in Revu.

    2. Click the AutoCAD Page Sizes tab.
    3. Click Clear and then Rebuild.
    4. Click the Plugins tab.
    5. Uncheck the AutoCAD box and click Apply.
    6. Check the AutoCAD box and click OK.
    7. Restart AutoCAD.

Make your changes and then create some PDF files using your existing drawings to test your changes.

Because the settings are stored on a per page-size basis, the margins must be changed individually for each page size.

Remember that these changes affect all PDF files created with the Bluebeam plugin for AutoCAD. If you need to contact Bluebeam Support, please let us know if you’ve made changes to your page sizes.

These changes do not affect the Bluebeam PDF printer. PC3 files for the Bluebeam PDF printer and plugin using the printer driver cannot be shared between computers or stored in a common location on a network.

Additional custom page sizes can be created for the plugin and Bluebeam PDF printer using the Bluebeam Administrator.

Related Articles