Installationsguide for Bluebeam® Revu® 21

revu
Implementeringsvejledning for Bluebeam® Revu® 21

Denne artikel gælder for:

  • Revu 21

Gå til andre versioner:

Download installationspakker (MSI)

Inden du fortsætter, skal du sørge for at downloade 64-bit udgaven af installationspakken. Disse pakker indeholder alt, hvad du skal bruge for en vellykket implementering. Se Planlæg installationen for at få en oversigt over komponenterne i disse pakker.

Download Revu 21

Download 64-bit

Leder du efter en ældre version?

Introduktion

Typisk står store organisationer over for en lang række udfordringer, såsom at finde den mest effektive implementeringsmetode og korrekte konfiguration af et program til brug i netværksbaserede flerbrugermiljøer. På de følgende sider har vi præsenteret retningslinjer for planlægning og implementering af din Bluebeam Revu-installation.

Denne vejledning er skrevet til it-administratorer under antagelse af, at læseren har en god forståelse af grundlæggende begreber, såsom softwareinstallation, Windows-kommandolinjen samt skrivning og kørsel af batchfiler.

Du kan finde retningslinjer for administration af installationen efter implementering i Administrationsvejledningen for Revu 21.

Nyheder i Revu 21

Registreringsprocessen:

  • Det er ikke længere nødvendigt at medsende et serienummer eller en produktnøgle under implementeringen. Som følge heraf skal der ikke medtages nogle påkrævede egenskaber i dit script.
  • Egenskaben Delayed Authorization (DA=1) er ikke længere påkrævet.
  • Det er ikke nødvendigt at oprette forbindelse til licensserveren under installationen. På grund af denne forbedring har vi fjernet behovet for at registrere/afregistrere softwaren. Du kan ikke længere finde knappen Registrering i Revu-menuen eller kommandolinjeindstillingerne i administratoren.

Fra og med Revu 21 kræves der ikke længere internetadgang under installationen:

  • Du kan bruge SYSTEM-kontoen, når du installerer via SCCM.
  • Da vi nu har en abonnementsmodel, logger brugerne ind på Revu efter installationen, så det korrekte abonnementsniveau kan træde i kraft.

Andre større ændringer i Revu 21:

  • Behovet for markeringstilstand og visningstilstand er ikke til stede, da funktionerne og funktionaliteten nu bestemmes af abonnementsniveauet, der logges ind på.
  • På grund af enkelheden ved abonnement og implementering har vi elimineret behovet for konfigurationseditoren.
  • Da vi er gået væk fra Revu Editions og over på en abonnementsmodel, er behovet for ARP-modifikatoren og den valgfrie kontrol før installationen blevet fjernet.

Planlæg installationen

Kompatibilitet og systemkrav

De nyeste kompatibilitetsoplysninger findes i Bluebeam Revu 21 Kompatibilitet og systemkrav.

Administrationsvejledning for Revu 21

Administrationsvejledning for Revu 21 omhandler forskellige emner efter installationen såsom Bluebeam Administrator Console-programmet, Revu-præferencer og -indstillinger, administration af abonnement, Bluebeam Studio samt elektroniske og digitale underskrifter.

Virksomhedsimplementeringspakkerne

Installationsprogrammet bruger Microsoft Windows Installer framework (msiexec.exe), så det er meget vigtigt, at den korrekte Windows Installer-version allerede er installeret på dine maskiner.

MSI-pakken

Du skal bruge denne fil til at implementere en fuld installation af Revu.

Det er meget vigtigt, at du downloader den korrekte installationspakke til dit miljø. Når du har gjort dette, skal du åbne .zip-filen og gøre dig bekendt med indholdet, som er:

  • En ReadMe-fil med en oversigt over indholdet af MSI-pakken og installationsforudsætningerne.
  • Revu MSI-installationsfilen
  • OCR MSI-installationsfilen. Fra og med Revu 20 blev OCR-modulet adskilt fra Revu MSI og er nu et separat installationsprogram.
  • Offlineinstallationsprogrammet til Microsoft .NET Framework 4.8. .NET Framework 4.8-installationen under Windows 10 kræver enten Windows 10 Anniversary eller Windows 10 Creators Update. For yderligere oplysninger henvises til Microsofts hjemmeside.
    .NET Framework 4.8 er også inkluderet i Windows 11-installationer.
  • En Visual C ++ Redistributable til Visual Studio 2022. Hvis dette ikke allerede er installeret på maskinerne, skal det implementeres, før MSI’en udrulles.
  • Et script til fjernelse af ældre Revu-versioner. (Uninstall Previous Version.txt – Skift filtypen til .bat, før du kører den. Når filen er ændret fra en tekstfil til en batchfil, skal du køre den med administratorrettigheder. Denne batchfil afregistrerer og afinstallerer Revu (enhver version) på maskinen).
  • En SharePoint-udvidelse. Understøttes på SharePoint 2019 eller nyere lokale servere og SharePoint Online-forekomster (Office 365).
  • Et SharePoint-tilføjelsesprogram. Understøttes på SharePoint 2013 eller nyere lokale servere og SharePoint Online-forekomster (Office 365).

Du kan få mere at vide om installation af Bluebeam SharePoint-integrationsappen i et SharePoint-miljø under Installation af SharePoint-integrationsappen.

Afinstallationsscriptet for hver mindre opdatering vil kunne fjerne enhver tidligere udgivelse, men er IKKE påkrævet, hvis du opdaterer til en mindre udgivelse inden for den samme version. Det betyder, at alle fremtidige MSI-opdateringer til Revu 21 kan køre oven på den tidligere Revu 21-installation.

Brugerdefinerede indstillinger og aktiver

Hvis din organisation bruger brugerdefinerede eller delte indstillinger og aktiver, f.eks. præferencer, profiler, værktøjssæt og stempler, skal du læse Administrationsvejledningen for Revu 21 for at få de bedste fremgangsmåder til eksport, indsamling og staging af disse elementer.

Opsætning af en staging-computer

Hvis du har brug for at oprette brugerdefinerede indstillinger og aktiver som nævnt ovenfor, skal du installere Revu manuelt på en maskine, så du kan oprette og stage disse aktiver som beskrevet i afsnittet Kontrolleret netkonfiguration i Administrationsvejledningen for Revu 21.

Til denne ene installation kan du downloade installationsprogrammet fra vores Download-center.

Implementeringsprocessen

Bedste praksis

Før vi kommer ind på de faktiske trin i implementeringsprocessen, er der nogle vigtige detaljer, der skal overvejes:

For at undgå potentielle opdateringsproblemer, mens du planlægger en ny implementering, er den bedste praksis at beholde din tidligere MSI-fil på dens oprindelige placering.
  • Følg instruktionerne nøje. Tag ikke genveje, og lav ikke ændringer i forløbet.
  • Bluebeam understøtter ikke manuel redigering af MSI-filen, da det vil ugyldiggøre filernes digitale signatur.
  • Hvis du opgraderer til Revu 21 fra en allerede eksisterende installation af en ældre Revu-version, skal du først fjerne den ældre software ved at udsende scriptet “Uninstall Previous Version”, der er inkluderet i Revu 21 MSI-installationspakken.
  • Sørg for at køre afinstallationsscriptet med administratorrettigheder.
    Hvis du bruger SCCM, kan scriptet Afinstaller tidligere version udsendes gennem en opgaverækkefølge. Se dokumentationen til Microsoft SCCM, hvis du har brug for hjælp til SCCM-processen.
  • Vi anbefaler på det kraftigste, at du opretter en pilotgruppe af slutbrugere til at teste nye Revu-versioner, før du implementerer den i hele din organisation.
MSI-filen skal køres med administratorrettigheder, uanset om den anvendte konto er en del af den lokale maskines administrative gruppe. Windows 10-brugere kan læse Windows Kontrol af brugerkonti for reference.
  • Brug af Microsoft SCCM

    Fra og med Revu 21 kræves der ikke længere internetadgang under implementering. På grund af dette kan du vælge Install for user​ eller Install for SYSTEM (SYSTEM-konto), når du opretter en MSI-installationspakke.

Implementeringsværktøjer

Uanset hvilken pakke eller hvilket installationsværktøj du bruger, starter dit kommandolinjescript Windows Installer (msiexec.exe) under installationen.

Der er forskellige installationssværktøjer, der bruger kommandolinjen til at køre et MSI-installationsprogram, såsom System Center Configuration Manager (SCCM), Quest KACE (tidligere Dell KACE) og Microsoft Windows Group Policy.

Det er vigtigt at bemærke, at vi kun yder support til brugen af kommandolinjescripts og ikke selve implementeringsværktøjerne.

Installation af OCR-modulet

For at gøre fremtidige opdateringer hurtigere leverer vi OCR-modulet i en separat MSI-fil adskilt fra Revu-applikationen. Både Revu MSI-filen og OCR MSI-filen er inkluderet i de installationspakker, der findes på vores websted.

Hvis du ønsker, at brugerne skal kunne drage fordel af visse Revu-funktioner, der bruger tekstgenkendelse, f.eks. OCR, AutoMark, Sets og Batch Link, skal du installere OCR MSI-filen.

Hvis OCR MSI-filen ikke installeres af en administrator, eller hvis en bruger afinstallerer den, vil Revu stadig fungere. Brugerne vil dog ikke være i stand til at bruge nogen af de funktioner, der er beskrevet ovenfor. For at løse sådanne problemer kan OCR-modulet installeres når som helst.

Revu MSI-filen og OCR MSI-filen kan implementeres i vilkårlig rækkefølge. Den ene er ikke afhængig af den anden. Når du opdaterer Revu til en ny mindre udgivelse, behøver du ikke at geninstallere OCR-modulet, hvis det blev installeret i din første installation. I denne situation behøver du kun at implementere Revu MSI-filen.

For at forenkle opdateringsprocessen og holde filstørrelsen på et minimum leveres OCR MSI-filen ikke via In-App Updater. Da OCR-modulet sjældent ændres, leverer Bluebeam kun en opdatering med hver større udgivelse.

OCR-pakken har ingen specielle parametre ud over standard msiexec-muligheder. Her er et eksempel på en lydløs installation af 64 bit OCR MSI:

msiexec.exe /i "[path to deployment folder]\BluebeamOCR x64 21.msi" /qn

Når du bruger batchfilen Afinstaller tidligere version, fjernes både Revu- og OCR-installationsprogrammerne. Men hvis du afinstallerer fra Kontrolpanelet, vises Revu og OCR som separate elementer og skal afinstalleres individuelt.

Hvis du foretager fejlfinding af en enkelt maskine og geninstallerer ved hjælp af Suite .exe, bliver OCR installeret automatisk.

Tabel over Revu MSI-egenskaber

Tabellen MSI-egenskaber viser de egenskaber, der giver dig mulighed for at konfigurere og tilpasse Revu-installationen. Fra og med Revu 21 er der ikke længere nogen påkrævede egenskaber til installation. Herunder finder du de understøttede valgfrie egenskaber.

Understøttede valgfrie egenskaber

BB_AUTO_UPDATE Aktivér eller deaktiver opdateringsmeddelelser i appen: Aktiveret (standard) = 1, Deaktiveret = 0. Se bemærkninger.
BB_DISABLEANALYTICS Aktivér eller deaktiver afsendelse af oplysninger om programbrug til Bluebeam. Send (standard) = 0, send ikke = 1. Se bemærkninger.
BB_DEFAULTVIEWER Indstil som standardapplikation (standard) = 1, Skift ikke standard = 0. Se bemærkninger.
BB_DESKSHORTCUT Skrivebordsgenvej til Bluebeam Revu (standard) = 1, Ingen genvej = 0
BB_DESKSTAPLER Skrivebordsgenvej til Bluebeam Stapler = 1, Ingen genvej (standard) = 0
BB_FEATURES Deaktiverer forskellige Revu-funktioner: Alle funktioner aktiveret = 65535 (standard). Find flere oplysninger i afsnittet Aktivering og deaktivering af Revu-funktioner.
BB_IE_PLUGIN Installer og aktiver = 1, Deaktiver (standard) = 0
BB_JOBOPTIONS Indtast UNC eller fuldstændig sti til din brugerdefinerede .jobOptions-fil.
BB_NETCONFIG Indtast UNC eller fuldstændig sti til din Netkonfigurationsmappe.
BB_PAGESIZE Indtast “A4” for at tilsidesætte standardsidestørrelsen for Bluebeam PDF-printeren.
DISABLE_WELCOME

Deaktiverer Revu HTML-velkomstsiden og siden Træningsvideoer om arbejdsgange. Aktivér (standard) = 0, deaktiver = 1

Opretter en post i registreringsdatabasen Computer\HKEY_CURRENT_USER\Software\Bluebeam Software\20\Revu og DWORD med navnet WorkflowsInitialized“.

BB_REVUPREFERENCES Indtast UNC eller fuldstændig sti til filen RevuPreferences.xml
IGNORE_RBT Deaktiver kontrol for afventede genstart = 1, Kontrol for afventende genstart = 0. Se bemærkninger.
MBCODE Bestemmer, hvilke Bluebeam-plugins der er aktiveret. Standardværdien på 1023 aktiverer dem alle. Se Aktivering af Bluebeam-plugins med MBCODE for at få flere oplysninger
Egenskaben BB_AUTO_UPDATE

Egenskaben BB_AUTO_UPDATE er som standard slået til. Når den er aktiveret, modtager brugere en besked i appen, når der er en ny Revu-opdatering tilgængelig. Hvis du ikke ønsker, at dine brugere skal modtage en notifikation i appen, når en ny version udgives, skal du deaktivere denne egenskab.

Egenskaben BB_DISABLEANALYTICS

Revu sender som standard brugsdata til Bluebeam for at hjælpe med at forbedre applikationen. De oplysninger, du giver, hjælper os med bedre at forstå brugsadfærd og tendenser, så vi kan fortsætte med at forbedre vores produkter og tjenester. Alle indsendte oplysninger er anonyme og deles ikke med tredjeparter. Bluebeam indsamler ikke personlige oplysninger om dig. Hvis du vil deaktivere dette, skal du installere dine installationer med egenskaben BB_DISABLEANALYTICS indstillet til en (BB_DISABLEANALYTICS=1) i dit MSI-kommandolinjescript eller MST-fil.

Brugere, der åbner Revu 21 for første gang, vil se et nyt vindue kaldet “Fortæl os om dig selv”, der beder om nogle grundlæggende kundeoplysninger.

Hvis du vælger at deaktivere afsendlese af brugsdata med BB_DISABLEANALYTICS= 1, vil dette også undertrykke vinduet “Fortæl os om dig selv”. Du kan finde flere oplysninger om de data, vi indsamler, i Bluebeams privatlivspolitik.

Indstilling af standard PDF-program med BB_DEFAULTVIEWER

Microsoft har ændret, hvordan standardapplikationer vælges i Windows 8 og nyere, hvilket resulterer i, at egenskaben BB_DEFAULTVIEWER tilsidesættes. Det betyder, at dine brugere bliver nødt til at følge trinnene i Ændring af standard PDF-fremviseren. For yderligere oplysninger henvises til Microsofts hjemmeside.

Aktivering og deaktivering af Revu-funktioner med BB_FEATURES

Hver Revu-funktion har en tildelt numerisk værdi som vist i nedenstående tabel. Hvis du vil deaktivere en funktion, skal du trække dens numeriske værdi, der er vist i tabellen over Understøttede valgfrie egenskaber ovenfor, fra standardværdien for egenskaben BB_FEATURES (65535) og angive svaret som den nye værdi for egenskaben BB_FEATURES.

Hvis du f.eks. vil deaktivere funktionen Redigering, skal du trække værdien af denne funktion (2) fra 65535 og derefter angive saldoen (65533) som den nye værdi for BB_FEATURES.

Revu-funktioner og deres numeriske værdier:

Administrator Button (Revu Menu) = 128 Product Updates Button (Help menu) = 16
AllFeatures = 1023 Redaction Cut Content & Erase Content = 2
DigitalSignatures = 4 SelfSignCertificates = 8
EditText = 1 TranslateMarkups = 32
ExportToOffice = 64 Session Following Feature = 512
Flere oplysninger om funktionen Følg session (Session Following Feature)

Nogle brugere kan have brug for muligheden for at forhindre andre brugere i at følge dem i en Studio-session for at overholde reglerne om beskyttelse af personlige oplysninger og arbejdsrelateret lovgivning. Følgende scenarier illustrerer, hvad der sker, når denne funktion er slået fra:

Bruger X forsøger at følge Bruger Y
– Bruger X’s skærm vises stadig, som om de følger Bruger Y, men de vil ikke modtage nogen positionsopdateringer fra Bruger Y.

Bruger X sender en “Følg mig”-anmodning til alle brugere
– Bruger Y får ikke vist anmodningsdialogboksen

Bruger Y forsøger at følge Bruger X
– Bruger Y vil ikke være i stand til at følge en anden bruger (alle grænsefladeelementer vedrørende sessionsfølgning vises ikke)

Deaktivering af “Tjek for afventende genstart”

Installationsprogrammet indstiller som standard egenskaben IGNORE_RBT til 0. Når MSI-filen startes, kontrollerer installationsprogrammet, om der er en afventende genstart på maskinen. Installationen stoppes ved både IGNORE_RBT = 0, og hvis der er en afventende genstart. Hvis egenskaben IGNORE_RBT=1 indstilles, stoppes installationen ikke, selv ikke med en afventende genstart. Uden dette flag stopper installationen, hvis en bruger ikke genstarter, når der anmodes om det.

Derudover giver en Microsoft-parameter kaldet REBOOT = ReallySuppress dig mulighed for at styre, hvornår en maskine genstarter.

I henhold til bedste praksis skal du afslutte alle aktive programmer og browsere for at sikre en større sandsynlighed for, at undertrykkelsen lykkes. For at Revu kan fungere korrekt, skal den afventende genstart ske på et tidspunkt, efter at installationen er fuldført.

Aktivering af Bluebeam-plugins med MBCODE

Hvert Bluebeam-plugin til understøttelse af tredjepartssoftware har en tildelt numerisk værdi, som vist i nedenstående tabel. Hvis du kun vil aktivere et enkelt plugin – for eksempel pluginet til AutoCAD – skal du erstatte standardværdien for MBCODE på 1023 (alle plugins aktiveret) med tallet 2. I tilfælde, hvor du har brug for at aktivere mere end et plugin, lægger du deres numeriske værdier sammen og indtaster totalen som den nye MBCODE-værdi. Ændring af værdien til 0 deaktiverer alle plugins.

Bluebeam-plugins aktiveres kun, hvis tredjepartsprogrammet er installeret. Se Revu-kompatibilitetsoversigten for at sikre, at dine tredjepartsprogrammer understøttes.

Revu-plugins og deres numeriske værdier

Alle plugins deaktiveret = 0 Microsoft Outlook = 128
AutoCAD = 2 ProjectWise = 64
AutoCAD LT (32 & 64-bit) = 4 Revit & Navisworks = 16
Internet Explorer = 32 SolidWorks = 8
Microsoft Office = 1  

Ændring af sprog

Du kan implementere installationer på et andet sprog end Windows-standarden ved at angive egenskaben TRANSFORMS til en af de sprogkoder, der er angivet nedenfor. Ellers installeres Revu på det sprog, der bruges af værtsoperativsystemet.

Eksempler på kommandolinjer for MST- og MSI-installationer kan findes senere i denne vejledning.

Koder til ændring af sprog i Revu:
Dansk = 1030 Italiensk = 1040
Hollandsk = 1043 Japansk = 1041
Engelsk = 1033 Koreansk = 1042
Finsk = 1035 Norsk = 1044
Fransk standard = 1036 Spansk = 1034
Tysk = 1031 Svensk = 1053

Implementeringsmetoder

Dette afsnit dækker emner som Windows Installer-parametre, og hvordan du skriver scripts til MSI-installationer.

En bemærkning om Windows Installer-parametre

Der er tre vigtige Windows Installer-parametre, du skal være opmærksom på, når du skriver et script til MST- eller MSI-installationer:

Beder Windows Installer om at bruge msiexec.exe til at køre en installation

/i

Denne parameter giver dig mulighed for at køre uovervågede og lydløse installationer

/qn

Bruges, hvis du har oprettet en MST, der skal hentes. Dette gøres ved at indtaste mappestien til, hvor MST-filen er placeret, og filnavnet på MST-filen. TRANSFORMS giver dig også mulighed for at installere Revu på forskellige sprog.

TRANSFORMS

Sådan skrives et installationsscript

Lad os se på de forskellige metoder til implementering af Revu, som hver især bruger kommandolinjen på lidt forskellige måder.

Brug af en MST-fil (Microsoft Transform)

En Microsoft Transform-fil (MST) giver dig mulighed for at minimere typografiske fejl, da alle egenskabs-/parameterændringer udføres i MST-filen, som kaldes af et kort kommandolinjescript. Det betyder, at du kan dobbelttjekke dine ændringer i tabellen Egenskaber, før de videregives under installationerne.

Vigtig bemærkning om Tranforms

Scenarie 1: TRANSFORMS vedrørende sprog

Når du bruger TRANSFORMS til sprog, skal MST-filen være i samme rod som MSI-filen. Brug ikke en sti til MST-filen. Kun MST-filens navn. Der må heller ikke være mellemrum i navnet på MST-filen og INGEN anførselstegn omkring MST-filnavnet.

TRANSFORMS=:1031;MyTransforms.mst
TRANSFORMS=:1031;<angiv ingen sti til mst-filen, kun mst-filens navn>

Scenarie 2: Standard TRANSFORMS

Når du bruger TRANSFORMS, skal MST-filen være i samme rod som MSI-filen. Brug anførselstegn omkring stien til MST-filen.

TRANSFORMS="C:\Deployment Folder\MyTransforms.mst"
TRANSFORMS=<sti med anførselstegn til mst-filnavnet>
Oprettelse og redigering af en MST-fil

Hvis du ikke allerede har gjort det, skal du downloade og installere en MSI-editor som InstEd. Når du har gjort det, skal du følge nedenstående trin:

  1. Start InstEd, klik på menuen File, og åbn den originale MSI-fil.
  2. Klik på menuen Transform, og vælg New Transform.
  3. Når dialogboksen New Transforms åbnes, skal du navngive MST-filen og derefter klikke på Save.
    Filen ikke kaldes “Transforms.mst”, og den skal gemmes i samme mappe som det originale MSI-installationsprogram.
  4. Klik på fanen Tables til venstre, vælg Property på listen Tables. På dette tidspunkt kan det hjælpe at klikke på kolonneoverskriften Property for at sortere listen Properties alfabetisk.
  5. Rediger egenskaberne, så de passer til dine behov.
    Rediger IKKE andre egenskaber end dem, der er angivet i MSI-egenskabstabellen
  6. Klik på menuen File, og gem filen.
Sådan skriver du et kommandolinjescript, der bruger din MST-fil

Her er et par eksempler på installationsscripts, der kalder en MST-fil:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=YourMSTFile.mst /qn

En lydløs tysksproget installation:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=:1031;MyTransforms.mst /qn

Det er meget vigtigt, at du tester dit script i en kommandoprompt med administratorrettigheder på en testmaskine, før du implementerer installationen, for at sikre, at den kører korrekt.

Du må ikke dobbeltklikke på MSI-filen. Hvis du gør det, installeres Revu uden de påkrævede administratorrettigheder og eventuelle tilpasninger, du har angivet i MSI-egenskaberne.
Brug af MSI-egenskaberne direkte

En anden metode til at opbygge din implementering er at skrive et komplet installationsscript, der kalder Revu MSI-filen og angiver alle egenskabsændringer.

Værdier for en MSI-parameter (markeret med en forlæns skråstreg) skal være omgivet af anførselstegn som vist nedenfor. For Bluebeam-specifikke egenskaber skal mellemrum erstattes af spørgsmålstegn.
Før du laver en implementering af Revu, anbefaler vi, at du skriver og korrekturlæser dit script i en teksteditor og kører det på en testmaskine i en kommandoprompt med administratorrettigheder.

Eksempler på MSI-scripts

Du kan få en bedre idé om, hvordan kommandolinjescripts kan skrives til forskellige installationskrav og konfigurationer, i følgende eksempler:

Grundlæggende lydløs installation, der også implementerer en specifik RevuPreferences.xml

Bemærk forskellen i stiangivelse mellem .msi- og .xml-filen:

msiexec.exe /i "\\MyServer\Bluebeam?Deployment\Bluebeam Revu x64 21.msi" BB_REVUPREFERENCES=\\MyServer\Bluebeam?Deployment\RevuPreferences.xml /qn

Script, der lydløst kombinerer OCR MSI-filen og Revu MSI-filen ved hjælp af en TRANSFORMS-fil:

START /WAIT msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\BluebeamOCR x64 21.msi" /qb && msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.msi" TRANSFORMS="C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.mst" /qn

Kørsel og fejlfinding af en implementering

Forudsat at du har skrevet dit script og afprøvet det i en kommandoprompt med administratorrettigheder på en testmaskine, kan du nu køre det i et installationsværktøj efter eget valg, f.eks. SCCM, Dell KACE eller Group Policy.

Hvis installationerne ikke går efter hensigten eller på anden måde fejler, skal du gå tilbage og kontrollere dit arbejde. Hvis dit script åbner en MST-fil, skal du åbne den med MSI-editoren igen og sørge for, at du har indstillet egenskaberne korrekt.

Når du har bekræftet, at du har brugt den korrekte syntaks i scriptet, skal du validere det igen ved hjælp af en kommandoprompt med administratorrettigheder på en testmaskine.

MSI-installationsprogrammet opretter en detaljeret logfil i mappen %TEMP% på det lokale drev på den maskine, som Revu er installeret på. Navnet følger mønsteret MSIxxxxx.log“, hvor xxxxx” er tilfældige tegn såsom MSIjfb1d6.log.” Gennemgå denne log for almindelige Windows-installationsfejl.

Hvis du bruger SCCM, kan logfilen findes i C:\windows\temp. Installationen foregår via SYSTEM-kontoen.
En liste over Windows Installer-fejlkoder og deres definitioner på Microsofts websted.
 

Sådan opdateres eksisterende installationer

Den nye MSI-proces fjerner den aktuelt installerede version af Revu 21 og erstatter den med den nyeste Revu 21-opdatering, som du implementerer. Processen kræver heller ikke geninstallering af OCR MSI-filen. Da OCR-modulet ikke er nødvendigt i efterfølgende Revu 21-opdateringer, bliver din Revu-installationspakke mindre.

Nedenfor er nogle eksempler på scripts, der kan bruges til at opdatere en eksisterende installation af Revu 21:

Indledende MSI-installation med valgfri parameter:

msiexec /i "Bluebeam Revu x64 21.0.0 msi" DISABLE_WELCOME=1 
Du skal angive alle de parametre, du oprindeligt gjorde med den første installation.

Opdater MSI-installation med valgfri parameter:

msiexec /i "Bluebeam Revu x64 21.0.X msi" DISABLE_WELCOME=1

Efterinstallation: Valgfri implementering af tilpasning

Bluebeam Administrator-konsollen

Med administratorprogrammet (PbMngr5.exe) kan du udføre følgende funktioner efter installationen via kommandolinjen i Windows:

  • Installere plugins
  • Geninstallere/afinstallere vores Bluebeam PDF-printer
  • Indstille standard-DPI for Bluebeam PDF-printeren
  • Konfigurere Netkonfiguration
  • Sikkerhedskopiér, nulstil, gendan Revu-brugerindstillinger

Du kan få flere oplysninger om de tilgængelige funktioner ved at tilgå hjælpeoplysningerne til PbMngr5.exe fra Windows Kommandoprompt ved at klikke på Start > Søg og skrive CMD.

Når kommandoprompten åbnes, skal du skrive cd “C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu efterfulgt af PbMngr5.exe /help og derefter Enter-tasten.
Alternativt kan du gå til Bluebeam Administrator-hjælp.

Revu-indstillinger

Der findes to Bluebeam-konfigurationsfiler med programindstillinger, som kan implementeres: Filen RevuPreferences.xml, som kan installeres når som helst, og UserPreferences.xml, som først kan installeres, når en ny Revu-installation er afsluttet.

RevuPreferences.xml

Denne fil indeholder alle indstillinger, der er konfigureret i dialogboksen Revu-indstillinger (Ctrl+K). Hvis du klikker på Eksporter i dialogvinduet, kan du gemme filen RevuPreferences.xml på en hvilken som helst placering, f.eks. en centraliseret mappe på en server.

Selvom den kan implementeres som en del af en MST-fil eller sendes som en MSI-kommandolinje, kan du også gøre det efter installationen ved hjælp af en kommandolinjeparameter, der kalder Bluebeam Administrator, som lader dig automatisere ændringer.

Her er et eksempel på, hvordan du udruller et opdateret sæt Revu-indstillinger, hvor alle plugins undtagen det til Internet Explorer skal forblive aktive:

"%ProgramFiles%\Bluebeam Software\Bluebeam Revu\21\Revu\PbMngr5.exe" /setup /PREFSPATH:"G:\Bluebeam Software\Settings\RevuPreferences.xml"

Du kan også kopiere eller sende filen RevuPreferences.xml til:

C:\ProgramData\Bluebeam Software\Bluebeam Revu\21\Revu
Når Revu starter, søger den efter RevuPreferences.xml. Når den finder ud af, at den er nyere end filen UserPreferences.xml i brugerens %appdata%-mappe, flettes indholdet ind i den eksisterende UserPreferences.xml. For at ændre filens dato skal du foretage en ændring af filen RevuPreferences.xml. Dette kan være så simpelt som at tilføje et mellemrum til starten af teksten.

Indstilling af et krav om offline-pinkode

Brugere kan konfigurere en offline-pinkode til at få adgang til Studio-filer, når de ikke har forbindelse til Bluebeam Studio. Selvom dette ikke er et standardkrav, kan det ændres under Studio-sektionen i RevuPreferences.xml på din staging-maskine. Det kan derefter eksporteres til en staging-placering på dit netværk. Dette er typisk den samme placering som den MSI-fil, du implementerer.

Ændringen i RevuPreferences.xml består af:

         <Studio> <RequireOfflinePIN>True</RequireOfflinePIN> </Studio>

Dette kan implementeres ved hjælp af MSI-filens egenskab BB_REVUPREFERENCES.

Når denne indstilling er angivet, kræves der oprettelse af offline-pinkode for alle nye og eksisterende Studio-brugere. De kan ikke logge på Bluebeam Studio uden at gøre det.

UserPreferences.xml

Denne fil indeholder indstillingerne for en individuel Revu-bruger. Selvom denne fil ikke kan implementeres i eksisterende installationer, kan den medsendes til en ny inden den første kørsel af programmet, ved at sende en ændret UserPreferences.xml til følgende placering på hver enkelt maskine:

C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu
Forudsat at du allerede har samlet dine brugerdefinerede aktiver, f.eks. profiler og værktøjssæt, mens du planlagde implementeringen, kan du også kopiere dem til denne placering.
Første gang Revu startes, kopieres filerne automatisk til følgende placering i deres roaming Windows-brugerprofil:
%APPDATA%\Bluebeam Software\Revu\21

Fletning af Revu-indstillinger

Hvis du kun vil tilføje nye indstillinger, skal du først åbne filen RevuPreferences.xml i en teksteditor og føje Merge=”True” til begyndelsen af filen som vist nedenfor, før du lægger den på staging-serveren til implementering. Se Administrationsvejledningen for Revu for at få flere oplysninger. Fletningsprocessen er en udskiftning af de data, der skal opdateres eller redigeres i filen RevuPreferences.xml.

Eksempel på en redigeret RevuPreferences.xml

Følgende sæt Revu-indstillinger indeholder en Revu-installation, der fletter disse indstillinger ind i en eksisterende UserPreference.xml-fil (Merge=”True”), og indeholder URL-adressen til en organisations SharePoint-server:

<?xml version="1.0" encoding="utf-8"?>
<RevuPreferenceDictionary Version="2" Merge="True">
<DocManSys>
<ActiveIndexx64.>0</ActiveIndexx64.>
<CacheSharePointFilesx64.>False</CacheSharePointFilesx64.>
<CheckcoutOnOpenFromHyperlinks.x64.0>False</CheckcoutOnOpenFromHyperlinks.x64.0>
<CheckcoutOnOpenFromHyperlinks.x64.1>False</CheckcoutOnOpenFromHyperlinks.x64.1>
<CheckoutOnOpen.x64.0>False</CheckoutOnOpen.x64.0>
<CheckoutOnOpen.x64.1>False</CheckoutOnOpen.x64.1>
<ClaimsSupported.x64.0>False</ClaimsSupported.x64.0>
<ClaimsSupported.x64.1>True</ClaimsSupported.x64.1>
<Countx64.>2</Countx64.>
<DefaultFileFilterPDF>True</DefaultFileFilterPDF>
<DocumentLibrary.x64.0></DocumentLibrary.x64.0>
<DocumentLibrary.x64.1></DocumentLibrary.x64.1>
<LastAccessedLibraryPath.x64.0>Test</LastAccessedLibraryPath.x64.0>
<LastAccessedLibraryPath.x64.1></LastAccessedLibraryPath.x64.1>
<LoginName.x64.0>sa</LoginName.x64.0>
<LoginName.x64.1>sa</LoginName.x64.1>
<PromptForCheckinCommentsx64.>True</PromptForCheckinCommentsx64.>
<PromptForCheckoutFromIEx64.>True</PromptForCheckoutFromIEx64.>
<RegKey.x64.0>SharePoint2007</RegKey.x64.0>
<RegKey.x64.1>SharePoint2007</RegKey.x64.1>
<SelectionDialogx64.>False</SelectionDialogx64.>
<SharePointUseExistingCookies>True</SharePointUseExistingCookies>
<Site.x64.0>http://sharepointserver1</Site.x64.0>
<Site.x64.1>http://sharepointserver2</Site.x64.1>
<SiteAlias.x64.0>SharePoint</SiteAlias.x64.0>
<SiteAlias.x64.1 />
<StoreLastAccessedFolderx64.>True</StoreLastAccessedFolderx64.>
<TestIfSharePointPathx64.>True</TestIfSharePointPathx64.>
<ToolbarIntegrationOnlyx64.>True</ToolbarIntegrationOnlyx64.>
<UseDefaultCredentialsx64.>True</UseDefaultCredentialsx64.>
</DocManSys>
</RevuPreferenceDictionary>

*Disse URL-adresser til SharePoint-servere ændres, når dataene flettes sammen med filen med Revu-indstillinger.

Implementering af brugerdefinerede udvidelser via Revu.exe på kommandolinjen

Kommandolinjeparametre for Revu.exe

Følgende parametre giver dig mulighed for at bestemme, hvordan importprocessen kører, og hvilke aktiver der skal kopieres til en lokal brugers standard Revu-roamingmappe %appdata%:

Når du importerer aktiver eller indstillinger, kopieres de som beskrevet ovenfor, hvorimod en “Tilføjelse” af dem opretter en reference (link) til et delt aktiv, der er placeret på et netværksdrev eller en anden ikke-standardplacering.
Når du opretter og eksporterer brugerdefinerede profiler, er det bedst at inkludere eventuelle afhængigheder, f.eks. brugerdefinerede værktøjssæt, skraveringsmønstre, stregtyper, brugerdefinerede kolonner eller brugerdefinerede statusser. Ved at indlejre dem i profilen på denne måde er det meget lettere at dele disse brugerdefinerede ressourcer på tværs af en organisation.
  • /bpximport:[Filnavn] – Importerer og aktiverer en profil.
  • /bpxdir:[Sti] – Giver dig mulighed for at angive en mappesti, hvis du vil angive en ny profilmappe. Dette er stien til en placering på et delt netværk, hvor profiler er placeret og delt på tværs af en organisation.
    Hvis du vil forhindre brugere i at foretage ændringer af profilerne i denne mappe, skal du indstille mappetilladelserne til “Skrivebeskyttet”.
  • /bpxactive:[Navn] – Angiver en bestemt profil som “Aktiv” i enten brugerens lokale Revu-roamingmappe %appdata% eller i en delt profil. Hvis du har brugt /bpxdir: til at angive en delt profilmappe på en netværksplacering, skal du sørge for, at den profil, du har angivet som Aktiv, findes i den angivne mappe.
  • /btxadd:[Filnavn] – Dette fortæller en Revu-installation, at den skal bruge et værktøjssæt, der er placeret på en placering, som ikke er standard, uden at importere det.
  • /btximport:[Filnavn] – Importerer et værktøjssæt til den aktuelle profilmappe.
  • /bhxadd:[Filnavn] – Beder Revu om at bruge et skraveringsmønster-sæt, der er placeret på en placering, som ikke er standard, uden at importere det.
  • /bhximport:[Filnavn] – Importerer et skraveringsmønster-sæt til den aktuelle profilmappe.
  • /blxadd:[Filnavn] – Beder Revu om at bruge en stregtype, der er placeret på en placering, som ikke er standard, uden at importere den.
  • /blximport:[Filnavn] – Importerer et stregtype-sæt til den aktuelle profilmappe.

Eksempler på anvendelse

Følgende script importerer lydløst Power Profile samt filerne toolset1.btx og dimensions.btx til den pågældende profil:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu\Revu.exe" /s /bpximport:"U:\netProfiles\Power.bpx" /bpxactive:Power/btximport:"U:\netProfiles\Revu\toolset1.btx" /btximport:"U:\netProfiles\Revu\dimensions.btx"
  • /s – Du kan se denne parameter i eksemplet ovenfor. Den deaktiverer alle meddelelser, der normalt vises på skærmen under importprocessen.
Parameteren /s gør ikke installationen “lydløs”.

Importerer en profil og gør den aktiv:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bpximport:"U:\Temp\Name_Profile.bpx" /bpxactive:Name_Profile

Importerer værktøjssæt:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /btximport:"U:\Temp\name_Toolset.btx"

Importerer skraveringsmønster:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bhximport:"U:\Temp\name_Hatch.bhx"

Importerer stregtype:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /blximport:"U:\Temp\name_Line.blx"

Bluebeam, Revu, and Bluebeam Studio are trademarks or registered trademarks of Bluebeam, Inc. Microsoft, SharePoint, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

AutoCAD is a registered trademark of Autodesk in the United States and/or other countries.

© 2020 Bluebeam, Inc. All Rights Reserved.

All other trademarks or registered trademarks are the property of their respective owners.

How-To

Revu 20

Deployment


Introduction
Typically, large organizations face a wide range of challenges, such as finding the most efficient deployment method, and properly configuring an application for use in networked, multi-user settings. We have presented guidelines in the following pages for planning and implementing your Bluebeam Revu deployment.
This guide was written for IT Administrators, under the assumption that the reader has a firm understanding of fundamental concepts, such as software installation, the Windows Command Line, as well as writing and running batch files.

You can find guidelines for post-installation management of your deployment in the Revu 21 Administration Guide
If you’re looking for information about using Revu in your Citrix environment, please refer to Bluebeam Revu in a Citrix Environment

Planning Your Deployment
Compatibility & System Requirements
The latest compatibility information can be found in the Bluebeam Revu 21 Compatibility & System Requirements.

Related Articles