Registration error: "The serial number and product key could not be validated"

This article applies to:

  • Revu 20 & below

Problem

When attempting to register Revu, the following error message displays:

The Serial Number and Product Key Could Not be Validated.

Cause

This error appears because the serial number and product key entered were entered incorrectly or belong to another version or edition of Revu.

Solution

Check your license certificate

The first thing you should do is confirm that the following information matches your License Certificate from registration@bluebeamops.com:

  • Edition (e.g. Standard, eXtreme).
  • Version number (e.g. 2019)
  • Serial number
  • Product Key

If you’re unable to find your license information, see Find your Revu product key.

  1. If the installed software matches what's listed on the license certificate:
    1. Click OK in the error dialog box.
    2. Copy and paste the serial number and product key directly from the license certificate into the Registration dialog box.
    3. Click Register.
      The license codes contain characters that look alike which can be misread.
  2. If the installed software doesn't match what's on the license certificate, please follow these steps for replacing the current installation with the correct software:

    A. Remove the current installation, if you need to install an older version of Revu:

    1. Click OK in the error message dialog box.
    2. Click Use as Trial or Cancel located at the bottom of the Registration dialog box so that the installation finishes.
    3. In Windows 10/11: Right-click Start, then click Apps and Features at the top.
      In Windows 8.1: Right-click Start, then click Programs and Features at the top.
      In Windows 7 SP1: Click Start > Control Panel, then click Uninstall a program or Programs and Features.
      In Revu for Mac: Locate Revu in the Applications folder and move it to the Trash.
    4. Select Bluebeam Revu and click Uninstall.
    5. Follow the on-screen prompts to continue uninstalling the software.

    B. Download and install the correct software:

      1. Download the correct installation file from our website. Please save it to your hard drive.
        Revu for Windows users: Make sure you only download and install the software edition (Standard, CAD, or eXtreme) and version number listed on your License Certificate.
        You can read the full Revu Installation Guide here.

        Revu for Mac installation: Revu for Mac 1.x users should follow the instructions found here. Revu for Mac 2.x users should follow the instructions found here.
        Please make sure you also check the Revu for Mac compatibility information for version 1.x or 2.x, depending on the version you're trying to install.
    1. Locate and double-click the installer, follow the on-screen prompts.
    2. Copy and paste the serial number and product key from License Certificate into their corresponding boxes in the Registration dialog box.
    3. Click Register.
  3. Please contact contact us if the registration still fails, and be sure to include complete details about the problem along with the serial number and product key you're entering.

Troubleshooting

Revu 20

Error Message

Licensing & Registration

Learn what to do if the message “The Serial Number and Product Key could not be Validated” appears when trying to register Bluebeam Revu.