Error: “Sorry, this combination doesn’t look right”

Applies to:

  • Revu 21
  • Revu 20

Problem

When you attempt to log into Studio or access the Bluebeam Gateway with your Bluebeam ID (BBID), you receive the following error message:

Sorry, this combination doesn't look right. Things you can check: your email, password, or regional selection.

Possible Causes

You could be receiving this error message for the following reasons:

  • You entered your BBID and/or password incorrectly.

  • You haven’t yet created your BBID.

  • Your account status is “Precreated”.

  • Your account was deactivated.

Solutions

  • Verify you entered your BBID correctly. If your BBID is correct, but you forgot your password, see this article for information about resetting your BBID password.

  • If you continue to receive this error after resetting your password and/or validating your account, be sure you’ve selected the correct server region.

  • If you haven’t yet created your BBID, see this article for information about creating your BBID.

If none of the above resolves the issue, please contact support@bluebeam.com and request account reactivation.

If your BBID account was deactivated at the request of your company, Bluebeam Technical Support will need approval from the original authority who requested the deactivation.

Revu 21

Revu 20

Troubleshooting

Error Message

Studio