Installationshandledning för företag för Bluebeam® Revu® 21

revu
Installationshandledning för företag för Bluebeam® Revu® 21

Denna artikel gäller:

  • Revu 21

Gå till andra versioner:

Ladda ner distributionspaketen (MSI)

Innan du fortsätter måste du kontrollera att du laddar ner 64-bitarsversionen av distributionspaketet. De här paketen innehåller allt du behöver för en lyckad distribution. En detaljerad beskrivning av de komponenter som ingår i paketen finns i Planera din distribution.

Ladda ner Revu 21

Ladda ner 64-bitarsversion

Söker du en äldre version?

Inledning

Stora företag ställs vanligtvis inför en rad olika utmaningar, till exempel att hitta den mest effektiva distributionsmetoden eller att konfigurera ett program för flera användare i ett nätverk. På följande sidor presenterar vi riktlinjer för planering och implementering av din Bluebeam Revu-distribution.

Den här handledningen är skriven för IT-administratörer, och förutsätter att läsaren har en bra förståelse av grundläggande koncept som programvaruinstallation, kommandoraden i Windows samt att skriva och köra batchfiler.

Du hittar riktlinjer för hantering av distributionen efter installationen i administrationshandboken för Revu 21.

Vad är nytt i Revu 21?

Registreringsprocessen:

  • Serienummer eller produktnyckel måste inte längre anges under distributionen. Det betyder också att det inte finns några obligatoriska egenskaper som ditt skript måste innehålla.
  • Egenskapen Fördröjd auktorisering (DA=1) krävs inte längre.
  • Anslutning till licensservern krävs inte under installationen. Tack vare den här förbättringen har vi tagit bort kravet på att registrera/avregistrera programvaran. Du hittar inte längre registreringsknappen i Revu-menyn eller bland kommandoradsalternativen i Kontrollpanelen.

Från och med Revu 21 krävs inte längre någon internetanslutning under installationen:

  • Du kan använda kontot SYSTEM när du distribuerar via SCCM.
  • Eftersom vi nu använder en prenumerationsmodell loggar användarna in på Revu efter distributionen så att rätt prenumerationsnivå kan tillämpas.

Andra viktiga ändringar i Revu 21:

  • Markeringsläget och visningsläget krävs inte längre eftersom tillgängliga funktioner avgörs av den prenumerationsnivå som användaren loggar in på.
  • Tack vare den förenkling som prenumerationerna medför för distributionen har vi kunnat eliminera behovet av konfigurationsredigeraren.
  • Eftersom vi har gått över från olika Revu-utgåvor till en prenumerationsmodell behövs inte längre ARP-modifieraren och den valfria förinstallationskontrollen.

Planera din distribution

Kompatibilitet och systemkrav

Den senaste informationen om kompatibilitet finns under Kompatibilitet och systemkrav för Revu 21.

Administrationshandbok för Revu 21

Administrationshandboken för Revu 21 omfattar olika ämnen efter installationen, till exempel konsolprogrammet Bluebeam Kontrollpanel, inställningar i Revu, prenumerationshantering, Bluebeam Studio samt elektroniska och digitala signaturer.

Distributionspaket för större företag

Installationsprogrammet använder Microsoft Windows Installer-ramverket (msiexec.exe), Det är därför mycket viktigt att rätt version av Windows Installer redan finns installerat på dina datorer.

MSI-paketet

Det här är den fil som du kommer att använda för att distribuera en fullständig Revu-installation.

Det är mycket viktigt att du laddar ner rätt distributionspaket för din miljö. När du har gjort det, öppnar du .zip-filen och bekantar dig med dess innehåll:

  • En readme-fil med en lista över innehållet i MSI-paketet samt installationskrav.
  • Installationsfilen Revu MSI.
  • Installationsfilen OCR MSI. Från och med Revu 20 skildes OCR-modulen från Revu MSI och är nu en separat installationsfil.
  • Offline-installationsprogrammet för Microsoft .NET Framework 4.8. Installationen av .NET Framework 4.8 under Windows 10 kräver antingen Windows 10 Anniversary Update eller Windows 10 Creators Update. Besök Microsofts webbplats för mer information.
    .NET Framework 4.8 ingår också i Windows 11-installationer.
  • En Visual C++ Redistributable för Visual Studio 2022. Om denna inte redan finns installerad på datorerna måste den distribueras före MSI-distributionen.
  • Ett skript för att ta bort tidigare versioner av Revu. (Uninstall Previous Version.txt – ändra filtillägget till .bat innan filen körs. När filen har ändrats från en textfil till en batchfil kör du den med förhöjd behörighet. Batchfilen avregistrerar och avinstallerar Revu (alla versioner) på datorn).
  • Ett SharePoint-tillägg. Stöds i SharePoint 2019 eller senare för lokala servrar och instanser av SharePoint Online (Office 365).
  • Ett SharePoint-tillägg. Stöds i SharePoint 2013 eller senare för lokala servrar och instanser av SharePoint Online (Office 365).

Om du vill veta mer om hur du installerar Bluebeams app för SharePoint-integration i en SharePoint-miljö kan du läsa Installera SharePoint-integrationsappen.

Avinstallationsskriptet för varje mindre uppdatering kan användas för att ta bort eventuella tidigare utgåvor, men det är INTE ett krav att köra det om du uppdaterar till en mindre utgåva inom samma version. Det här betyder att alla framtida MSI-uppdateringar för Revu 21 kan köras ovanpå den tidigare Revu 21-installationen.

Anpassade inställningar och tillgångar

Använder din organisation anpassade eller delade inställningar och tillgångar, till exempel profiler, verktygssatser och stämplar? I Administrationsguiden för Revu 21 finns information om bästa praxis för att exportera, samla och mellanlagra dessa objekt.

Konfigurera en mellanlagringsdator

Om du behöver skapa ovannämnda anpassade inställningar och tillgångar måste du manuellt installera Revu på en dator så att du kan skapa och mellanlagra tillgångarna så som beskrivs i avsnittet Centrala inställningar i Administrationsguiden för Revu 21.

För den här enstaka installationen kan du ladda ner installationsprogrammet från vårt nedladdningscenter.

Distributionsprocessen

Bästa praxis

Innan vi går in på de olika stegen i själva distributionsprocessen finns det en del viktig information att tänka på:

För att undvika potentiella uppdateringsproblem när du planerar en ny distribution är det bäst att låta din tidigare MSI-fil ligga kvar på sin ursprungliga plats.
  • Följ instruktionerna noga, ta inga genvägar eller ändra arbetsflödet på något annat sätt.
  • Bluebeam stöder inte manuell redigering av MSI-filen eftersom det gör att filernas digitala signaturer blir ogiltiga.
  • Om du uppgraderar till Revu 21 från en befintlig installation av en äldre Revu-version måste du först ta bort den äldre programvaran genom att distribuera skriptet Uninstall Previous Versions (Avinstallera tidigare versioner) som ingår i MSI-distributionspaketet för Revu 21.
  • Kör avinstallationsskriptet med förhöjd behörighet.
    Om du använder SCCM kan skriptet Uninstall Previous Versions distribueras genom en uppgiftssekvens. Läs SCCM-dokumentationen från Microsoft SCCM om du behöver hjälp med SCCM-processen.
  • Vi rekommenderar starkt att du skapar en pilotgrupp av användare som kan testa nya Revu-versioner innan du distribuerar dem i hela organisationen.
MSI-filen måste köras med förhöjd behörighet, oavsett om det konto som används ingår i administrationsgruppen för de lokala datorerna eller inte. Windows 10-användare bör läsa Windows User Account Control som referens.
  • Använda Microsoft SCCM

    Från och med Revu 21 krävs inte längre någon internetanslutning under distributionen. Därmed kan du välja Install for user eller Install for SYSTEM (SYSTEM-konto) när du skapar ett MSI-distributionspaket.

Distributionsverktyg

Oavsett vilket paket eller distributionsverktyg du använder gör kommandoradsskriptet att Windows Installer (msiexec.exe) startas under installationerna.

Det finns olika distributionsverktyg som utnyttjar kommandoraden för att köra en MSI-installationsfil, till exempel System Center Configuration Manager (SCCM), Quest KACE (formerly Dell KACE) och Microsoft Windows Group Policy.

Det är viktigt att notera att vi endast tillhandahåller support för användning av kommandoradsskripten, och inte för själva distributionsverktygen.

Distribuera OCR-modulen

För att framtida uppdateringar ska gå snabbare levererar vi OCR-modulen i en separat MSI-fil utanför Revu-programmet. Både Revu MSI och OCR MSI ingår i distributionspaketen på vår webbplats.

Om du vill att dina användare ska kunna utnyttja vissa Revu-funktioner som bygger på textigenkänning, till exempel OCR, AutoMark, Sets och Batch Link, måste du distribuera OCR MSI-filen.

Om OCR MSI inte installeras av en administratör, eller om en användare avinstallerar den, fungerar Revu ändå. Användaren kan dock inte utnyttja några av de funktioner som nämns ovan. För att lösa sådana problem kan OCR-modulen installeras när som helst.

Revu MSI och OCR MSI kan distribueras i valfri ordning. De är inte beroende av varandra. När du uppdaterar Revu till en mindre punktutgåva behöver du inte distribuera OCR-modulen på nytt om den redan har distribuerats som en del av din ursprungliga installation. I den situationen behöver du bara distribuera Revu MSI.

För att effektivisera uppdateringsprocessen och hålla filstorleken så liten som möjligt levereras OCR MSI inte genom uppdateraren i programmet. Eftersom OCR-modulen sällan ändras tillhandahåller Bluebeam en uppdatering med varje huvudversion.

OCR-paketet har inga särskilda parametrar utöver de vanliga msiexec-alternativen. Här är ett exempel på en tyst installation av 64-bitars OCR MSI:

msiexec.exe /i "[path to deployment folder]\BluebeamOCR x64 21.msi" /qn

När du använder .bat-filen Uninstall Previous Versions tas både Revu- och OCR-installationsprogrammet bort. Om du avinstallerar från Kontrollpanelen visas Revu och OCR dock på separata rader och måste avinstalleras individuellt.

Om du felsöker en enskild dator och avinstallerar med Suite.exe installeras OCR automatiskt.

Egenskapstabell för Revu MSI

I egenskapstabellen för MSI-filen visas de egenskaper som du kan använda för att konfigurera och anpassa Revu-installationen. Från och med Revu 21 finns det inte längre några obligatoriska egenskaper för installation. Nedan hittar du de valfria egenskaper som stöds.

Valfria egenskaper som stöds

BB_AUTO_UPDATE Aktivera eller inaktivera uppdateringsmeddelanden i programmet: Aktiverade (standard) = 1, Inaktiverade = 0. Se anmärkningarna.
BB_DISABLEANALYTICS Aktivera eller inaktivera skickande av information om programanvändning till Bluebeam. Skicka (standard) = 0, Skicka inte = 1. Se anmärkningarna.
BB_DEFAULTVIEWER Ställ in som standardprogram (standard) = 1, Ändra inte standardinställningen = 0. Se anmärkningarna.
BB_DESKSHORTCUT Skrivbordsgenväg till Bluebeam Revu (standard) = 1, Ingen genväg = 0
BB_DESKSTAPLER Skrivbordsgenväg till Bluebeam Stapler = 1, Ingen genväg (standard) = 0
BB_FEATURES Inaktiverar olika Revu-funktioner: Alla funktioner aktiverade = 65535 (standard). Se Aktivera och inaktivera Revu-funktioner med BB_FEATURES för mer information.
BB_IE_PLUGIN Installera och aktivera = 1, Inaktivera (standard) = 0
BB_JOBOPTIONS Ange UNC eller fullständig sökväg för din anpassade .jobOptions-fil.
BB_NETCONFIG Ange UNC eller fullständig sökväg för mappen med de centrala NetConfig-inställningarna.
BB_PAGESIZE Ange A4 för att åsidosätta standardsidstorleken för Bluebeam PDF-skrivare.
DISABLE_WELCOME

Inaktiverar HTML-välkomstsidan och sidan om utbildningsvideor för arbetsflöden för Revu. Aktivera (standard) = 0, Inaktivera = 1

Skapar registerposten Computer\HKEY_CURRENT_USER\Software\Bluebeam Software\20\Revu och DWORD kallad WorkflowsInitialized”.

BB_REVUPREFERENCES Ange UNC eller fullständig sökväg för din RevuPreferences.xml-fil.
IGNORE_RBT Inaktivera kontroll av väntande omstart = 1, Kontrollera väntande omstart = 0. Se anmärkningarna.
MBCODE Avgör vilka av Bluebeam-pluginprogrammen som ska aktiveras. Standardvärdet 1023 gör att samtliga aktiveras. Se Aktivera Bluebeam-pluginprogram med MBCODE för mer information
Egenskapen BB_AUTO_UPDATE

Egenskapen BB_AUTO_UPDATE är aktiverad som standard. Om du låter den vara aktiverad får användare ett meddelande i programmet när det finns en ny Revu-uppdatering tillgänglig. Om du inte vill att dina användare ska få ett meddelande i programmet när en ny version släpps måste du inaktivera den här egenskapen.

Egenskapen BB_DISABLEANALYTICS

Som standard skickar Revu användningsdata till Bluebeam för att hjälpa till med att förbättra programmet. Den information som du lämnar hjälper oss att bättre förstå användares beteenden och trender, så att vi kan fortsätta att förbättra våra produkter och tjänster. All information som lämnas är anonym, och delas inte med tredje part. Bluebeam samlar inte in någon personlig information om dig. Om du vill inaktivera den här inställningen ska du distribuera dina installationer med egenskapen BB_DISABLEANALYTICS inställd på Ett (BB_DISABLEANALYTICS=1) i kommandoradsskriptet för MSI eller i MST-filen.

Användare som öppnar Revu 21 för första gången ser ett nytt fönster, ”berätta om dig själv”, där de blir ombedda att ange grundläggande kunduppgifter.

Om du väljer att avstå från att skicka användningsdata genom att ange BB_DISABLEANALYTICS=1, kommer även ”berätta om dig själv”-fönstret att inaktiveras. Mer information om de uppgifter som vi samlar in finns i Bluebeams Privacy Policy.

Ställa in standardprogrammet för PDF med BB_DEFAULTVIEWER

Microsoft har ändrat hur standardprogram väljs i Windows 8 och senare, vilket gör att inställningen i BB_DEFAULTVIEWER åsidosätts. Det betyder att dina användare måste följa stegen i Ändra standardprogram för PDF-visning. Mer information finns på Microsofts webbplats.

Aktivera och inaktivera Revu-funktioner med BB_FEATURES

Varje Revu-funktion har tilldelats ett numeriskt värde enligt tabellen nedan. För att inaktivera en funktion drar du av dess numeriska värde från standardvärdet för egenskapen BB_FEATURES (65535) som visas i tabellen i Valfria egenskaper som stöds ovan, och anger resultatet som det nya värdet för egenskapen BB_FEATURES.

För att till exempel inaktivera funktionen Bearbetning drar du av den funktionens värde (2) från 65535, och anger sedan resultatet (65533) som nytt värde för BB_FEATURES.

Revu-funktionerna och deras numeriska värden:

Administrator Button (Revu Menu) = 128 Product Updates Button (Help menu) = 16
AllFeatures = 1023 Redaction Cut Content & Erase Content = 2
DigitalSignatures = 4 SelfSignCertificates = 8
EditText = 1 TranslateMarkups = 32
ExportToOffice = 64 Session Following Feature = 512
Mer information om funktionen för att följa en session (Session Following Feature)

Vissa användare kan behöva kunna hindra andra användare från att följa dem i en Studio-session för att uppfylla sekretess- och arbetsmarknadsregler. Följande scenarier illustrerar vad som händer om den här funktionen stängs av:

Användare X försöker följa användare Y
– på användare X skärm ser det ut som om hen fortfarande följer användare Y, men hen kommer inte att få några positionsuppdateringar från användare Y.

Användare X skickar en Följ mig-begäran till alla användare
– dialogrutan med begäran visas inte hos användare Y

Användare Y försöker följa användare X
– användare Y kan inte följa någon annan användare (alla gränssnittskomponenter som gäller att följa sessioner tas bort)

Inaktivera kontroll av väntande omstart

Som standard ställer installationsprogrammet in egenskapen IGNORE_RBT på 0. När MSI körs kontrollerar installationsprogrammet om det finns någon väntande omstart av datorn. Installationen stoppas om IGNORE_RBT=0 och det finns en väntande omstart. Om egenskapen istället anges som IGNORE_RBT=1 stoppas inte installationen även om det finns en väntande omstart. Utan den här flaggan stoppas installationen om en användare inte startar om på begäran.

Dessutom finns det en Microsoft-parameter som kallas REBOOT=ReallySuppress, och som ger dig möjlighet att styra när en dator ska startas om.

Enligt bästa praxis bör du stänga eventuella aktiva program och webbläsare för att göra det mer troligt att undertryckningen lyckas. För att Revu ska fungera som avsett måste den väntande omstarten göras någon gång efter att installationen är klar.

Aktivera Bluebeam-pluginprogrammen med MBCODE

Vart och ett av Bluebeam-pluginprogrammen för tredjeparter som stöds har tilldelats ett numeriskt värde enligt tabellen nedan. Om du bara vill aktivera ett enda pluginprogram – till exempel det för CAD – ersätter du standardvärdet för MBCODE på 1023 (alla pluginprogram är aktiverade) med siffran 2. Om du behöver aktivera fler än ett pluginprogram lägger du ihop deras numeriska värden och anger totalsumman som nytt MBCODE-värde. Om du ändrar värdet till 0 inaktiveras samtliga pluginprogram.

Bluebeam-pluginprogram aktiveras bara om det aktuella tredjepartsprogrammet finns installerat. Se kompatibilitetstabellen för Revu för att kontrollera att dina tredjepartsprogram stöds.

Revu-pluginprogrammen och deras numeriska värden

Alla pluginprogram är inaktiverade = 0 Microsoft Outlook = 128
AutoCAD = 2 ProjectWise = 64
AutoCAD LT (32 och 64 bitar) = 4 Revit och Navisworks = 16
Internet Explorer = 32 SolidWorks = 8
Microsoft Office = 1  

Språktransformeringar

Du kan distribuera installationer på ett annat språk än det som är förvalt i Windows genom att ställa in egenskapen TRANSFORMS på en av de språkkoder som visas i listan nedan. Annars installeras Revu på det språk som värdoperativsystemet använder.

Kommandoradsexempel för MST- och MSI-installationer visas senare i den här guiden.

Språktransformeringskoder för Revu:
Danska = 1030 Italienska = 1040
Nederländska = 1043 Japanska = 1041
Engelska = 1033 Koreanska = 1042
Finska = 1035 Norska = 1044
Franska (standard) = 1036 Spanska = 1034
Tyska = 1031 Svenska = 1053

Distributionsmetoder

I det här avsnittet behandlas ämnen som Windows Installer-växlar och hur du skriver skript för MSI-installationer.

Om Windows Installer-växlar

Det finns tre viktiga Windows Installer-växlar att vara medveten om när du skriver ett skript för MST- eller MSI-installationer:

Instruerar Windows Installer att anropa msiexec.exe för att köra en installation

/i

Med den här växeln kan du köra obevakade och tysta installationer

/qn

Används om du har skapat en MST som behöver anropas. Detta görs genom att ange sökvägen till den mapp där MST-filen finns samt MST-filens namn. Med TRANSFORMS kan du också installera Revu på olika språk.

TRANSFORMS

Skriva ett installationsskript

Låt oss ta en titt på de olika metoderna för att distribuera Revu. För var och en av dem används kommandoraden på lite olika sätt.

Använda en Microsoft Transform-fil (MST)

Med en Microsoft Transform-fil (MST) kan du minimera antalet skrivfel, eftersom alla ändringar av egenskaper och parametrar görs i MST-filen, som anropas med hjälp av ett kort kommandoradsskript. Det innebär att du kan kontrollera dina ändringar av egenskapstabellen innan de skickas vidare under installationerna.

Viktig anmärkning om transformeringar

Scenario 1: Språktransformeringar

När du använder TRANSFORMS för språk, måste MST-filen finnas i samma rotkatalog som MSI-filen. Använd inte en sökväg till MST-filen – bara MST-filens namn. Använd INGA mellanslag och INGA citattecken i MST-filens namn.

TRANSFORMS=:1031;MyTransforms.mst
TRANSFORMS=:1031;<använd inte sökvägen till mst-filen, bara mst-filens namn>

Scenario 2: Standardtransformeringar

När du använder TRANSFORMS måste MST-filen finnas i samma rotkatalog som MSI-filen. Använd citattecken runt sökvägen till MST-filen.

TRANSFORMS="C:\Deployment Folder\MyTransforms.mst"
TRANSFORMS=<sökväg till mst-filnamnet med citattecken>
Skapa och redigera en MST-fil

Om du inte redan har gjort det måste du ladda ner och installera en MSI-redigerare, till exempel InstEd. När du har gjort det följer du stegen nedan:

  1. Starta InstEd, klicka på menyn File (Arkiv) och öppna den ursprungliga MSI-filen.
  2. Klicka på menyn Transform (Transformering) och välj New Transform (Ny transformering).
  3. När dialogrutan New Transform (Ny transformering) öppnas namnger du MST-filen och klickar på Save (Spara).
    Filen får inte heta Transforms.mst, och den måste sparas i samma mapp som den ursprungliga MSI-installationsfilen.
  4. Klicka på fliken Tables (Tabeller) till vänster och välj Property (Egenskap) i listan Tables (Tabeller). Här kan det vara till hjälp att klicka på kolumnrubriken Property (Egenskap) för att sortera listan Properties (Egenskaper) alfabetiskt.
  5. Redigera Properties (Egenskaper) enligt dina behov.
    REDIGERA INTE några andra egenskaper än de som visas i tabellen över MSI-egenskaper
  6. Klicka på menyn File (Arkiv) och spara filen genom att klicka på Save (Spara).
Skriva ett kommandoradsskript som använder MST-filen

Här är ett par exempel på installationsskript som anropar en MST-fil:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=YourMSTFile.mst /qn

En tyst installation av språket tyska:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=:1031;MyTransforms.mst /qn

Det är mycket viktigt att du testar ditt skript i en upphöjd kommandotolk på en testdator innan du distribuerar installationen för att försäkra dig om att skriptet fungerar som det ska.

Dubbelklicka inte på MSI-filen. Om du gör det installeras Revu utan nödvändig förhöjd behörighet eller de anpassningar som du eventuellt har ställt in i MSI-egenskaperna.
Använda MSI-egenskaperna direkt

En annan metod för att bygga din distribution är att skriva ett fullständigt installationsskript som anropar MSI-filen för Revu och listar alla egenskapsändringar.

Värden för en MSI-växel (som anges med ett snedstreck) måste omges av citattecken enligt nedanstående. För Bluebeam-specifika egenskaper måste mellanslag ersättas med frågetecken.
Innan du distribuerar Revu rekommenderar vi att du skriver och korrekturläser ditt skript i en textredigerare och kör det på en testdator i en upphöjd kommandotolk.

Exempel på MSI-skript

För att få en bättre uppfattning om hur kommandoradsskript kan skrivas för olika installationskrav och konfigurationer kan du titta på följande exempel:

Grundläggande tyst installation som också distribuerar en specifik RevuPreferences.xml-fil

Lägg märke till skillnaden i sökvägen mellan .msi- och .xml-filen:

msiexec.exe /i "\\MyServer\Bluebeam?Deployment\Bluebeam Revu x64 21.msi" BB_REVUPREFERENCES=\\MyServer\Bluebeam?Deployment\RevuPreferences.xml /qn

Skript som tyst kombinerar OCR MSI och Revu MSI med hjälp av en TRANSFORMS-fil:

START /WAIT msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\BluebeamOCR x64 21.msi" /qb && msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.msi" TRANSFORMS="C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.mst" /qn

Köra och felsöka en distribution

Förutsatt att du har skrivit ditt skript och provat det i en upphöjd kommandotolk på en testdator kan du nu köra det i valfritt distributionsverktyg, till exempel SCCM, Dell KACE eller Group Policy.

Om installationerna inte går som du hade tänkt dig eller misslyckas på något annat sätt måste du gå tillbaka och kontrollera ditt arbete. Om ditt skript anropar en MST-fil öppnar du den igen med MSI-redigeraren och kontrollerar att du har ställt in egenskaperna rätt.

När du har bekräftat att du har använt rätt syntax i skriptet validerar du det igen med en upphöjd kommandotolk på en testdator.

MSI-installationsfilen skapar en utförlig loggfil i katalogen %TEMP% på den lokala enheten på den dator där Revu är installerat. Namngivningskonventionen är MSIxxxxx.log” där xxxxx” är slumpmässiga tecken som MSIjfb1d6.log.” Granska loggen för att upptäcka vanliga Windows-installationsfel.

Om du använder SCCM kan du hitta loggfilen i C:\windows\temp när den har installerats via SYSTEM-kontot.
En lista över felkoder för Windows Installer och deras definitioner finns på Microsofts webbplats.
 

Uppdatera befintliga installationer

Den nya MSI-processen tar bort den installerade versionen av Revu 21 och ersätter den med den senaste Revu 21-uppdateringen som du distribuerar. Processen kräver inte heller att OCR MSI-filen distribueras på nytt. Eftersom OCR-modulen inte krävs för nyare Revu 21-uppdateringar kommer ditt distributionspaket för Revu att vara mindre.

Nedan hittar du några exempelskript som kan användas för att uppdatera en befintlig installation av Revu 21:

Inledande MSI-installation med valfri parameter:

msiexec /i "Bluebeam Revu x64 21.0.0 msi" DISABLE_WELCOME=1 
Du måste använda eventuella övriga parametrar på samma sätt som med den första distributionen.

Uppdaterad MSI-installation med valfri parameter:

msiexec /i "Bluebeam Revu x64 21.0.X msi" DISABLE_WELCOME=1

Efter installationen: distribution av valfri anpassning

Bluebeam Kontrollpanel

Med programmet Kontrollpanel (PbMngr5.exe) kan du utföra följande funktioner efter installationen via kommandoraden i Windows:

  • Installera plugin-program
  • Installera om/avinstallera Bluebeam PDF-skrivare
  • Ställa in standard-DPI för Bluebeam PDF-skrivare
  • Ställa in nätkonfiguration
  • Säkerhetskopiera, återställa och återskapa användarinställningar för Revu

För mer information om tillgängliga funktioner kan du komma åt hjälpen för PbMngr5.exe från Windows kommandotolk genom att klicka på Start > Sök och skriva CMC.

När kommandotolken öppnas skriver du cd ”C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu följt av PbMngr5.exe /help och trycker sedan på Enter.

Revu-inställningar

Det finns två Bluebeam-konfigurationsfiler med programinställningar som kan distribueras: filen RevuPreferences.xml som kan distribueras när som helst och UserPreferences.xml som bara kan distribueras efter att en ny Revu-installation har slutförts.

RevuPreferences.xml

Den här filen innehåller alla inställningar som har konfigurerats i dialogrutan Revu-inställningar (Ctrl+K). Om du klickar på Exportera i dialogrutan kan du spara filen RevuPreferences.xml på valfri plats, till exempel en central mapp på en server.

Filen kan distribueras som en del av en MST eller skickas som ett MSI-kommando, men du kan också göra det efter installationen med hjälp av ett kommandoradssalternativ som anropar Bluebeam Kontrollpanel där du kan göra automatiska ändringar.

Här är ett exempel på hur du distribuerar en uppdaterad uppsättning Revu-inställningar där alla pluginprogram utom det för Internet Explorer ska förbli aktiverade:

"%ProgramFiles%\Bluebeam Software\Bluebeam Revu\21\Revu\PbMngr5.exe" /setup /PREFSPATH:"G:\Bluebeam Software\Settings\RevuPreferences.xml"

Du kan också kopiera eller skicka filen RevuPreferences.xml file till:

C:\ProgramData\Bluebeam Software\Bluebeam Revu\21\Revu
När Revu startas söker programmet efter RevuPreferences.xml. När programmet upptäcker att filen är nyare än filen UserPreferences.xml file i användarens %appdata%-mapp, slås innehållet ihop med det i den befintliga UserPreferences.xml. För att ändra datumet för senaste ändring måste du göra en ändring i filen RevuPreferences.xml. Det kan vara så enkelt som att lägga till ett mellanslag i början av texten.

Ställa in ett krav på offline-PIN-kod

Användare kan ställa in en offline-PIN-kod för att komma åt Studio-filer när de inte är anslutna till Bluebeam Studio. Även om det här inte är något standardkrav kan det redigeras under avsnittet Studio i RevuPreferences.xml på mellanlagringsdatorn. Det kan sedan exporteras till en mellanlagringsplats i ditt nätverk. Det är vanligtvis samma plats som den MSI-fil som du distribuerar.

Ändringen av RevuPreferences.xml består av:

         <Studio> <RequireOfflinePIN>True</RequireOfflinePIN> </Studio>

Det kan distribueras med hjälp av MSI-egenskapen BB_REVUPREFERENCES.

När den här inställningen har gjorts måste alla nya och befintliga Studio-användare skapa en offline-PIN-kod. De kommer inte att kunna logga in i Bluebeam Studio utan att ha skapat en sådan.

UserPreferences.xml

Den här filen innehåller inställningar för en enskild Revu-användare. Även om den här filen inte kan distribueras till befintliga installationer kan den distribueras till en ny, före första start, genom att skicka en ändrad UserPreferences.xml till följande plats på varje dator:

C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu
Förutsatt att du samlade in dina anpassade resurser, till exempel profiler och verktygssatser, medan du planerade distributionen, kan du också kopiera dem till den här platsen.
Första gången som Revu startas kopieras filerna automatiskt till följande plats i användarens centrala Windows-användarprofil:
%APPDATA%\Bluebeam Software\Revu\21

Slå ihop Revu-inställningar

Om du bara vill lägga till nya inställningar bör du först öppna filen RevuPreferences.xml i en textredigerare och lägga till Merge=”True” i början av filen enligt nedanstående innan du mellanlagrar den för distribution. Se administrationsguiden för Revu för mer information. Sammanslagningsprocessen innebär en ersättning av de data som ska uppdateras eller redigeras i filen RevuPreferences.xml.

Exempel på en redigerad RevuPreferences.xml-fil

Följande uppsättning Revu-inställningar ger en Revu-installation där de här inställningarna slås ihop med en befintlig UserPreference.xml-fil (Merge=”True”), och tillhandahåller URL:en till en organisations SharePoint-server:

<?xml version="1.0" encoding="utf-8"?>
<RevuPreferenceDictionary Version="2" Merge="True">
<DocManSys>
<ActiveIndexx64.>0</ActiveIndexx64.>
<CacheSharePointFilesx64.>False</CacheSharePointFilesx64.>
<CheckcoutOnOpenFromHyperlinks.x64.0>False</CheckcoutOnOpenFromHyperlinks.x64.0>
<CheckcoutOnOpenFromHyperlinks.x64.1>False</CheckcoutOnOpenFromHyperlinks.x64.1>
<CheckoutOnOpen.x64.0>False</CheckoutOnOpen.x64.0>
<CheckoutOnOpen.x64.1>False</CheckoutOnOpen.x64.1>
<ClaimsSupported.x64.0>False</ClaimsSupported.x64.0>
<ClaimsSupported.x64.1>True</ClaimsSupported.x64.1>
<Countx64.>2</Countx64.>
<DefaultFileFilterPDF>True</DefaultFileFilterPDF>
<DocumentLibrary.x64.0></DocumentLibrary.x64.0>
<DocumentLibrary.x64.1></DocumentLibrary.x64.1>
<LastAccessedLibraryPath.x64.0>Test</LastAccessedLibraryPath.x64.0>
<LastAccessedLibraryPath.x64.1></LastAccessedLibraryPath.x64.1>
<LoginName.x64.0>sa</LoginName.x64.0>
<LoginName.x64.1>sa</LoginName.x64.1>
<PromptForCheckinCommentsx64.>True</PromptForCheckinCommentsx64.>
<PromptForCheckoutFromIEx64.>True</PromptForCheckoutFromIEx64.>
<RegKey.x64.0>SharePoint2007</RegKey.x64.0>
<RegKey.x64.1>SharePoint2007</RegKey.x64.1>
<SelectionDialogx64.>False</SelectionDialogx64.>
<SharePointUseExistingCookies>True</SharePointUseExistingCookies>
<Site.x64.0>http://sharepointserver1</Site.x64.0>
<Site.x64.1>http://sharepointserver2</Site.x64.1>
<SiteAlias.x64.0>SharePoint</SiteAlias.x64.0>
<SiteAlias.x64.1 />
<StoreLastAccessedFolderx64.>True</StoreLastAccessedFolderx64.>
<TestIfSharePointPathx64.>True</TestIfSharePointPathx64.>
<ToolbarIntegrationOnlyx64.>True</ToolbarIntegrationOnlyx64.>
<UseDefaultCredentialsx64.>True</UseDefaultCredentialsx64.>
</DocManSys>
</RevuPreferenceDictionary>

*Dessa SharePoint-server-URL:er ändras när data slås ihop med filen med Revu-inställningar.

Distribuera anpassade tillägg genom kommandoraden Revu.exe

Kommandoradsväxlar för Revu.exe

Med följande växlar kan du bestämma hur importprocessen ska köras och vilka tillgångar som ska kopieras till en användares förinställda lokala %appdata%-roamingmapp för Revu:

När tillgångar eller inställningar importeras kopieras de så som beskrivs ovan. Om de ”läggs till” skapas en hänvisning (länk) till en delad tillgång som ligger på en nätverksenhet eller annan icke-standardplats.
När du skapar och exporterar anpassade profiler är det bäst att ta med eventuella beroenden som anpassade verktygssatser, skrafferingsmönster, linjeformat, anpassade kolumner eller anpassade statusar. Att bädda in dem i profilen gör det mycket enklare att dela de här anpassade resurserna i en hel organisation.
  • /bpximport:[Fil] – importerar och aktiverar en profil.
  • /bpxdir:[Sökväg] – du kan ange en sökväg till en mapp om du vill tilldela en ny profilkatalog. Det här är sökvägen till en delad nätverksplats där profiler finns och delas med hela organisationen.
    För att hindra användare från att göra ändringar i profilerna i den här katalogen kan du ställa in mappbehörigheterna på Skrivskyddad.
  • /bpxactive:[Namn] – tilldelar en viss profil som Aktiv i antingen användarens lokala %appdata%-roamingmapp för Revu eller en delad profil. Om du har använt /bpxdir: för att ange en delad profilkatalog på en nätverksplats ska du kontrollera att den profil som du ställer in som Aktiv finns i den angivna katalogen.
  • /btxadd:[Fil] – instruerar en Revu-installation att använda en verktygssats som finns på en icke-standardplats utan att importera den.
  • /btximport:[Fil] – importerar en verktygssats till den aktuella profilkatalogen.
  • /bhxadd:[Fil] – instruerar Revu att använda en uppsättning skrafferingsmönster som finns på en icke-standardplats utan att importera den.
  • /bhximport:[Fil] – importerar en uppsättning skrafferingsmönster till den aktuella profilkatalogen.
  • /blxadd:[Fil] – instruerar Revu att använda ett linjeformat som finns på en icke-standardplats utan att importera det.
  • /blximport:[Fil] – importerar ett linjeformat till den aktuella profilkatalogen.

Användningsexempel

Följande skript importerar tyst energiprofilen samt filerna toolset1.btx och dimensions.btx till den profilen:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu\Revu.exe" /s /bpximport:"U:\netProfiles\Power.bpx" /bpxactive:Power/btximport:"U:\netProfiles\Revu\toolset1.btx" /btximport:"U:\netProfiles\Revu\dimensions.btx"
  • /s – du ser den här växeln i exemplet ovan. Växeln stänger av eventuella meddelanden på skärmen som normalt visas under importprocessen.
Växeln /s gör inte installationen ”tyst”.

Importerar en profil och gör den aktiv:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bpximport:"U:\Temp\Name_Profile.bpx" /bpxactive:Name_Profile

Importerar en verktygssats:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /btximport:"U:\Temp\name_Toolset.btx"

Importerar skrafferingsmönster:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bhximport:"U:\Temp\name_Hatch.bhx"

Importerar ett linjeformat:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /blximport:"U:\Temp\name_Line.blx"

Bluebeam, Revu, and Bluebeam Studio are trademarks or registered trademarks of Bluebeam, Inc. Microsoft, SharePoint, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

AutoCAD is a registered trademark of Autodesk in the United States and/or other countries.

© 2020 Bluebeam, Inc. All Rights Reserved.

All other trademarks or registered trademarks are the property of their respective owners.

How-To

Revu 21

Installation

 

Related Articles