Hur man skapar dynamiska stämplar | Revu 21

Använder du en äldre version av Revu?

Denna artikel gäller:

  • Basics
  • Core
  • Complete

Vad är en dynamisk stämpel?

Med alla prenumerationsplaner har du möjlighet att skapa dynamiska stämplar (som tidigare kallades interaktiva stämplar) anpassade efter dina projekt. Stämplar skapas med hjälp av JavaScript, och kan bestå av knappar, formulärfält, företagslogotyper, datum med mera. När du har lagt in stämplar i ett dokument kan du och dina kollegor interagera med dem genom att fylla i formulärfält, markera kryssrutor och ändra annat innehåll som är relevant för projektet.

Underlagsstämpel, grundläggande

Med interaktiva stämplar kan du skapa formulär som kan redigeras och fyllas i av vem som helst. När en användare till exempel placerar ut stämpeln Underlagsprojekt (Submittal Status) blir användaren ombedd att:

  • Välja namnet på det projekt som stämpeln gäller.
  • Markera aktuell status för den PDF som stämplas.
  • Fylla i relevant information om användare, specifikation, datum och underlagsnummer.

Vilka Revu-produkter fungerar med interaktiva stämplar?

Även om det går att redigera en interaktiv stämpels utseende med vilken prenumerationsplan som helst, krävs en prenumeration på Complete för att lägga till formulärfält, redigera formulärfält och redigera JavaScript för en interaktiv stämpel.

Lägga till en stämpel i Revu

Det finns två sätt att skapa en interaktiv stämpel. Ett sätt är att skapa stämpeln från grunden med JavaScript. Ett annat sätt är att börja med en stämpelmall (t.ex. från vår sida med anpassade bibliotek för Revu) och anpassa den efter ditt projekt. Den här artikeln handlar om hur du skapar stämplar med mallar.

Ladda ner mallen

  1. Gå till sidan med anpassade bibliotek för Revu.
  2. Under Interaktiva stämplar väljer du Underlagsprojekt (Submittal Status) för att starta nedladdningen.
  3. Hitta submittal-status.zip bland dina nedladdningar, högerklicka på filen och välj Extrahera alla.
  4. Välj Extrahera.

Importera stämpeln

  1. Öppna och logga in i Revu 21.
  2. Gå till Verktyg > Stämpel > Importera stämpel…
  3. Gå till den mapp där din stämpel finns.
    I det här exemplet går du till dina nedladdningar och öppnar mappen som heter submittal-status.

    Mappen innehåller följande PDF-filer:

    • Submittal_Status Instructions.pdf med specifika instruktioner för att ändra det globala skriptet och formulärfälten i den aktuella stämpeln.
    • Submittal_Status.pdf som används för att placera ut en enstaka stämpel.
    • Submittal_Status_Batch.pdf som används för att stämpla flera sidor samtidigt.
  1. Välj din stämpel.
    I det här exemplet väljer du Submittal_Status.pdf.
  2. Välj Öppna.

Nästa gång du väljer stämpelverktyget visas stämpeln i listan.

Placera ut en stämpel

  1. Välj Verktyg > Stämpel och välj sedan Underlagsprojekt (Submittal Status) i listan över stämplar.
  2. Klicka på det ställe i dokumentet där du vill placera stämpeln. Du blir ombedd att fylla i följande fält:

Underlagsstämpel, ifyllt formulär

  1. Välj ett projekt i listrutan.
  2. Välj en status.
  3. Fyll i textfälten.
  4. Välj OK för att placera stämpeln på sidan.

Underlagsstämpel, grundläggande, ifylld

Stämpelns innehåll kan inte ändras när den har lagts till på en sida.

Anpassa en stämpel

Förutom texten i formulärfält kan du anpassa alla aspekter av en stämpel i Revu 21 oavsett vilken prenumerationsplan du har. I det här exemplet ska vi anpassa företagsnamnet och företagslogotypen.

För att göra ändringar av en stämpel öppnar du den i redigeringsläget:

  1. Välj Verktyg > Stämpel. Håll sedan markören över önskad stämpel och klicka på Redigera till höger.
    I det här exemplet ska du redigera stämpeln Submittal_Status.pdf.
  2. Använd markeringsverktygen för att anpassa stämpeln genom att lägga till ditt företagsnamn och ändra textfärg, bakgrundsfärg eller företagslogotyp.

Underlagsstämpel med företagslogotyp

För att justera, lägga till eller ta bort formulärfält måste du ha en prenumeration på Complete.
  1. När du har anpassat din stämpel väljer du Arkiv > Spara som och anger ett nytt namn på din stämpel.

Redigera formulärfält och JavaScript

Det här avsnittet handlar om hur du gör ändringar i JavaScript-dialogrutan och formulärfälten utan att behöva kunna i stort sett något alls om JavaScript. När en dynamisk eller interaktiv stämpel har placerats ut i ett dokument:

  • Det här utlöser en åtgärd från fältet Beräkning, vilket gör att dialogrutan Stämpel öppnas.
  • Den person som placerar ut stämpeln kan sedan fylla i önskad information i JavaScript-prompten.

JavaScript i stämplarna från vår tilläggssida är uppdelat i två delar: StampCode och beräkningsskriptet. Det är viktigt att du förstår de här två termerna innan du redigerar din stämpel.

För att kunna redigera JavaScript måste du ha en prenumeration på Complete.

Beräkningsskript

Beräkningsskriptet är skrivet på förhand och bör inte ändras. Du hittar det bland egenskaperna för formulärfältet Beräkning. Beräkningsskriptet definierar de variabler som StampCode hänvisar till. Om du inte har avancerade kunskaper om JavaScript kommer din stämpel troligen inte att fungera om du redigerar beräkningsskriptet.

Redigera inte, och ta inte bort, fältet Beräkning i stämpeln.
Varje stämpel från tilläggssidan fungerar med fördefinierade formulärfält. Du kan inte lägga till alternativgrupper eller andra typer av formulärfält. Om det behövs kan du dock kontakta den tekniska supporten för fler stämpelexempel.

StampCode

Varje stämpel har ett lagrat värde som kallas StampCode, vilket är den backend-kod som motsvarar de visuella elementen av en interaktiv stämpel. Om du till exempel vill lägga till eller redigera formulärfält använder du StampCode. StampCode styr vilket innehåll som ska visas i stämpelns dialogruta och interagerar direkt med formulärfälten i stämpeln.

I följande figur visas hur StampCode motsvarar formulärfältens namn:

Underlagsstämpel, revidera i kod och stämpel

För alla stämplar som är tillgängliga på sidan med anpassade bibliotek för Revu är StampCode uppdelat i två delar: den första halvan av koden hänvisar till alla textfält som används i stämpeln, medan den andra halvan hänvisar till en grupp alternativknappar och en listruta.

Redigera StampCode

  1. Gå till Fönster > Paneler Formulär  (Alt+Q) för att öppna panelen Formulär. 
  2. Gå till Verktyg > Formulär > JavaScript… (Ctrl+Skift+J) för att öppna dialogrutan Globalt JavaScript.
  3. Kontrollera att StampCode är markerat och välj sedan Redigera.
    Förinställd StampCode Javascript för Underlagsprojekt (Submittal Status) visas.

Du kanske lägger märke till att värdena i StampCode för närvarande motsvarar namnen på varje formulärfält som används i stämpeln. I panelen Formulär anges alternativknappen Revise (Revidera) i StampCode som:

{ value:"Revise", description:"Revise" }

Textfältet CheckedBy anges i StampCode som:

{ field:"CheckedBy", description:"Checked by:", default:function() { return Collab.user; } }

I båda dessa exempel inleds StampCode med value: eller field:. Dessa två termer motsvarar direkt namnen i formulärfältet. Om ett formulärfälts namn inte exakt stämmer överens med dess värde (value) eller fält (field) i StampCode kommer JavaScript inte att kunna köras. Om vi till exempel ändrar alternativknappen Revise (Revidera) till Revised (Reviderat), men inte uppdaterar StampCode för att spegla ändringen, fungerar inte stämpeln.

Efter value eller field ser du description, vilket är den beskrivning som visas efter att du har placerat ut stämpeln och får se JavaScript-dialogrutan. Formulärfältet Spec anges till exempel som:

{ field:"Spec", description:"Spec #:", default:function() { return ""; } }

För att anpassa de fältbeskrivningar som visas i JavaScript-dialogrutan redigerar du namnet på formulärfältet i panelen Formulär samt i StampCode. Description behöver inte stämma överens med namnet på ett formulärfält. Om vi till exempel ändrar Spec # i StampCode till Specifikationsnummer speglas ändringen i dialogrutan.

Redigera en alternativgrupp

Gör så här för att lägga till en ny alternativknapp till en befintlig alternativgrupp:

  1. Välj Verktyg > Stämpel, håll muspekaren över önskad stämpel och välj  Redigera.
  2. Välj panelen  Formulär (Alt + Q).
  3. Välj en av alternativknapparna i alternativgruppen Status för att markera alternativknappen i stämpeln.
  4. I stämpeln högerklickar du på den markerade alternativknappen och väljer Kopiera.
  5. Klistra in (Ctrl+V) alternativknappen där du vill att den ska visas på stämpeln.
  6. I panelen Formulär dubbelklickar du på den nya alternativknappen för att ge den ett nytt namn. I det här exemplet har en alternativknapp lagts till med namnet Support.

Underlagsstämpel, support tillagd

  1. Gå till Verktyg > Formulär > JavaScript (Ctrl + Skift +J).
  2. Välj StampCode och välj sedan  Redigera.
  3. Lägg till ett nytt värde i alternativgruppen:

Det nya kodavsnittet visas nedan:

{ value:"Approved", description:"Approved" },
{ value:"Revise", description:"Revise" },
{ value:"Rejected", description:"Rejected" },
{ value:"Support", description:"Supported" }

  1. Välj OK för att stänga JavaScript-redigeraren.
  2. Välj OK för att stänga dialogrutan Globalt JavaScript.
  3. Spara stämpeln och testa dina ändringar.

När du lägger till stämpeln i en PDF-fil visar dialogrutan Stämpel det nya alternativet som du har skapat. I det här fallet finns nu en fjärde alternativknapp i dialogrutan som heter Support.

Underlagsstämpel, knapp, logotyp tillagd och ifylld

Om du lägger till en ny alternativknapp direkt från formulärverktygen skapas en ny alternativgrupp, och knappen blir inte en del av den befintliga alternativgruppen. Du kan ändra namnet på den nya alternativknappen till Status under Egenskaper (Alt + P), vilket gör att knappen läggs till i alternativgruppen Status.

Stämpeln Underlagsprojekt är endast avsedd att fungera med en alternativgrupp. Om du försöker lägga till ytterligare en alternativgrupp kommer stämpeln inte längre att fungera som den ska.

Användbar information

Processen för interaktiva stämplar

Sammanfattningsvis utförs processen för interaktiva stämplar i följande ordning:

  1. Stämpeln placeras ut.
  2. Beräkningsskriptet genererar stämpelns dialogruta baserat på det globala skriptet.
  3. Information anges i stämpelns dialogruta.
  4. Stämpeln slutförs med önskad information.

Listrutor och fälttypen Listruta

I flera stämplar som tillhandahålls genom tilläggssidan kan du lägga märke till att ett textfält används som en listruta eller ett formulärfält av typen listruta. Att använda en faktisk listruta eller ett formulärfält av typen listruta är inte kompatibelt med några av de beräkningsskript som är inbäddade i stämplar i Revu.

Här är ett exempel på ett textfält som visas som en listruta i dialogrutan för stämpeln:

Underlagsstämpel, listruta, JavaScript

Textfältet Projekt fungerar som en listruta i dialogrutan för stämpeln. Listan över objekt som visas i stämpelns dialogruta beror på StampCode.

Underlagsstämpel, dialogruta, listruta

Felsökning

JavaScript-dialogrutan visas inte när en stämpel placeras ut

Det vanligaste problemet som uppstår med interaktiva stämplar är att fältet Beräkning har raderats. Om fältet Beräkning har raderats visas inte JavaScript-dialogrutan när stämpeln placeras ut.

Beräkningsfält för stämpel

För att återskapa fältet Beräkning efter att det har raderats måste du först hitta och kopiera fältet från den ursprungliga mallen.

  1. Välj Verktyg > Stämpel, håll markören över önskad stämpel (Submittal Status (Underlagsprojekt) i det här exemplet) och välj  Redigera.
  2. Högerklicka på skriptet Beräkning och välj Kopiera.

Lägg sedan till fältet Beräkning i den felaktiga stämpeln:

  1. Välj Verktyg > Stämpel, håll muspekaren över önskad stämpel och välj  Redigera.
  2. Gå till Verktyg > Formulär > Textruta. Placera textrutan var som helst i stämpeln och använd panelen Formulär för att ge fältet namnet Beräkning.

Återskapa beräkningsfält

  1. Högerklicka på fältet Beräkning och välj Egenskaper.
  2. I formulärfältets egenskaper väljer du Beräkna och använder listrutan för att välja Anpassat beräkningsfält.

Beräkningsfältet har lagts till igen manuellt

  1. Klicka på Redigera och klistra in (Ctrl + V) beräkningsskriptet för stämpeln.
  2. Spara stämpeln.
  3. Välj Arkiv > Ny, och placera stämpeln i dokumentet för att kontrollera att den fungerar som den ska.

Om du stöter på problem med några av stegen i den här artikeln, eller om du har frågor om dynamiska eller interaktiva stämplar, kan du skicka ett e-postmeddelande till support@bluebeam.com. Bifoga den aktuella stämpeln till din förfrågan tillsammans med en kort beskrivning av problemet.

I Complete kan du skapa interaktiva stämplar anpassade efter ditt projekts behov.

Related Articles