Documents print slowly or incorrectly
Applies to:
- Revu 21
- Revu 20
Problem
Whenever you print certain PDFs to a physical printer, the documents don't print correctly, or the printing process takes an unusually long time.
Cause
When you print a file, the Windows Graphic Device Interface (GDI) transmits PostScript files that are sent to a physical printer. The printer converts these files into printed page content.
During the conversion process, fonts and other printed elements are broken down into data points that represent arcs, curves, transparencies, etc. and are sent to the printer. The more PostScript data your file has, the longer it will take to print. If your file has a high word count or more complex graphical data like line merge, transparency, and hatch patterns, your file will take longer to print.
Solution
There are a few things you can do to resolve the issue:
Use a PCL printer driver if you're not already doing so
PCL 6 drivers help compatible printers translate GDI to PCL 6 faster than converting PostScript data, because PCL 6 commands are designed to closely match Microsoft Windows GDI commands.
Assuming there's already a PCL 6 driver installed on your machine for your printer, follow these steps listed to select it:
- Initiate the print process in Revu by going to File > Print (Ctrl+P).
- Choose the PCL 6 version of your printer from the Name dropdown list, located at the top of the Print dialog.If no PCL 6 driver is listed, check the manufacturer website for an available for your printer.
- Select Print.
Print as image
If the issue still persists or you were already using a PCL 6 driver in the first place, you can usually fix these types of printing problems by sending the document to the printer as an image instead of a combination of different elements.
- Initiate the print process in Revu by going to File > Print (Ctrl+P).
- Select Advanced.
- From the Printing Engine dropdown list, selet Image, and then select OK.
- Select Print.
Print from Revu (32-bit)
If your printer drivers are 32-bit, you may experience problems printing in 64-bit software like Revu. Because of this, Revu offers a 32-bit mode which allows printers with 32-bit drivers to function properly.
To run Revu in 32-bit:
- In Windows, go to Start > Bluebeam Software > Bluebeam Revu [your version] (32-bit).
- When Revu opens, try printing as you normally would.
Troubleshooting
Revu 20
Revu 21
Printing