Transferring a Revu license to a new computer

This article applies to:

  • Revu 20
  • Revu 2019
  • Revu 2018

Jump to other versions:

wfh, work from home

To move your Revu license onto a new computer, you’ll need to have your serial number and product key handy. 

Both your serial number and product key can be found on the License Certificate sent to the license owner from registration@bluebeamops.com. If you’ve lost this information, contact us to request a new copy of your License Certificate.

Backing up and restoring settings

If you’d like to retain the same tool sets and profiles present on your old computer, you can do this by backing up your settings, and then restoring those settings onto a new computer. Be sure to save your backup file to a portable device, or upload it to a location you can access from your new computer.  

Stamps are not included in your Revu settings backup files. To import your stamps onto a new computer, see Backing up and restoring your stamps.

Transferring your license

Before beginning, make sure the source computer you are transferring from has a stable internet connection. You may also want to ensure that your version of Revu is compatible with the operating system and associated software on your new computer.

On the source computer

  1. Open Revu and go to Revu > Unregister. Close Revu after you have successfully unregistered. 
  2. On your computer, click the Start menu and then select Apps and Features (Programs and Features).
  3. Select Bluebeam Revu and then select Uninstall. Follow the on-screen prompts to continue uninstalling the software.
    If you are using Revu 20, continue to step 4. Otherwise, continue to the next section on installing Revu to your new computer.
  4. From Apps and Features, select BluebeamOCR 20. As of Revu 20, the OCR module must be uninstalled separately from the general Revu application.
  5. Select Uninstall. Follow the on-screen prompts to continue uninstalling the software.

On the destination computer

If you have not yet installed Revu on your new computer, follow the steps below:

If you have already installed Revu onto the destination computer, you simply need to register your software on the new device by opening Revu, going to Revu > Register, and then entering the serial number and product key listed on your License Certificate.
  1. Download Revu onto your new computer. A download link for the software is included in the License Certificate. You can also download the software directly from our Download Center, but be sure to download the edition and version of the software listed on your License Certificate. 
  2. Install Revu. If you’re unfamiliar with the installation process, see the Revu Installation Guide for a step-by-step guide.
  3. During the installation, enter the serial number and product key when prompted. These are listed on the License Certificate you received from registration@bluebeamops.com.

Once the installation process is complete, your license of Revu will have been successfully transferred. You may need to restart Windows before launching Revu. Save your work and close any running applications before restarting.

Troubleshooting

For help with possible errors during the registration process, see Revu registration errors for a list of common solutions. If an issue persists, contact us for further installation and registration support.

Other versions of this article

Revu 2017 and older

You can move your license to a new computer by completing the process described below. However, you’ll need the serial number and product key listed in the license certificate, which was sent to you from registration@bluebeamops.com.

If you’ve lost this information, you can contact License & Registration to request that the license certificate be resent to you. When doing so, be sure to include the serial number, version number, your name, company name, email address and phone number where you can be reached.

If you don’t know your Revu serial number, it can be found by opening Revu and clicking Help > About. The serial number is listed in the upper-left corner, below the title and version number, which you also need to include when you contact License & Registration.

Revu 2015 and Microsoft® ACS retirement

Microsoft® retired their Access Control Service (ACS), a cloud authentication service that authorized users to access certain web applications and services. The 2015.5 and 2015.6 versions of Revu use ACS when users attempt to register or activate a computer to a license of Revu online. As a result, the online registration process will no longer work with those versions. If you’re on Revu 2015.5 or 2015.6, see Microsoft ACS retirement and Revu authentication for more information, and instructions on transferring your license.

Backing up your Revu Settings

If you would like to keep your settings and stamps from your current computer, please read Backing Up and Restoring Your Bluebeam Revu Settings, Tools Sets, Profiles and Stamps.


Moving the License on Windows® 10, 8.1 and 7 SP1

  1. Go to the Bluebeam Revu Compatibility Chart and confirm that your version of Revu is compatible with the operating system and associated software on your new machine.
  2. While the computer is connected to the internet, use the Bluebeam Administrator to unregister the software.
    1. In Windows 10: Click Start > Bluebeam Software > Bluebeam Administrator.
      In Windows 8.1: Click or press Start and type Bluebeam Administrator.
      In Windows 7 SP1: Click Start > All Programs > Bluebeam Software > Bluebeam Administrator.
    2. From the Tools menu, click Unregister.
    3. Click OK.
  3. Uninstall Revu from the original computer.
    1. In Windows 10: Right-click Start, then click Apps and Features or Programs and Features at the top.
      In Windows 8.1: Right-click Start, then click Programs and Features at the top.
      In Windows 7 SP1: Click Start > Control Panel, then click Uninstall a program or Programs and Features.
    2. Select Bluebeam Revu and click Uninstall.
    3. Follow the on-screen prompts to continue uninstalling the software.
  4. Download and install the software on the new computer. A download link for the software is included in the license certificate, and you can also download the software from our Downloads & Updates page.
    Make sure you download the edition and version of the software listed on your license certificate.
  5. During the installation, you’ll be prompted to enter the same serial number and product key you received from Bluebeam.
    Follow the directions to complete the online or manual authorization process to authorize the software on the new computer.

If Revu has already been installed on the new computer, follow the steps listed below to complete the registration process:

  1. Open Revu.
  2. Click Help > Register.
  3. If needed, copy and paste the serial number and product key from the license certificate email, into their corresponding boxes on the Registration dialog box.
  4. Click Register and then click Finish.
    If an error message displays during the registration, click here for details about the error and how to resolve it.

Moving the License on Windows XP

Although we’ve provided the instructions listed below, it’s important to know that Microsoft no longer supports Windows XP. With this in mind, we’re unable to provide support for Revu versions that are incompatible with currently supported versions of Windows. Please refer to our compatibility information for further details.

If you’d like to run Bluebeam Revu on a supported version of Windows, you can purchase the current version online from the Bluebeam Store.

  1. Go to the Bluebeam Revu Compatibility Chart and confirm that your version of Bluebeam Revu is compatible with the operating system and associated software on your new machine.
  2. While the computer is connected to the internet, unregister the software.
    1. Click Start > All Programs > Bluebeam Software > Bluebeam Administrator.
    2. On the Tools menu, click Unregister.
    3. Click OK.
  3. Uninstall the Bluebeam software from the original computer.
    1. Click Start and then Control Panel.
    2. Click Add or Remove Programs.
    3. Select Bluebeam Revu in the list.
    4. Click Change/Remove and complete the uninstall.
  4. Download and install the software on the new computer.
    1. A download link for the software is included in the license certificate, and you can also download the software from our Downloads & Updates page.
      Make sure you only download and install the edition and version of the software listed on your license certificate.
    2. During the installation, you’ll be prompted to enter the same serial number and product key you received from Bluebeam.
    3. Complete the online or manual authorization process to authorize the software on the new computer.

If Revu has already been installed on the new computer, follow the steps listed below to complete the registration process:

  1. Open Revu.
  2. Click Help > Register.
  3. If needed, copy and paste the serial number and product key from the license certificate email, into their corresponding boxes on the Registration dialog.
  4. Click Register and then click Finish.
    If an error message displays during the registration, click here for details about the error and how to resolve it.

Did you know you can transfer your Revu license to a new computer? Learn more about backing up your settings and follow our step-by-step guide here.

Related Articles