Having Trouble Accessing Studio?

This article applies to:

  • Revu 2019 & below
  • Vu 2017 & below
  • Revu for Mac

Problems

  • When you attempt to log into Studio on Revu 2018 or Revu 2019, there's no login screen. You receive an error message: Revu 2018 & 2019 have now reached end of life (EOL). You can no longer access Studio on these versions of Revu. Visit bluebeam.com/pricing to upgrade to the latest version to ensure continued access to Studio and get all the latest features of Revu 21.
  • When you attempt to log into Studio on Revu 2017 & below, Revu for Mac, or Vu 2017 & below, you receive an error message: Bluebeam Revu Error: The request is not permitted from this version of your client software.

Cause

The following products have now reached End of Life (EOL):

  • Revu 2019 & below
  • Vu 2017 & below
  • Revu for Mac

Studio is no longer accessible on these versions of Revu. Please see our EOL FAQs page to learn more about EOL.

For outages, you can look up the status of Bluebeam services by visiting the Bluebeam Services Status page.

Solution

You can access your Sessions and Projects by logging into Studio on a supported version of Revu. 

  • To learn more about upgrading to the latest version of Revu, click here.
  • To sign up for a trial of Revu 21, visit this page

Troubleshooting

Revu for Mac

Revu 2017 & Below

Revu 2018

Revu 2019

Studio

Revu offers notification and alert features within Studio that help you stay updated on changes made to Sessions and Projects.