Error: "Oops, something went wrong..." when resetting password

Applies to:

  • Revu 21

Problem

When you try to reset the password for your Bluebeam ID and click Send Reset Instructions, you receive the following error message:

Oops, something went wrong. It's not you it's us!

Cause

Your Bluebeam ID was deactivated by your Org Admin.

Solution

If you have Revu 21, it's possible that your Org Admin deactivated your account. Please have your Org Admin reactivate your account.