Revu hangs or freezes when opening a PDF

Applies to:

  • Revu 21
  • Revu 20

Problem

Revu hangs, freezes, or causes graphical issues on some Dell and Alienware computers running the Alienware Command Center (AWCC) application. This issue is most likely to occur on machines equipped with an external graphics card (e.g. NVIDIA GeForce) and an external monitor set as the non-primary display.

Users running the AWCC application might also experience issues such as blurred and garbled text or certain elements skewed out of proportion. If you're experiencing these issues, please see Graphical issues in Revu menus and interface.

Cause

These issues are most likely related to how the AWCC interacts with graphics card drivers. Monitoring and/or performance hooks may be injected into the graphics card drivers, which cause rendering or graphical issues on secondary monitors.

Solution

Update to latest version of AWCC

Launch the AWCC application on your system. You should be prompted to install the latest update. After updating, reboot your system and note if the issue persists.

Uninstall AWCC from your system

If updating to the latest version of AWCC did not resolve your issue, consider uninstalling the AWCC application from your system. When uninstalling, be sure to uninstall Alienware Command Center, Alienware Command Center Suite, and Alienware OC Controls.

After uninstalling the AWCC applications, reboot your system and note if the issue persists.

Enable Software Rendering

If the problem continues after attempting the solution(s) above, enable Software Rendering. Revu can render documents using Software Rendering or Hardware Rendering. Hardware Rendering generally offers better performance and is enabled by default. For this reason, we don't recommend disabling Hardware Rendering in most cases.

To enable Software Rendering, follow these steps:

  1. Go to Revu > Preferences (Ctrl+K).
  2. In the Preferences sidebar, select Advanced.
  3. On the 2D Rendering tab, from the Rendering Engine dropdown menu, select Software, and then select OK.

If none of the suggested workarounds solve this issue, please contact us.

Troubleshooting

Revu 20

Revu 21

Performance