Error: "Stapler has encountered an unsupported file type"
Applies to:
Revu 20 & below
Problem
The following error appears when trying to open a file in Bluebeam Stapler:
"Stapler has encountered an unsupported file type. Check the Settings to make sure a necessary converter has not been disabled."
Cause
The file you're trying to open isn't a PDF and/or an applicable converter isn't installed for it. The following file types aren't supported by Revu:
- .zip
- .dwg
- .doc(x)
- .xlsx
- .rvt
- .csv
Solution
Revu can only open and edit PDF files. If you try to open a non-PDF, Stapler (Bluebeam's PDF converter application) will automatically launch in an attempt to convert the file.
For the file conversion to be successful, you must be working with a convertible file type and have the applicable converter installed. Bluebeam Stapler can convert the following file types:
- Image file types (.jpg, .png, etc.)
- Word (requires Microsoft® Word® and the Bluebeam plugins for Office)
- Excel (requires Microsoft Excel® and the Bluebeam plugins for Office)
- PowerPoint (requires Microsoft PowerPoint® and the Bluebeam plugins for Office)
- MIME (requires Microsoft Outlook® and the Bluebeam plugins for Office)
- AutoCAD® (requires AutoCAD or the DWG TrueView® application and the Bluebeam plugin for AutoCAD)
- Revit® (requires Revit and the Bluebeam plugin for Revit)
- SolidWorks® (requires SolidWorks and the Bluebeam plugin for SolidWorks)
- Navisworks® (requires Navisworks and the Bluebeam plugin for Navisworks)
- Sketchup Pro® (requires Sketchup Pro and the Bluebeam plugin for Sketchup Pro)
If you use Revu CAD or eXtreme, you can install the plugin(s) you need with the Bluebeam Administrator. For more information, please see Install the latest Bluebeam plugin for your CAD software.
Troubleshooting
Revu 20
Revu 2019
Error Message
PDF Management
If you are having trouble opening a file with the Bluebeam Stapler, make sure to check file type.