Error: "We can't log you in because of an authentication error" | Bluebeam Subscription Management
This article applies to:
- Revu 21
- Bluebeam Cloud
Problem
You attempt to log into the Bluebeam Subscription Management Portal and get the following error: “ We can’t log you in because of an authentication error.“
Causes
You’re receiving this login error for one of the following reasons:
- You didn’t accept the email invitation to start managing your Revu 21 subscription(s).
- You’re not an Org Admin for your Bluebeam account.
- You haven’t purchased a Bluebeam Plan (Basics, Core, or Complete).
- You’re attempting to log into a server region that doesn’t contain your account or subscription(s).
Solutions
Accept email invitation
If you purchased or upgraded to Revu 21, you’re an Org Admin for your Bluebeam account by default. To start managing your subscription via the portal, you must first accept your email invitation. For more information about accessing and setting up your account, visit Bluebeam Subscription Onboarding.
Request Org Admin permissions
If you can sign into Revu 21, Bluebeam Cloud, and/or Studio with your Bluebeam ID (BBID), then your account has been set up with End User permissions. However, you must have Org Admin permissions to access the Bluebeam Subscription Management Portal. Reach out to the Org Admin(s) for your Bluebeam account (i.e., license owner and/or IT dept.) to request access.
For more information about editing permissions for users, please see the Bluebeam Subscription Management Guide.
Purchase a Revu 21 subscription
If you haven’t purchased or upgraded to Revu 21 yet, you won’t be able to access the Bluebeam Subscription Management Portal — even with an existing BBID. For purchasing options, visit the Bluebeam Webstore and be sure to select the correct location/region from the dropdowns at the top of the page.
Select the server region associated with your account
Before logging into the Bluebeam Subscription Management Portal, you must select the correct server region for your account.
To confirm your account’s server region, locate the invitation email and/or welcome email that was sent to you after purchasing or upgrading to Revu 21. These emails confirm the server region for your subscription plan(s). Can’t find your onboarding emails? Contact us for additional help.
Bluebeam Cloud
Revu 21
Subscription
Subscription Management