Error: "File is locked by another user. Would you like to open a read-only copy of this file?"
Applies to:
Revu 20
Problem
When attempting to open a PDF file, an error says:
Error Opening File: "File is locked by another user. Would you like to open a read-only copy of this file?"
Cause
This happens when Windows doesn't have a built-in PDF viewer for displaying files in the preview pane. Instead, Windows uses a third-party PDF viewer to mark the file as locked, or in use.
Solutions
Change the default PDF viewer
Revu includes a PDF previewer for Windows Explorer that doesn't mark files as in use. The PDF previewer is activated when Revu is set as the default PDF viewer in Windows.
- Open Revu.
- Select Revu > Preferences.
- Select Admin from the left-hand menu.
- Select Open Default Programs.
- When the Settings window displays, complete these additional steps:
- Select Choose default apps by file type.
- Scroll through the list of file types until you reach .pdf, and double-click the current default app.
- Select Revu from the list of applications.
Edit your Revu preferences
You can also edit your Revu Preferences, as described below:
- Go to Revu > Preferences.
- Select General from the left-hand menu.
- Select the Document tab.
- Clear the checkbox for Prompt user if file is locked.
- Select OK.
If you're previewing the file within the Windows preview pane, you may not be able to save it in Revu. You may see this error: "The document could not be published. The process cannot access the file because it is in use by another process."
Files stored on a server
If this error appears when opening a file stored on a server, it's possible that another user has the same document open. Some network processes, such as backup or synchronization utilities, may also mark files as in use.
Troubleshooting
Error Message
Studio
Revu 20