Multiple "Save As" dialogs display when creating PDF from plugins or Bluebeam PDF printer

Applies to:

  • Revu 21
  • Revu 20
  • Revu 2019
  • Revu 2018

Problem

Printing to the Bluebeam PDF printer or using one of the plugins displays in multiple Save As dialogs displaying for old print jobs.

Cause

The temporary files created by printer and plugins aren't being removed after PDFs are created. These temporary files should be automatically removed. One reason why these files might remain is that the program was started using "Run as administrator" and then printed with the Bluebeam PDF printer. Remove the files by restarting the Port Monitor (bbprint.exe).

Solution

  1. In Revu, go to Revu > Administrator.
  2. Select the Printer tab.
  3. Select Clear Print Jobs.
  4. Under Port Monitor, select Stop and click Restart.
  5. Select Cancel if the Save As dialog displays for any old PDFs.
  6. Select OK.

If the prompts for the old PDFs continue after restarting the Port Monitor, follow the steps below to manually remove the temporary files:

  1. Open the Bluebeam Administrator.
  2. Press Windows+ R.
  3. In the Run dialog, enter %programdata%\Bluebeam Software\Print Jobs.
    The ProgramData folder is hidden by default. If the folder isn't visible, follow the steps on the Microsoft Support site to show hidden files.
  4. Delete any .mxB and .psB files in the folder.
  5. Open the folder labeled under your username.
  6. Delete any .mxB and .psB files in the folder.
  7. In Bluebeam Administrator, select the Printer tab.
  8. Under Port Monitor, select Stop and click Restart.

Troubleshooting

Revu 2018

Integrations & Plugins

Revu 20

Revu 21

Printing to the Bluebeam PDF printer or using one of the plugins displays in multiple Save As dialogs displaying for old print jobs.