Error: "A validated email address is required to login. A new validation email has been sent."

Applies to:

  • Revu 21
  • Revu 20

Problem

When you attempt to log in to Studio or join a Session/Project, you receive one of the following (or similar) error messages:

A validated email address is required to login. A new validation email has been sent.

Something's not quite right. Please check that your email, password, and region are correct. If your account isn't validated or you forgot your password, click 'Reset password or validate email' to complete your setup.

Cause

Your account wasn't validated via the link in your account validation email.

Solution

To validate your Bluebeam ID (BBID), reset your password to generate a new validation link and email.

  1. Go to your account settings page: ClosedSelect Account Settings Region
    US Region
    UK Region
    DE Region
    AU Region
    SE Region
  2. In the Sign In tab, enter your BBID.
  3. Select Reset password or validate email at the bottom of the Sign In screen.
  4. In the Reset password or validate email dialog, enter your BBID and select Send email.
  5. Check your email for a reset message and follow its instructions.
    If the email doesn't appear in your Inbox, please check your spam or junk folder and ensure do-not-reply@bluebeamops.com is on the approved list of senders.

If you continue to encounter issues, email support@bluebeam.com and attach a screenshot of your BBID validation email.

Revu 21

Revu 20

Troubleshooting

Error Message

Studio

Learn the steps to take if you receive a login error Something's not quite right. Please check that your email, password, and region are correct. If your account isn't validated or you forgot your password, click 'Reset password or validate email' to complete your setup.