Registration error: "The serial number and product key could not be validated"
Applies to:
- Revu 20
Problem
When attempting to register Revu, the following error message displays:
The Serial Number and Product Key Could Not be Validated.
Cause
This error appears because the serial number and product key entered were entered incorrectly or belong to another version or edition of Revu.
Solution
Check your license certificate
The first thing you should do is confirm that the following information matches your License Certificate from registration@bluebeamops.com:
- Edition (e.g. Standard, eXtreme).
- Version number (e.g. 20)
- Serial number
- Product Key
If you're unable to find your license information, see Find your Revu product key.
- If the installed software matches what's listed on the license certificate:
- Click OK in the error dialog box.
- Copy and paste the serial number and product key directly from the license certificate into the Registration dialog box.
- Click Register.The license codes contain characters that look alike which can be misread.
- If the installed software doesn't match what's on the license certificate, please follow these steps for replacing the current installation with the correct software:
A. Remove the current installation, if you need to install an older version of Revu:
- Click OK in the error message dialog box.
- Click Use as Trial or Cancel located at the bottom of the Registration dialog box so that the installation finishes.
- In Windows 11: Right-click Start, then click Apps and Features at the top.
Microsoft ended support for Windows 10, Office (2016-2019), and Outlook (2016-2019) on October 14, 2025. For optimal performance and compatibility, we recommend upgrading to the latest Microsoft products.
- Select Bluebeam Revu and click Uninstall.
- Follow the on-screen prompts to continue uninstalling the software.
B. Download and install the correct software:
- Locate and double-click the installer, follow the on-screen prompts.
- Copy and paste the serial number and product key from License Certificate into their corresponding boxes in the Registration dialog box.
- Click Register.
- Please contact us if the registration still fails, and be sure to include complete details about the problem along with the serial number and product key you're entering.
Troubleshooting
Revu 20
Error Message
Licensing & Registration
