Error: “Email already exists”

Applies to:

  • Revu 21
  • Revu 20

Problem

When you attempt to change the email address of your Studio account, you receive the following error:

Email already exists {0}

Cause

This error occurs when:

  1. You have an existing Bluebeam ID (BBID) with your original email address.
  2. You receive an invitation to a Studio Project or Session using a new email address.
  3. Studio automatically creates a placeholder account for this new email address.
  4. You attempt to update your existing BBID to use this new email address.

Since the new email address is already associated with the placeholder account, you can't use it for your existing account until you free up that email address.

Solution

To fix this issue, you'll need to complete two main tasks. First, activate the placeholder account that's already using your new email address. Then, change that account's email to something else, which frees up your new email for use with your original account.

Create the placeholder account for your new email address

  1. Go to the ClosedBluebeam Accounts page for your region.
    US Region
    UK Region
    DE Region
    AU Region
    SE Region
  2. Select Create Account and fill out the required fields.
    Be sure to use your new, desired email address.
  3. Select Create Account.
  4. Check the inbox of your new email address for a validation email, and select Confirm My Bluebeam ID to validate your account.

Free up the new email address

  1. Log out of the Bluebeam ID (BBID) you created above.
  2. Go to the ClosedBluebeam Accounts page for your region.
    US Region
    UK Region
    DE Region
    AU Region
    SE Region
  3. Log in with the BBID you created above.
  4. Select Change next to Email.
  5. Enter an unused email address, and select Save.
    Be sure to use an email address you have access to, such as a personal email address. This temporary email address is only being used to free up your desired email address for your original account.
  6. Check the inbox of your temporary email address for a validation email, and select Change My Bluebeam ID to validate your account.

Change the email on your original Studio account to your new email address

  1. Log out of all Bluebeam accounts on all devices.
  2. Go to the ClosedBluebeam Accounts page for your region.
    US Region
    UK Region
    DE Region
    AU Region
    SE Region
  3. Log in using your original email address and password.
  4. Select Change next to Email.
  5. Enter your final, desired email address, and select Save.
  6. Check the inbox of your new email address for a validation email, and select Change My Bluebeam ID to validate your account.

If you’ve completed this process and are still experiencing issues, please contact us for further assistance.

Troubleshooting

Revu 20

Revu 21

Studio

When you attempt to change the email address of your Studio account, you receive the following error: “Email already exists {0}”