Error: "Your trial will expire in 'x' amount of days" | Bluebeam Subscription Management
This article applies to:
- Revu 21
- Bluebeam Cloud
Problem
Even though you've purchased a subscription plan (Basics, Core, or Complete) and activated your account, you receive either of the following error messages when you sign into Revu 21:
- "Your trial will expire in 'x' amount of days."
- "You have x day(s) left on your trial."
Cause
If you signed up for a trial of Revu 21 and purchased a subscription before the trial end date, then the trial is still active alongside your official account.
Solution
Let the trial period run its course. After 14 days from signing up, your trial will expire, and your active subscription (Basics, Core, or Complete) should automatically appear under your account details when you log into Revu 21.
If your account doesn't automatically switch from the trial period to the subscription you purchased, please contact us here.
Bluebeam Cloud
Revu 21
Troubleshooting
Subscription Management
Subscriptions