検索パネル
Revu は、PDF を検索する 2 つの方法(テキスト検索とビジュアル検索)をサポートしています。
-
テキスト検索は一般的に高速で信頼性が高いですが、PDF 内の実際のテキスト要素に対してのみ機能します。例えば、スキャンされた PDF は画像であるため、その画像に単語が含まれていてもテキスト要素とは見なされず、テキスト検索は機能しません。スキャンされたドキュメントを検索可能にするには、OCR を実行します。 -
ビジュアル検索を使用すると、PDF 内のグラフィカルなシンボルを検索できます。テキスト検索よりも時間がかかる場合がありますが、テキスト検索にはない機能を提供します。
[検索] パネルでは、現在の PDF、開いているすべての PDF、フォルダ内の PDF、または [最近使ったファイル] リスト内のファイルから、テキストやビジュアルを検索できます。[テキスト検索] または [ビジュアル検索] を実行できます。検索と置換も可能です。
ウィンドウ> パネル>検索に行くか、Alt+1またはCtrl+Fを押して検索パネルを表示します。
テキスト検索で検索するには、PDF ファイル内にテキストが存在する必要があります。スキャンされた PDF ファイルは画像であり、テキストが含まれていないため、検索できません。スキャンしたドキュメントを検索可能にする方法の詳細については、OCR を参照してください。
- ウィンドウ> パネル>検索に行くか、Alt+1またはCtrl+Fを押して検索パネルを表示します。
-
選択
Text. - 最初のパラメータ現場に検索語を入力します。
-
2 番目のパラメーター現場のメニューから、検索するドキュメントまたは場所を選択します。オプションは、現在のドキュメント、現在のページ、開いているすべてのドキュメント、現在の Set、最近使用したファイル、フォルダー、または 現在の Studio プロジェクト です。
- [フォルダ] が選択されている場合は、パスボックスを使用するか、[参照] を選択してフォルダの場所を指定します。テキスト検索オプションで [サブフォルダを含める] を選択すると、指定したフォルダ内にあるフォルダも検索対象に含まれます。
- [現在のセット] オプションは、Set が開いている場合にのみ使用できます。開いている Set 内を検索するには、これを選択します。
- 現在のプロジェクトオプションは、プロジェクトにログインしている場合にのみ利用可能です。そのプロジェクトからすべてのローカル(ダウンロード済み)ファイルを検索するには、これを選択します。このオプションはファイル名検索のみに制限されています。現在、ドキュメントの内容を検索することはできません。
- [オプション] で利用可能な検索オプションを選択します。利用可能な正確なオプションは、最初のパラメータ現場で行った選択によって異なります。
- Select 検索.
長い検索が実行されると、[検索] タブの下部に進行状況バーが表示されることがあります。検索結果 が [結果] セクションに表示されます。
一部の検索結果には、追加の操作を実行できます。これらの結果の横にはチェックボックスが表示され、これらの操作のために一部またはすべてを選択できます。これらの追加操作の詳細については、「検索結果オプション」を参照してください。
- [サブフォルダを含める]:指定されたフォルダ内にあるサブフォルダを検索します。検索パラメータとして [フォルダ] が選択されている場合にのみ使用できます。
- ページを検索する:PDF のコンテンツ内のテキストを検索します。
- [ファイル名を検索]: 検索パラメータとして[最近使ったファイル] または[フォルダ] が選択されている場合に、[最近使ったファイル] リストまたは指定されたフォルダ内のファイル名を検索します。
- ファイルプロパティを検索:プロパティのメタデータ現場内のテキストを検索します。
- [フォームのフィールドを検索]:フォームのフィールドに入力されたデータ内のテキストを検索します。
- [マークアップを検索]: マークアップ内のテキストを検索します。
- 大文字と小文字を区別:検索語句現場に入力された通りの大文字と小文字の区別でテキストを検索します。
- [完全に一致する単語のみ]:検索語が単独の単語として存在する場合のみ検索します。検索語が他の単語の一部に含まれており、[完全に一致する単語のみ] ボックスがオンになっている場合、その単語は検索結果に含まれません。
検索結果は オプション セクションに表示されています。検索語は、その用語が見つかったフレーズで蛍光ペンで強調されています。PDFのページ番号は各結果の冒頭に記載されています。特定の検索結果を選択して、メインワークスペース内の用語の位置にジャンプします。
検索用語が複数のドキュメントで見つかった場合(例:すべての開いているドキュメントまたはフォルダで検索が実行された場合)、検索結果はドキュメントごとにグループ化されます。
一部の検索結果には、追加の操作を実行できます。これらの結果の横にはチェックボックスが表示され、これらの操作のために一部またはすべてを選択できます。これらの追加操作の詳細については、「検索結果オプション」を参照してください。
テキスト検索中にPDFコンテンツレイヤーに見つかったテキストは、結果ツールバーの
「チェック済み置換」ツールで置き換えることができます。メモ: この方法で置き換えられるのはPDFコンテンツレイヤー内のテキストのみです。マークアップはフラット化済みになるまでコンテンツレイヤーに存在しないため、フラット化されていないマークアップに含まれるテキストはこのツールで置き換えることはできません。この操作をフラット化済みマークアップを含むページで行う と、ページ上のすべてのマークアップがフラット化解除されるのを防ぎます。
- 置き換えたいテキストの テキスト検索 を実行します。
- [検索結果] から目的の結果を選択します。フラット化されていないマークアップ内のテキストなど、PDF コンテンツレイヤーの外で見つかった結果にはチェックボックスがなく、この操作で選択することはできません。
-
[結果] ツールバーで
[チェック済みを置換] を選択します。 - In 検索と置換 dialog, 置き換えテキストを「置換」現場に入力してください。
- 編集権限のないフォントを使用するテキストの処理方法を決定するには、フォント オプションのいずれかを選択します。このような置換を スキップ するか、リストから別のフォントを選択して 使用 することができます。
ビジュアル検索を使用して、ドキュメント内に表示されるビジュアルオブジェクトのすべてのインスタンスを検索します。
PDF でビジュアル検索を実行する方法については、[ビジュアル検索の概要] を参照してください。
- [感度]: 有効な結果と見なされるために、画像がどの程度一致する必要があるかを決定します。スライダーを調整して、感度を低くまたは高く設定します。感度を下げると、隣接する線のようなわずかな違いがある一致も許容されますが、いいえの誤検知が発生する可能性もあります。
スキャンから作成された PDF を操作している場合、PDF 内に不要なピクセルや背景ノイズが含まれている可能性があるため、感度を下げる必要があるかもしれません。
- [複数の回転を検索]:0度、45度、90度、135度、180度、225度、270度の回転でシンボルが検索されます。
- 色でフィルタ:色を微調整ボタンを有効にします。検索では、選択範囲に含まれていない(またはヒストグラムの選択範囲内にない)色がフィルタリングされます。
-
[選択範囲で制限]: ベクター PDF 上で、このオプションは以下の例に示すように、選択した四角形からはみ出しているベクターオブジェクトを除外します。
- [感度]: 有効な結果と見なされるために、画像がどの程度一致する必要があるかを決定します。スライダーを調整して、感度を低くまたは高く設定します。感度を下げると、隣接する線のようなわずかな違いがある一致も許容されますが、いいえの誤検知が発生する可能性もあります。
スキャンから作成された PDF を操作している場合、PDF 内に不要なピクセルや背景ノイズが含まれている可能性があるため、感度を下げる必要があるかもしれません。
- [複数の回転を検索]:0度、45度、90度、135度、180度、225度、270度の回転でシンボルが検索されます。
- 色でフィルタ:色を微調整ボタンを有効にします。検索では、選択範囲に含まれていない(またはヒストグラムの選択範囲内にない)色がフィルタリングされます。
-
[選択範囲で制限]: ベクター PDF 上で、このオプションは以下の例に示すように、選択した四角形からはみ出しているベクターオブジェクトを除外します。
検索結果は [結果] セクションに表示されます。検索結果のグラフィックと、その周囲の小さな面積が結果リストに表示されます。画像を選択すると、メインの PDF ワークスペースが切り替わり、その結果とその周辺の面積が表示されます。
VisualSearch の検索結果の操作は テキスト検索の結果 の操作と似ていますが、テキストベースのアクションはサポートされていません。さらに、VisualSearch の結果に 数の測定 を適用することもできます。
- カウントする結果を選択します。
-
[アクション] メニューから
[チェック項目に数の測定を適用] に移動し、選択した結果に適用する目的のカウントシンボルを選択します。
テキスト検索とビジュアル検索の両方で、これらのオプションを使用して検索結果を管理します。
[すべてを選択]: 追加の操作を実行できるすべての結果アイテムを選択します。これにより、複数のドキュメントにわたる検索結果の用語に対して、一括変更を簡単に適用できます。すべての検索結果に対して追加の操作を実行できるわけではないことをメモしてください(たとえば、フラット化されていないマークアップからの検索結果は、これらの操作から除外されます)。
[チェックのオプション] メニュー:チェックされたすべての項目に対して一度に実行できるコマンドが含まれています。これらのコマンドは、個々の検索結果を右クリックし、コンテキストメニューからコマンドを選択することでも実行できます。
-
[チェック項目にハイパーリンク]: 選択した各結果に対して ハイパーリンク を作成します。
-
[墨消し範囲を指定]:選択した各結果を 修正 します。
-
[チェック項目に数の測定を適用]:選択した各結果に 数の測定マークアップ を追加します。表示されるメニューからカウント記号を選択します。
-
チェック項目に蛍光ペン:選択された各結果に黄色の 蛍光ペンマークアップを適用します。
-
[チェック項目に下線]: 選択した各結果に [下線] マークアップを適用します。
-
[チェック項目に波下線]:選択した各結果に 波下線マークアップを適用します。
-
[チェック項目に打ち消し線]: 選択した各結果に [取り消し線] マークアップを適用します。
チェックした項目を置換: テキスト検索で見つかったテキストを別のテキストに置き換えることができます。検索と置換を参照してください。
[検索結果をクリア]:現在の検索結果リストをクリアします。