Revu 21 Administration Guide | Revu 21

revu
Bluebeam® Revu 21® Administration Guide

This article applies to:

  • Revu 21

Jump to other versions:

Introduction

This guide gives IT administrators the knowledge, self-sufficiency, and freedom to manage and troubleshoot all aspects of Bluebeam Solutions across your organization.

In this guide, we cover topics such as: subscription plans, single sign-on (SSO), Studio, firewall and proxy settings, Revu and document management system (DMS) configurations, as well as Revu settings and preferences.

Complete instructions for deploying Revu in your organization can be found in the Revu Deployment Guide. For more information about subscription rollout, please see the Bluebeam Subscription Implementation Guide.

Subscription

Bluebeam Plans

The features available in Revu 21, as well as the features available in Bluebeam Cloud, are now determined by which of the following subscription plans is associated with a named-user license: Basics, Core, or Complete. With our new subscription-based model, users will need to log in with a Bluebeam ID (BBID) to access Bluebeam Solutions. To learn how to create a BBID, visit this article.

Bluebeam Subscription Management Portal

The Bluebeam Subscription Management Portal is an online administrative tool for organization admins (Org Admins) to manage their users’ named-user licenses and their subscription access. From here, Org Admins can allocate Bluebeam subscription seats, change subscription packages, manage other admins, and more. Learn how to manage subscriptions and users via the portal with the Bluebeam Subscription Management Guide.

Bluebeam Cloud

Any users with access to Revu 21 will also be able to use Bluebeam Cloud, our new mobile/app collaboration offering. Bluebeam Cloud encompasses current and future cloud-based solutions—including Bluebeam’s powerful Field Tools for managing punch, RFIs, and submittals on the go. This will enable your users to better build, manage, and deliver projects on time with enhanced productivity and a single system of record.

Revu accounts vs. Studio accounts

Ideally, users will have one BBID to log into all things Bluebeam. However, if a user’s subscription is connected to a different BBID from where their Studio Projects and Sessions are stored (or if they have BBIDs for different Studio regions), they can activate their Revu features with one BBID and sign into Studio with another.

Offline Mode

Users with a Revu 21 subscription can temporarily work offline if they lose internet connection for up to 14 days.

Single sign-on

Single sign-on (SSO) is in an early access phase. SSO is available only to active customers who have purchased or converted a minimum of 100 seats to a Bluebeam subscription plan.

Single sign-on (SSO) allows users to leverage a Non-Bluebeam Federated Directory for authentication and identity with Bluebeam Solutions (i.e., Revu 21, Studio, and Bluebeam Cloud). Bluebeam SSO can be set up in both Microsoft Azure AD and Okta environments. If implemented, SSO provides a better sign-in experience for your employees as well as improved security, risk, and user management for your IT teams.

SSO configuration supports multi-factor authentication (MFA) as defined by the identity provider.

Bluebeam Studio

Bluebeam Studio is our cloud-based collaboration platform that helps teams and organizations manage work projects. Users can create and join Studio Sessions and Studio Projects, then upload PDFs and other file types, allowing them to collaborate with their partners in real time. With Revu 21, users can sign into Studio with a separate BBID from the one that designates their subscription plan.

Bluebeam Studio Portal

With the Bluebeam Studio Portal, users can manage their Bluebeam Studio accounts. After they’ve logged in with their Studio account credentials, they can perform the following tasks:

  • Manage their Studio Profile
  • Email address changes
  • View a list of Sessions they have created
  • Reassign ownership of their Sessions
  • View a list documents in their Sessions
  • View lists of attendees for their Sessions

Additional Resources

For more information about Bluebeam Studio, check out the following guides and articles in our knowledge base:

If you have additional questions about Studio functionalities or issues, please contact us.

The Bluebeam Administrator

The Bluebeam Administrator lets you configure Revu using the features on the various tabs as described in the following sections. These settings can be pushed out to your end-user machines as a means of standardizing your post-deployment customizations.

The Bluebeam Administrator must be able to run with elevated privileges, and your firewall and proxy server should not prevent it from connecting to the internet.

Further information can be found in the Bluebeam Administrator Help Guide.

Plugins Tab

This tab displays a list of installed applications that are supported by our PDF plugin, which are detected by the “Bluebeam Admin User.exe” that launches when the client machine starts up.

All Revu subscription tiers will list the plugins for Microsoft Office (Word, Excel, Power Point, and Outlook). While the plugins for AutoCAD, Revit, SolidWorks, and Navisworks will also be listed, they will only function for Core and Complete subscription tiers.

Revu 21 Side-By-Side Installation

Revu 21 can be installed and run side-by-side with Revu 2019 and above, which gives your users access to two fully functional versions of Revu. This allows users to evaluate Revu 21 while your organization decides whether or not it’s time to upgrade.

All plugin activations and deactivations must be done in Bluebeam Administrator 21 if you are running side-by-side installations of Revu.

Enabling a Plugin

You can find more information about troubleshooting plugin issues on this page, but if a plugin is missing within a supported application, you can enable it by following these steps:

  1. Close the application
  2. Go to Start > All Programs > Bluebeam Software > Bluebeam Administrator 21. You can either:
    • Select Start and type Bluebeam Administrator 21.
    • Go to Help > Administrator in Revu.
  3. Select the Plugins tab.
  4. Select the check box next to the name of the program.
  5. Select OK.
  6. Reopen the application.

Net Configurations Tab (Net Config)

This tab allows you to set the location of various Revu settings and assets. They can remain in the default local folders listed in the Unmanaged section, or they can be accessed from a centralized server location which you can set in the Managed Net Configuration section. However, you can also configure Revu to use a combination of local and network locations based on folder paths you define in the Unmanaged section.

Unmanaged Net Configurations

In a typical Revu installation, the Unmanaged option is enabled by default. In this instance, the assets and settings are in various locations within the user’s Windows profile under C:\ProgramData as shown in the screenshot.

E-mail Templates uses a different default folder: C:\Users\Documents\Bluebeam\E-mail

Managed Net Configuration

To configure your Revu installations to access all settings and assets from a centralized server location:

Select a computer to use as a “staging” machine and copy any custom settings or assets into their corresponding default locations that are listed when the Unmanaged option is enabled. Refer to the screenshot of the Unmanaged settings above.
You can easily open the default folder locations by double-clicking on their corresponding folder paths.

  1. When you have finished copying the items, enable the Managed Net Configuration option. A dialog will open, where you can either browse to an existing network folder you want to use as the centralized location or create a new network folder.
  2. In either case, select the folder and press the Select Folder button.
  3. When the Copy All Files dialog opens click one of the following three choices:
    • Copy All, which creates folders for the asset type or setting in the server location, and copies everything to the correct location.
    • Merge, which takes all locally defined settings and resources and merges them with any existing items in the shared location.
    • No Copy, which points to the network folder, but does not copy or integrate anything into the folder. Once the operation has completed, the Net Config tab will display the locations of all assets and settings.
If you want to prevent your end users from making changes to the centralized network folder, you can set the folder permissions to Read Only.

Affected Registry Keys

The following five registry keys are altered whenever you make changes in the Net Config tab:

The folder paths shown below are for demonstration purposes only.
[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins]"ManageNetConfig"="1""ManageNetConfigPath"="U:\\netconfig\\"

 

[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Brewery\V45]"PageSizeConfigFile"="U:\\netconfig\\PtrPageSizes\\"

 

[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins\AutoCAD]"PC3Path"="U:\\netconfig\\PC3"

 

[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins\Email]"TemplateFolder"="U:\\netconfig\\E-mail\\"

 

[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins\PageSetup]"ConfigFolder"="U:\\netconfig\\Page Setup\\"

Deploying a Managed Configuration

The Bluebeam Administrator creates a registry file named Netcfg.reg containing all affected registry keys. This file is located in the root of the managed folder (U:\netconfig in the preceding example), and it can be distributed as part of an MSI deployment as described in the Revu Deployment Guide.

You can deploy this registry file to individual workstations to quickly apply the managed configuration.

When distributing a Managed Net Configuration as part of an MSI deployment, the changes will not take effect until the client machine is restarted. However, a restart is not needed when manually configuring an individual machine.

When updating the path within Managed Net Configuration or within Revu Preferences Net Configuration, Revu must be closed and re-opened in order for changes to take effect.

Printer Tab

This tab is divided into four sections (Printer Options, Printer, Port Monitor, and Image Resolutions) which offer features and functions for controlling and reinstalling the Bluebeam PDF printer.

Printer Options

These options determine what happens during and after a PDF is created using the PDF Printer or the Stapler.

Prompt for File Name

When this option is enabled, a Save As dialog will appear, prompting the user to enter a file name, and if needed, choose a destination for the new PDF.

Delete Source PS File

This option is disabled by default. When the option is enabled, the PostScript file a PDF is based on will be deleted once the document has been produced.

Open in Viewer

This setting determines whether the new PDF will be open in the default PDF application on the user’s machine.

Stapler Context Menu

When this option is enabled, the Combine Files in Revu and Convert Files in Revu options will be available when the user right-clicks on an applicable file on their desktop or in the File Explorer.

The user must have Administrative rights on the machine in order to change this setting.

Folder Options

Selecting Folder Options opens the Folder Options dialog which lets you select the default location to save new PDFs produced using the Bluebeam Stapler. The available options are:

  • Source Folder: the location of the original source file.
  • Last Saved Folder: the last folder that a new PDF was saved to.
  • Custom Projects Folder : this option lets you specify a different default location.
Image Resolutions

The Resolutions list shows the image resolutions that will appear in the Save As window for the Bluebeam PDF printer, Stapler, and Bluebeam Plug-ins.

Printer

In addition to displaying the printer name, driver, and printer port, the printer section allows you to select the default page size from the available list of pages sizes. You can also use the Manage Pages button to edit the page size list as described below.

In addition, you can uninstall and reinstall the Bluebeam PDF printer using the Reinstall Printer button when troubleshooting performance issues.

Manage Pages

Clicking the Manage Pages button opens the Page Sizes dialog, where you can add, delete, or edit page sizes used by Revu, the PDF printer, Stapler, and plugins.

These are the same page size settings (PrtPageSizes.xml) that are copied from their default location (%ProgramData%\Bluebeam Software\Bluebeam Revu\21\Brewery\V45\Printer Support) when setting up a Managed Net Configuration.

Reinstall Printer

If a user runs into an issue with either the Bluebeam PDF printer or Stapler, such as the Save As dialog not appearing when creating a PDF, one of the things you’ll need to do is use the Reinstall Printer button to reinstall the PDF Printer.

If this doesn’t work, you can also right-click the Reinstall Printer button and select Install Printer.

Once you install the Bluebeam PDF printer, you should go into the Devices and Printers section of the Windows Control Panel to make sure it’s also installed there.

Port Monitor

The Port Monitor is based on the BBPrint.exe process which runs on a per-user basis, and watches the user’s printer folder (C:\ProgramData\Bluebeam Software\Print Jobs\) for files to process.

Assuming that BBPrint.exe is enabled as a Startup item, it’s quite likely that the Port Monitor isn’t running if the Save As dialog never appears, or a user is otherwise unable to produce PDFs using the Bluebeam PDF printer or Stapler. In that case, the Port Monitor Status box will display “<n/a>”. You can restart the Port Monitor by following the instructions in the next section.

Restarting the Port Monitor

If the Port Monitor Status shows as <n/a>, or the Save As dialog is not being displayed while creating PDF, restart the Port Monitor. Once it’s running again, the Status should display as Responding, and BBPrint.exe should be listed as a running process in the Windows Task Manager.

AutoCAD Page Sizes Tab

This tab is available for Core and Complete subscribers on machines that also have a compatible AutoCAD product installed on them.

You can use the checkboxes to select the page sizes (ANSI, ARCH, or ISO) that you want to make available on the Page Setup tab of the AutoCAD plugin.

ANSI, ARCH, and ISO Checkboxes

As an alternative to clicking the individual checkboxes, you can use the ANSI, ARCH, and ISO checkbox to select or deselect whole groups of size types.

PDF Type

The PDF Type dropdown lets you decide which printer driver will be used when creating PDFs from AutoCAD.
Your choices are either the default PDF driver or the Heidi (AutoCAD HDI) driver, which are explained below:

Printer

This option uses the Bluebeam PDF printer, which supports TrueType fonts for creating PDFs from AutoCAD with searchable text. In addition to offering better image quality, this driver also lets you add more Page Sizes and synchronize them across your network for use by all of your Revu Core and Complete users.

Heidi

The Heidi option uses the AutoCAD HDI driver which doesn’t support TrueType fonts and “draws” non-searchable text as Vector data. However, you can create custom Page Sizes and synchronize them across your network for use by all of your Revu Core and Complete users.

Synchronizing Page Sizes Across Your Network

If you’d like to centralize your custom page sizes for all Core and Complete users, follow the steps listed below based on whether or not your organization used the Bluebeam PDF printer or the AutoCAD Heidi driver:

  1. Synchronizing Page Sizes for the Bluebeam PDF Printer
  2. Select a computer to use as a staging machine, and create your custom Page Sizes on it.
  3. Go to the Net Config tab.
  4. Click the ellipse located to the right of the default folder path for the Printer Driver.
  5. A dialog will open where you can either browse to an existing network folder you want to use as the centralized location, or create a new network folder.
  6. Select the folder and click Select Folder.
  7. When the Copy all Printer Page Size Files dialog opens, click Copy All.
    This copies the prtPages.xml file from the default location on the local drive to the network location, and the new folder path for the Printer Driver will be listed on the Net Config tab.
  8. Click Apply, and click OK.
Configuring Other Machines to Use the Centralized Page Sizes for the PDF Printer

This setting can be distributed to other Core and Complete subscribers as part of an MSI deployment, or you can manually configure individual machines by following the steps listed below:

Note: Centralized PC3 files cannot be used when the PDF Type is set to Printer. They can only be used when the Heidi driver is selected.

If this is distributed as part of an MSI deployment, the changes will not take effect until the client machine is restarted. A restart isn’t required when manually configuring an individual machine.

  1. Open Bluebeam Administrator and go to the Net Config tab.
  2. Click the ellipse located to the right of default folder path for the Printer Driver.
  3. When the File Explorer opens, locate and click on the network folder which contains the prtPages.xml, and then click Select Folder.
  4. When the Copy all Printer Page Size Files dialog opens, click No Copy.
  5. Click Apply, and click OK.
Synchronizing Page Sizes for the Heidi Driver
  1. Select a computer to use as a staging machine, and create your custom Page Sizes on it.
  2. Click the Net Config tab, then double-click the folder path for the Heidi Driver.
    A dialog will open where you can either browse to an existing network folder you want to use as the centralized location, or create a new network folder.
  3. Select the folder and click Select Folder.
  4. When the Copy all Bluebeam PC3 Files dialog opens, click Copy All.
  5. This copies the PC3 files from the default location on the local drive to the network location, and the new folder path for the Heidi Driver will be listed on the Net Config tab.
  6. Click Apply and OK.
Configuring Other Machines to Use the Centralized PC3 Files

This setting can be distributed to your other Revu Core and Complete clients as part of an MSI deployment as described in the Revu Enterprise Deployment Guide, or you can manually configure individual machines by following the steps listed below:

Centralized PC3 files can only be used for the AutoCAD plugin if the Heidi driver is selected. Centralized PC3 files cannot be used for the Bluebeam PDF printer.

If this is distributed as part of an MSI deployment, the client machine must be restarted before it can be used.

  1. Open Bluebeam Administrator and go to the Net Config tab.
  2. Click the ellipse located to the right of default folder path for the Heidi Driver.
  3. When the File Explorer opens, locate and select the network folder which contains the PC3 files, and then click Select Folder.
  4. When the Copy all Bluebeam PC3 Files dialog opens, click No Copy.
  5. Click Apply, and click OK.

Affected Registry Keys

The following two registry keys are altered when the PDF Printer pages sizes and PC3 files are centralized:

The folder paths shown below are for demonstration purposes only.
[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Brewery\V45]"PageSizeConfigFile"="U:\\netconfig\\PtrPageSizes\\"
[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins\AutoCAD]"PC3Path"="U:\\netconfig\\PC3"

Support Logs

If you’re experiencing issues with Revu or its plugins, there are multiple ways to access the relevant logs, and if needed, email them to our Technical Support group.

View log files

  • Bluebeam Administrator – Help > Explore Log Folder
  • Revu – Revu > Preferences > Admin > Options > Explore Log Folder

Email logs to Bluebeam Technical Support

  • Bluebeam Administrator – Help > Email Logs to Support
  • Revu – Help > Report an Issue > Yes
You can only toggle Extended Debugging in Revu Preferences.

Application Logs

These log files record the activities of the various Revu application components. You can open each log file by clicking its corresponding hyperlink.

Plugin Logs

This group of log files record the activities of any enabled plugins for supported applications. Each enabled plugin will have a corresponding hyperlink which you can click to open the log file.

Explore

This button opens the folder within the current Windows user profile where all the log files are stored.

Email Logs to Support

This button is used for submitting your log files to our Technical Support group.

Before sending in the log files, please try to reproduce the issue.

This creates new log entries that are specific to the issue. Clicking it creates a zip file (logs.zip) containing the complete set of log files for all Revu components and plugins. This is attached to a new email, addressed to support@bluebeam.com.

If the email doesn’t open, or you’re using a webmail account, you can follow the directions to View log files above and manually attach the logs.zip file to an email addressed to support@bluebeam.com.

In either case, please include as much information as possible about the problem you’re experiencing.

Reset Settings

Running this option resets the software to the default state based the settings found in C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\{Revu-version-number}\Revu.

C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\"PbMngr5.exe" /reset - Resets Revu settings

When running a reset of the Revu settings, the Backup.zip file is created in %Appdata%\Roaming\Bluebeam Software\Revu\21\

This applies to resets initiated in the following ways:

  • Revu > Preferences > Admin > Reset
  • Bluebeam Administrator Console > Help > Reset Settings
  • The Command Line.

Administrator Console Application

The console application allows administrators to perform the following administrative functions via command line using the PbMngr5.exe application.

The following Command Line Options need to be executed with elevated privileges. Select Start, type CMD, and then right-click Command Prompt and select Run as Administrator.

Administrative Functions

The PbMngr5.exe executable allows Administrators to perform the following Administrative functions via the command line:

  • Install Plugins
  • Set Revu as the Default Application
  • Reinstall/Uninstall our Bluebeam PDF Printer
  • Set default DPI for the Bluebeam PDF Printer
  • Setup Net Config
  • Reset/Restore/and Backup user’s settings

Examples of these commands are below:

Backup Settings

This option backs up your current Revu settings to a .zip file and saves it to a location of your choice, which is useful when migrating settings to another machine.

Stamps and pinned items in the File Access tab are not backed up during this process.

Backup

Creates a zipped file named Backup in root of C:\ :

C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\"PbMngr5.exe" /backup "C:\backup.zip"

Reset Settings

Running the option below resets the software to the default state based on the settings found in C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\{Revu-version-number}\Revu:

C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\"PbMngr5.exe" /reset
Running a Reset of the Revu Settings, creates the Backup.zip file within %Appdata%\Roaming\Bluebeam Software\Revu\21\ This applies to running a Reset from within Revu > Preferences > Admin > Reset, Bluebeam Administrator Console > Help > Reset Settings, and via the Command Line as shown above.

Restore Settings

Running this option lets you restore select Revu settings, which is an integral part of migrating Revu settings from one machine to another:

C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\”PbMngr5.exe” /restore “C:\backup.zip” – Restores Revu settings from zipped file named backup.zip in root of C:\

Printer Reinstall

Running this command reinstalls the Bluebeam PDF Printer.

C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\"PbMngr5.exe" /reinstallptr

Administrator Console Features

To see more details about the available features within the Administrator Console, follow these steps:

  1. Click Start and type CMD.
  2. Open the command prompt.
  3. In the command prompt type “C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu.”
  4. Type: PbMngr5.exe /help.
  5. Press Enter.

This procedure opens the latest Help file for the application. The available options are as follows:

/help or /? Shows command line help for PbMngr5.exe.
/printername Displays the printer name used by Bluebeam Revu.
/printerdpi <number> Sets the default DPI of the Bluebeam PDF printer.
/reinstallptr Reinstalls the Bluebeam Printer.
/uninstallptr Uninstalls the Bluebeam Printer.
/reset

Resets Revu settings. Make sure to back up settings before.

Ex: C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\”PbMngr5.exe” /reset

/backup <zipfile>

Backs up Revu settings.

Ex: C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu\”PbMngr5.exe” /backup “C:\backup.zip” – Creates zipped file named Backup in root of C:\

/restore <zipfile> Restores Revu settings.
/setup [parameters] Setup is used to initialize Bluebeam Revu.
/DVON Makes Bluebeam Revu the default pdf editor.
/DVON32 Makes Bluebeam Revu 32-bit the default pdf editor.
/DVOFF Resets the default pdf editor. Required parameter to avoid changing default viewer to Revu.
/IF:

Bitwise flags to install plugins in:

Office(1), AutoCAD(2), AutoCAD Lt(4), SolidWorks(8), Revit(16), IE(32), ProjectWise(64), Outlook(128), Sketchup(256)

/DPS:[A4 or Letter] Default page size to use with Bluebeam PDF printer.
/NCPATH:<path> Netconfig path.
/JOPATH:<path> Job options path.
/PREFSPATH:<path> Path to a Bluebeam Revu preferences setup file.
/ANALYTICS Enables data concerning the usage of Revu to be captured and automatically sent to Bluebeam servers. No user data is captured or transmitted.
/QLINKON Enables the Quantity Link plugin for Excel.
/QLINKOFF Enables the Quantity Link plugin for Excel.
/latest Use the latest installed version of Bluebeam Administrator to execute the command line.

Revu Preferences – Admin

Some features that were previously found in the Bluebeam Administrator have been moved to the Revu Preferences under the Admin section, including Reset Settings, Backup Setting, Logging, and client-specific Net Config settings.

Options Tab

The Options Tab contains the following features:

  • Default PDF Viewer
  • Explore Log Folder
  • Extended Debugging
  • Settings
  • Reset
  • Backup
  • Restore
  • Default PDF Viewer
  • Opens the Default Apps window

Default PDF Viewer

Opens the Default Apps window. To make Revu the default PDF viewer:

  1. Select Choose default apps by file type.
  2. Select .pdf.
  3. Select Bluebeam Revu.

Explore Log Folder

Opens the pathing to the Revu log files. The log files can be found here: C:\Users\AppData\Local\Bluebeam\Revu\21\Logs

Extended Debugging

Selecting this option turns on verbose logging in the application.

Settings – Reset

When you select this option, you will be prompted to close Revu. After selecting OK in the dialog window:

  • Revu will automatically close.
  • The user settings will be reset.
  • Once the process is completed, Revu will automatically restart.
  • You can select Cancel to stop the process.

When running a Reset of the Revu Settings, the Backup.zip file is created in %Appdata%\Roaming\Bluebeam Software\Revu\21\
This applies to running a Reset from within Revu > Preferences > Admin > Reset, Bluebeam Administrator Console > Help > Reset Settings, and via the Command Line.

Settings – Backup

After selecting this option, a Save As dialog appears.

If you select a directory and then click Save, a .zip file containing a backup of Revu settings will be saved to the selected location..

Settings – Restore

This option restores settings from a backup .zip file.

  1. After clicking Settings — Restore, you will be prompted to close Revu.
  2. Select OK.
  3. Select the backup .zip file.
  4. Click Open

Once the Restore is complete, Revu will automatically restart.

Net Config Tab

The Net Config tab contains the following options:

  • Stamps pathing
  • Email Templates pathing
Pathing will change if new pathing is selected under Stamp > Change Stamp Folder

The default path for Stamp files is ProgramData\Bluebeam Software\Bluebeam Revu\21\Stamps. You can choose a different Stamp folder by clicking Browse and selecting the desired folder.

The default path for Email Templates is C:\Users\Documents\Bluebeam\E-mail. You can choose a different Email Templates folder by clicking Browse and selecting the desired folder.

Revu Preferences and Settings

The Preferences dialog is used for customizing Revu settings for a single workstation, or for an organization.

For example, you might go to Interface > File Access to configure a connection to Microsoft SharePoint or Bentley ProjectWise, which you will then deploy to your user population.

Or, if your organization uses Studio U.K. to host Sessions and Projects, you can set up this connection from the Studio section.

Exporting Revu Preferences

If you want to use a set of Revu Preferences across all or part of your organization, you can click Export in the lower left of the Preferences dialog and save them to a network share. The RevuPrefences.xml can be distributed by following the process outlined in the Revu Deployment Guide.

Revu Profiles

Profiles contain information about the overall layout of the Revu interface, such as toolbar positions, Tool Chest contents, and panel configurations.

Best Practice: If you’ve created your company Profiles in an older version of Revu, and haven’t updated them in several years, it is a good idea to recreate those Profiles in the latest version of Revu. Otherwise, you may have compatibility issues.

Exporting Profiles

Complete instructions for managing, exporting, and importing Revu Profiles can be found in the Revu Manual, but once a Profile is created, configured, and saved, it can be exported to a central location by clicking Export in the Manage Profiles dialog. After this, it can be deployed by following the process in the Revu Deployment Guide.

You can also import a profile into a Revu installation by navigating to its location and double-clicking the .bpx file. You can also import it by clicking Import in the Manage Profiles dialog, selecting the file, and clicking Open.

Include Dependencies

Selecting this checkbox before clicking Export embeds the following items into the Profile:

  • Tool Sets
  • Custom Columns
  • Custom Statuses
  • Bookmark Structures™ (Revu Complete only)

Using Shared Profiles on a Network Location

If you do not want to import a profile into Revu, you can link to its location on a centralized network location accessible to all users. To do this:

  1. Open the Manage Profiles dialog and click the Browse button located to the right of the folder path displayed in the Location box.
  2. Navigate to the folder, click it, and then click Select Folder.
Shared Profiles are read-only. Any changes made by a user (such as turning toolbars on or off) are lost when Revu is closed.

Read-Only Profiles

By default, Revu remembers the last known state or layout of the user interface when the application is closed. Changes — such as enabling a tool bar or hiding the Properties tab — are saved to the active Profile. If your organization uses shared Profiles as described above, you will want to prevent this because it overwrites the shared Profile, which can adversely affect other people who are using it. To do this:

  1. Navigate to the network location of the Profile.
  2. Right-click the Profile and select Properties in the pop-up menu.
  3. Select the Read Only checkbox, and then select Apply and OK.

The Tool Chest

Essentially, the Tool Chest is a convenient location where users can save and organize markups into Tool Sets. More in-depth information about the Tool Chest can also be found in the Revu Manual.

In Revu 21, users can send their tool chests to Bluebeam Cloud, so they can access their custom markups on-the-go. To learn more, visit this article.

Managing Tool Sets

All tool sets are saved as .btx files that can be copied to a network drive or sent directly to users. As with Profiles, tool sets can be imported directly into Revu by double-clicking a .btx file, or from the Manage Tool Sets dialog.

Best Practice: If you’ve created your company Profiles in older version of Revu, and have not updated them in several years, it is a good idea to recreate those Profiles in the latest version of Revu. Otherwise, your may have compatibility issues.

To export a Tool Set, open the Manage Tool Sets dialog, select the Tool Set, and click Export. When the Save As dialog opens, select the destination folder for the Tool Set, and click Save. If your users will be sharing this Tool Set, save it to a network location they can access.

You can also distribute Tool Sets using a command line script, as described in the Revu Deployment Guide.

Using Shared Tool Sets on a Network Location

If you do not want to import a profile into Revu, you can “link” to its location on a centralized network location accessible to all users. To do this you’ll need to follow the steps listed in the Revu Manual.

Although Tool Sets located in a shared network location can be used while a user is offline, they cannot be updated or checked out.

Locked Tool Sets

A locked Tool Set appears in the Tool Chest with a blue padlock   located to the right of its name. As the Administrator, you can grant any user write permissions to the file and set others to read-only. A user with write permissions to the Tool Set will be able to check out the file and add changes. Any changes made to a Tool Set will affect all users sharing that Tool Set.

If a user is designated as read-only, that user can’t make any changes to the Tool Set or unlock it for changes. Users marked as read-only must contact the Admin and request permission to check out the Tool Set.

Specific user permissions can be modified on a Tool Set by following the steps below:

1. Go to the network location of the Tool Set.
2. Right-click the Tool Set (.btx) and select Properties. The properties dialog box appears.
3. Go to Security and select Edit under Group or user names.
4. Modify existing users/groups or add new users/groups.
5. Press Apply, and click OK.

Read-Only Tool Sets

If you want to prevent changes to a shared tool set, you can set its properties to read-only by doing the following:

  1. Navigate to the network location of the Tool Set.
  2. Right-click the Tool Set and select Properties in the pop-up menu.
  3. Fill the Read Only checkbox, and then click Apply and OK.

Hatch Patterns

Revu includes several standard Hatch Patterns used for filling in markups, which can be exported, imported, or added in the same manner as Tool Sets. These Hatch Pattern (.bhx) files can also be exported to a centralized network location from which they can be deployed to your Revu installation.

You can find details about deploying Hatch Patterns within your organization in the Revu Deployment Guide. Information about managing exporting, importing, adding, or otherwise working with your hatch patterns can be found in the Revu Manual.

SharePoint and ProjectWise Integration

Revu has direct integration with Microsoft SharePoint and Bentley ProjectWise document management systems (DMS).  From Revu, you can check in, check out, and view files from either a ProjectWise DataSource or a SharePoint Document Library.

Logging In

By default, whenever you log into a SharePoint site, the first login attempt will use your Windows account credentials. If the attempt fails, you will be prompted to enter credentials. To ensure a smooth authentication, Revu can store the correct credentials for you within the Revu File Access Preferences. However, these credentials will not be included in the RevuPreferences.xml export file.

The Revu Manual includes more in-depth information about setting up SharePoint or ProjectWise integration, but the basic steps are:

  1. Go to Revu > Preferences (Ctrl+K)
  2. In the Preferences dialog, go to Interface > File Access.
  3. Click the + symbol in the File Access dialog. This opens the Add Document Management Systems dialog.
  4. Select the type of DMS you’re to configuring, and then enter the login credential and any other required information.
  5. Click OK.

Bluebeam, Revu, and Bluebeam Studio are trademarks or registered trademarks of Bluebeam, Inc. Microsoft, SharePoint, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

AutoCAD is a registered trademark of Autodesk in the United States and/or other countries.

© 2019 Bluebeam, Inc. All Rights Reserved.

All other trademarks or registered trademarks are the property of their respective owners.

How-To

Revu 21

Deployment

In this guide, IT administrators can learn about subscription plans, single sign-on (SSO), Studio, firewall and proxy settings, Revu 21and document management system (DMS) configurations, and Revu 21 settings and preferences.

Related Articles