Bereitstellungsanleitung zu Bluebeam® Revu® 21

revu
Bereitstellungsanleitung zu Bluebeam® Revu® 21

Dieser Artikel bezieht sich auf:

  • Revu 21

Zu anderen Versionen wechseln:

Download der Bereitstellungspakete (MSI)

Laden Sie zunächst das 64-Bit-Bereitstellungspaket herunter, bevor Sie fortfahren. Diese Pakete enthalten alles, was Sie für eine erfolgreiche Bereitstellung benötigen. Eine Auflistung der Komponenten in diesen Paketen finden Sie unter Planung Ihrer Bereitstellung.

Revu 21 herunterladen

64-Bit-Version herunterladen

Suchen Sie nach einer älteren Version?

Einleitung

Große Unternehmen stehen in der Regel vor einer Vielzahl von Herausforderungen wie der Suche nach der effizientesten Bereitstellungsmethode oder der ordnungsgemäßen Konfiguration einer Anwendung für den Einsatz in einer vernetzten Umgebung mit mehreren aktiven Benutzer:innen. Auf den folgenden Seiten finden Sie Anweisungen zur Planung, Implementierung und Bereitstellung von Bluebeam Revu in Ihrer Organisation.

Diese Anleitung wurde für IT-Administrator:innen geschrieben, wobei vorausgesetzt wird, dass die Leser:innen über ein solides Verständnis grundlegender Konzepte wie die Installation von Software, die Windows-Befehlszeile sowie das Schreiben und Ausführen von Stapeldateien verfügen.

Informationen zur Verwaltung der Anwendung nach der Installation finden Sie in der Anleitung zu Revu 21 für Administrator:innen.

Was ist neu in Revu 21?

Registrierungsprozess:

  • Für die Bereitstellung ist keine Seriennummer und kein Produktschlüssel mehr erforderlich. Daher gibt es keine erforderlichen Eigenschaften, die Sie in Ihr Skript einfügen müssen.
  • Die Eigenschaft „Verzögerte Autorisierung“ (DA=1) ist nicht mehr erforderlich.
  • Während der Installation muss keine Verbindung mit dem Lizenzierungsserver hergestellt werden. Aufgrund dieser Verbesserung ist es nicht mehr erforderlich, die Software zu registrieren bzw. die Registrierung aufzuheben. Die Schaltfläche zur Registrierung im Menü von Revu und die Befehlszeilenoptionen im Administrator sind nicht mehr vorhanden.

Seit Revu 21 ist während der Installation kein Internetzugang mehr erforderlich:

  • Bei der Bereitstellung via SCCM können Sie das Konto „SYSTEM“ verwenden.
  • Da wir auf ein Subscription Modell umgestellt haben, wird bei der Anmeldung der Benutzer:innen die ihnen zugewiesene Subscription Stufe ausgewählt.

Weitere nennenswerte Änderungen in Revu 21:

  • Der Markierungs- und der Ansichtsmodus sind nicht mehr erforderlich, da die Funktionen und die Funktionalität jetzt durch die Subscription Stufe der angemeldeten Benutzer:innen bestimmt werden.
  • Aufgrund der einfachen Bereitstellung mit Subscriptions ist der Konfigurations-Editor nicht mehr erforderlich.
  • Seit der Umstellung von den Revu-Editionen auf ein Subscription Modell sind der ARP-Modifizierer und die optionale Prüfung vor der Installation nicht mehr erforderlich.

Planung Ihrer Bereitstellung

Kompatibilität und Systemanforderungen

Aktuelle Informationen zur Kompatibilität finden Sie unter Bluebeam® Revu® 21 – Kompatibilität und Systemanforderungen.

Anleitung zu Revu 21 für Administrator:innen

Die Anleitung zu Revu 21 für Administrator:innen enthält Informationen zur Nutzung von Revu nach der Installation, u. a. zur Bluebeam Administratorkonsole, zu Bluebeam Studio, den Einstellungen von Revu, der Verwaltung der Subscriptions sowie den elektronischen und digitalen Signaturen.

Bereitstellungspakete für Unternehmen

Das Installationsprogramm basiert auf dem Framework des Microsoft Windows Installer (msiexec.exe). Daher ist es äußerst wichtig, dass die richtige Version des Windows Installer bereits auf Ihren Geräten installiert ist.

MSI-Paket

Dies ist die Datei, die Sie für die Bereitstellung einer vollständigen Installation von Revu verwenden werden.

Es ist äußerst wichtig, dass Sie das richtige Bereitstellungspaket für Ihre Umgebung herunterladen. Öffnen Sie anschließend die ZIP-Datei und machen Sie sich mit ihrem Inhalt vertraut, der wie folgt aussieht:

  • Eine Infodatei, in der der Inhalt des MSI-Pakets und die Installationsvoraussetzungen aufgeführt sind.
  • Die MSI-Installationsdatei von Revu.
  • Die MSI-Installationsdatei von OCR. Mit Revu 20 wurde das OCR-Modul von der MSI-Datei von Revu getrennt und stellt nun ein separates Installationsprogramm dar.
  • Das Offline-Installationsprogramm von Microsoft .NET Framework 4.8. Für die Installation von .NET Framework 4.8 unter Windows 10 ist entweder das Windows 10 Anniversary Update oder das Windows 10 Creators Update erforderlich. Weitere Informationen finden Sie auf der Website von Microsoft.
    .NET Framework 4.8 ist auch in Installationen von Windows 11 enthalten.
  • Eine Visual C++ Redistributable für Visual Studio 2022. Wenn diese nicht bereits auf den Geräten installiert ist, muss sie vor der Bereitstellung der MSI-Datei installiert werden.
  • Ein Skript zum Entfernen älterer Versionen von Revu. (Uninstall Previous Version.txt – Bitte ändern Sie die Dateiendung vor der Ausführung zu .bat. Sobald die Datei von einer Textdatei in eine Stapeldatei umgewandelt wurde, führen Sie sie mit erweiterten Berechtigungen aus. Diese Stapeldatei hebt die Registrierung von jeder Revu-Version auf dem Rechner auf und deinstalliert das Programm.)
  • Eine SharePoint-Erweiterung. Die Option wird auf SharePoint 2019 oder höher für lokale Server und auf Instanzen von SharePoint Online (Office 365) unterstützt.
  • Ein SharePoint-Add-in. Die Option wird auf SharePoint 2013 oder höher für lokale Server und auf Instanzen von SharePoint Online (Office 365) unterstützt.

Weitere Informationen zur Installation der SharePoint-Integrationsapp von Bluebeam in einer SharePoint-Umgebung finden Sie unter Installieren der Integrationsapp für SharePoint.

Das Deinstallationsskript für jedes kleinere Update kann alle vorherigen Versionen entfernen, muss aber NICHT ausgeführt werden, wenn Sie ein Update auf eine Unterversion innerhalb derselben Version vornehmen möchten. Das bedeutet, dass alle künftigen MSI-Updates für Revu 21 auf der vorherigen Installation von Revu 21 ausgeführt werden können.

Benutzerdefinierte Einstellungen und Assets

Wenn benutzerdefinierte oder gemeinsam genutzte Einstellungen und Assets in Ihrem Unternehmen verwendet werden, z. B. Einstellungen, Profile, Werkzeugsets und Stempel, finden Sie in der Anleitung zu Revu 21 für Administrator:innen die Best Practices für den Export, das Zusammenführen und das Staging dieser Elemente.

Einrichten eines Staging-Computers

Wenn Sie wie oben beschrieben benutzerdefinierte Einstellungen und Assets erstellen möchten, müssen Sie Revu manuell auf einem Computer installieren, um diese Assets erstellen und bereitstellen zu können. Dies wird im Abschnitt „Konfigurationen eines verwalteten Netzwerks“ der Anleitung zu Revu 21 für Administrator:innen beschrieben.

Das Installationsprogramm für diese Einzelinstallation können Sie in unserem Downloadbereich herunterladen.

Bereitstellungsprozess

Best Practices

Vor den eigentlichen Schritten des Bereitstellungsprozesses sind einige wichtige Details zu beachten:

Um mögliche Aktualisierungsprobleme bei der Planung einer neuen Bereitstellung zu vermeiden, empfiehlt es sich, die vorherige MSI-Datei an ihrem ursprünglichen Speicherort zu belassen.
  • Bitte befolgen Sie die Anweisungen genau und versuchen Sie nicht, den Arbeitsablauf abzukürzen oder anderweitig zu verändern.
  • Das manuelle Bearbeiten der MSI-Datei wird von Bluebeam nicht unterstützt, da dadurch die digitale Signatur der Dateien ungültig wird.
  • Wenn Sie ein Upgrade von einer bereits installierten älteren Version von Revu auf Revu 21 durchführen, müssen Sie zunächst die ältere Software entfernen. Führen Sie dazu das Skript „Uninstall Previous Version“ aus, das im MSI-Bereitstellungspaket für Revu 21 enthalten ist.
  • Achten Sie darauf, das Deinstallationsskript mit erweiterten Berechtigungen auszuführen.
    Wenn Sie SCCM verwenden, kann das Skript „Uninstall Previous Version“ über eine Tasksequenz ausgelöst werden. Wenn Sie Unterstützung für den SCCM-Prozess benötigen, konsultieren Sie bitte die SCCM-Dokumentation von Microsoft.
  • Wir empfehlen dringend, eine Pilotgruppe von Endbenutzer:innen zum Testen neuer Versionen von Revu einzurichten, bevor Sie diese unternehmensweit bereitstellen.
Die MSI-Datei muss mit erweiterten Berechtigungen ausgeführt werden, unabhängig davon, ob das verwendete Konto Teil der administrativen Gruppe des lokalen Computers ist. Benutzer:innen von Windows 10 sollten die Windows-Benutzerkontensteuerung zurate ziehen.
  • Verwenden von Microsoft SCCM

    Seit Revu 21 ist während der Bereitstellung kein Internetzugang mehr erforderlich. Aus diesem Grund können Sie bei der Erstellung eines MSI-Bereitstellungspakets zwischen den Optionen Install for user und Install for SYSTEM (Konto „SYSTEM“) wählen.

Tools für die Bereitstellung

Unabhängig davon, welches Paket oder Bereitstellungstool Sie verwenden, startet Ihr Befehlszeilenskript den Windows Installer (msiexec.exe) während Ihrer Installation.

Es gibt verschiedene Bereitstellungstools, die die Befehlszeile zum Ausführen eines MSI-Installationsprogramms verwenden, z. B. den System Center Configuration Manager (SCCM), Quest KACE (früher Dell KACE) und die Gruppenrichtlinie von Microsoft Windows.

Wir weisen darauf hin, dass wir nur Support für die Verwendung der Befehlszeilenskripte und nicht für die Bereitstellungstools selbst anbieten.

Bereitstellung des OCR-Moduls

Um künftige Updates zu beschleunigen, liefern wir das OCR-Modul in einer separaten MSI-Datei außerhalb der Anwendung von Revu aus. Sowohl die MSI-Datei von Revu als auch die MSI-Datei von OCR sind in den Bereitstellungspaketen enthalten, die Sie auf unserer Website finden.

Wenn Ihre Benutzer:innen in der Lage sein sollen, bestimmte Funktionen von Revu zu verwenden, die die Texterkennung nutzen, wie OCR, AutoMark, Sets und Batch Link, müssen Sie die MSI-Datei von OCR bereitstellen.

Wenn die MSI-Datei von OCR nicht von einem oder einer Administrator:in installiert wird oder wenn ein:e Benutzer:in sie deinstalliert, funktioniert Revu weiterhin. Die Benutzer:innen können die oben genannten Funktionen dann jedoch nicht nutzen. Zur Behebung entsprechender Probleme kann das OCR-Modul jederzeit installiert werden.

Die MSI-Datei von Revu und die MSI-Datei von OCR können in beliebiger Reihenfolge bereitgestellt werden. Sie sind nicht voneinander abhängig. Wenn Sie ein Update von Revu auf eine neue Unterversion (Point Release) durchführen, müssen Sie das OCR-Modul nicht erneut bereitstellen, wenn es bereits bei der Erstinstallation bereitgestellt wurde. In diesem Fall müssen Sie nur die MSI-Datei von Revu bereitstellen.

Um den Aktualisierungsprozess zu optimieren und die Dateigröße so gering wie möglich zu halten, wird die MSI-Datei von OCR nicht über den In-App-Updater bereitgestellt. Da das OCR-Modul nur selten geändert wird, stellt Bluebeam mit jeder Hauptversion ein Update zur Verfügung.

Das OCR-Paket verfügt über keine speziellen Parameter, die über die Standardoptionen von msiexec hinausgehen. Hier ist ein Beispiel für eine stumme Installation der 64-Bit-MSI-Datei von OCR:

msiexec.exe /i "[path to deployment folder]\BluebeamOCR x64 21.msi" /qn

Wenn Sie die BAT-Datei „Uninstall Previous Version“ verwenden, werden sowohl Revu als auch die OCR-Installationsprogramme entfernt. Bei der Deinstallation über die Systemsteuerung werden Revu und OCR jedoch als separate Elemente angezeigt und müssen einzeln deinstalliert werden.

Wenn Sie bei der Fehlerbehebung auf einem einzelnen Computer eine Neuinstallation mit der Datei Suite.exe durchführen, wird OCR automatisch installiert.

Tabelle der MSI-Eigenschaften von Revu

In der Tabelle der MSI-Eigenschaften sind die Eigenschaften aufgeführt, mit denen Sie die Installation von Revu konfigurieren und anpassen können. Seit Revu 21 gibt es keine erforderlichen Eigenschaften für die Installation mehr. Im Folgenden finden Sie die unterstützten optionalen Eigenschaften.

Unterstützte optionale Eigenschaften

BB_AUTO_UPDATE Aktivieren oder deaktivieren Sie die In-App-Aktualisierungsbenachrichtigungen: Aktiviert (Standard) = 1, Deaktiviert = 0 (siehe Hinweise).
BB_DISABLEANALYTICS Aktivieren oder deaktivieren Sie das Senden von Informationen zur Anwendungsnutzung an Bluebeam: Senden (Standard) = 0, Nicht senden = 1 (siehe Hinweise).
BB_DEFAULTVIEWER Als Standardanwendung festlegen (Standard) = 1, Standardanwendung nicht ändern = 0 (siehe Hinweise)
BB_DESKSHORTCUT Desktop-Verknüpfung für Bluebeam Revu (Standard) = 1, Keine Verknüpfung = 0
BB_DESKSTAPLER Desktop-Verknüpfung für Bluebeam Stapler = 1, Keine Verknüpfung (Standard) = 0
BB_FEATURES Deaktiviert verschiedene Funktionen von Revu: Alle Funktionen aktiviert = 65535 (Standard). Weitere Informationen finden Sie unter Aktivieren und Deaktivieren von Revu-Funktionen mit BB_FEATURES.
BB_IE_PLUGIN Installieren und aktivieren = 1, Deaktivieren (Standard) = 0
BB_JOBOPTIONS Geben Sie den UNC- oder vollqualifizierten Pfad zu Ihrer benutzerdefinierten JOBOPTIONS-Datei ein.
BB_NETCONFIG Geben Sie den UNC- oder vollqualifizierten Pfad zu Ihrem verwalteten Netzwerkkonfigurationsordner ein.
BB_PAGESIZE Geben Sie „A4“ ein, um die Standardseitengröße des PDF-Druckers von Bluebeam zu überschreiben.
DISABLE_WELCOME

Deaktiviert die HTML-Startseite von Revu und die Seite mit Schulungsvideos zu Arbeitsabläufen: Aktivieren (Standard) = 0, Deaktivieren = 1.

Erstellt den Eintrag Computer\HKEY_CURRENT_USER\Software\Bluebeam Software\20\Revu in der Registry sowie ein DWORD namens WorkflowsInitialized„.

BB_REVUPREFERENCES Geben Sie den UNC- oder vollqualifizierten Pfad zu Ihrer Datei RevuPreferences.xml ein.
IGNORE_RBT Prüfung auf ausstehenden Neustart deaktivieren = 1, Prüfung auf ausstehenden Neustart = 0 (siehe Hinweise)
MBCODE Legt fest, welche der Plug-ins von Bluebeam aktiviert sind. Mit dem Standardwert von 1023 werden alle aktiviert. Weitere Informationen finden Sie unter Aktivieren der Bluebeam Plug-ins mit MBCODE.
Eigenschaft „BB_AUTO_UPDATE“

Die Eigenschaft „BB_AUTO_UPDATE“ ist standardmäßig aktiviert. Wenn diese Funktion aktiviert ist, erhalten Benutzer:innen eine In-App-Benachrichtigung, wenn ein neues Update für Revu verfügbar ist. Falls Ihre Benutzer:innen keine In-App-Benachrichtigung erhalten sollen, wenn eine neue Version veröffentlicht wird, müssen Sie diese Eigenschaft deaktivieren.

Eigenschaft „BB_DISABLEANALYTICS“

Revu sendet standardmäßig Nutzungsdaten an Bluebeam, um die weitere Verbesserung der Anwendung zu unterstützen. Mithilfe der von Ihnen bereitgestellten Informationen können wir das Nutzungsverhalten und Trends besser verstehen und so unsere Produkte und Services weiter optimieren. Alle bereitgestellten Informationen sind anonym und werden nicht an Dritte weitergegeben. Bluebeam erfasst keine personenbezogenen Daten. Wenn Sie diese Option deaktivieren möchten, setzen Sie bei der Bereitstellung Ihrer Installationen die Eigenschaft „BB_DISABLEANALYTICS“ in Ihrem MSI-Befehlszeilenskript oder Ihrer MST-Datei auf 1 (BB_DISABLEANALYTICS=1).

Beim ersten Öffnen von Revu 21 wird ein neues Fenster mit dem Titel „Erzählen Sie uns mehr über sich“ angezeigt, in dem einige grundlegende Kundeninformationen abgefragt werden.

Wenn Sie die Übermittlung von Nutzungsdaten durch die Eingabe von „BB_DISABLEANALYTICS=1“ ablehnen, wird auch das Fenster „Erzählen Sie uns mehr über sich“ nicht angezeigt. Weitere Informationen zu den von uns erfassten Daten finden Sie in der Privacy Policy von Bluebeam.

Festlegen des Standard-PDF-Viewers mit „BB_DEFAULTVIEWER“

Microsoft hat die Art und Weise geändert, wie Standardanwendungen in Windows 8 und höher ausgewählt werden, was dazu führt, dass die Einstellung „BB_DEFAULTVIEWER“ überschrieben wird. Aus diesem Grund müssen Ihre Benutzer:innen die Schritte unter Einrichten eines anderen Standard-PDF-Viewers befolgen. Weitere Informationen finden Sie auf der Website von Microsoft.

Aktivieren und Deaktivieren von Revu-Funktionen mit „BB_FEATURES“

Wie in der folgenden Tabelle dargestellt, ist jeder Funktion von Revu ein Zahlenwert zugewiesen. Um eine Funktion zu deaktivieren, subtrahieren Sie ihren Zahlenwert vom Standardwert der Eigenschaft „BB_FEATURES“ (65535), der in der obigen Tabelle der unterstützten optionalen Eigenschaften angegeben ist. Geben Sie das Ergebnis als neuen Wert für die Eigenschaft „BB_FEATURES“ ein.

Um beispielsweise die Schwärzungsfunktion zu deaktivieren, müssten Sie den Wert dieser Funktion (2) von 65535 subtrahieren und dann das Ergebnis (65533) als neuen Wert für „BB_FEATURES“ eingeben.

Funktionen von Revu und ihre Zahlenwerte:

Administrator Button (Revu Menu) = 128 Product Updates Button (Help menu) = 16
AllFeatures = 1023 Redaction Cut Content & Erase Content = 2
DigitalSignatures = 4 SelfSignCertificates = 8
EditText = 1 TranslateMarkups = 32
ExportToOffice = 64 Session Following Feature = 512
Weitere Informationen zur Funktion „Folgen in Sitzungen“ (Session Following Feature)

Einige Benutzer:innen müssen unter Umständen die Möglichkeit haben, andere Benutzer:innen daran zu hindern, ihnen in einer Studio-Sitzung zu folgen, um die Einhaltung von Datenschutz- und Arbeitsvorschriften zu gewährleisten. Die folgenden Szenarien veranschaulichen, was passiert, wenn diese Funktion deaktiviert ist:

Benutzer:in X versucht, Benutzer:in Y zu folgen
– Der Bildschirm von Benutzer:in X sieht immer noch so aus, als würde diese Person Benutzer:in Y folgen, aber sie erhält keine Positionsaktualisierungen von Benutzer:in Y mehr.

Benutzer:in X sendet eine „Mir folgen“-Anfrage an alle Benutzer:innen
– Bei Benutzer:in Y wird der Dialog nicht angezeigt.

Benutzer:in Y versucht, Benutzer:in X zu folgen
– Benutzer:in Y kann keinen anderen Benutzer:innen folgen (alle Elemente zum Folgen in Sitzungen wurden aus der Benutzeroberfläche entfernt).

Deaktivieren von „Prüfung auf ausstehenden Neustart“

Standardmäßig setzt das Installationsprogramm die Eigenschaft „IGNORE_RBT“ auf 0. Wenn die MSI-Datei gestartet wird, prüft das Installationsprogramm, ob auf dem Computer ein Neustart aussteht. Die Installation wird unterbrochen, wenn die Option „IGNORE_RBT=0“ gesetzt ist und gleichzeitig ein Neustart aussteht. Wenn die Eigenschaft „IGNORE_RBT=1“ aktiviert ist, wird die Installation selbst bei einem ausstehenden Neustart nicht unterbrochen. Ohne diese Einstellung wird die Installation angehalten, wenn der Computer nach einer entsprechenden Aufforderung nicht neu gestartet wird.

Darüber hinaus können Sie mit dem Microsoft-Parameter namens „REBOOT=ReallySuppress“ steuern, wann ein Computer neu gestartet wird.

Bitte schließen Sie gemäß den Best Practices alle aktiven Programme und Browser, um die Wahrscheinlichkeit einer erfolgreichen Unterdrückung zu erhöhen. Damit Revu korrekt funktioniert, muss der ausstehende Neustart zu einem Zeitpunkt nach dem Abschluss der Installation erfolgen.

Aktivieren der Bluebeam Plug-ins mit „MBCODE“

Wie in der folgenden Tabelle dargestellt, ist jedem Plug-in von Bluebeam für unterstützte Software von Drittanbietern ein Zahlenwert zugewiesen. Wenn Sie nur ein einziges Plug-in aktivieren möchten (z. B. das Plug-in für AutoCAD), ersetzen Sie den Standard-MBCODE-Wert von 1023 (alle Plug-ins aktiviert) durch die Zahl 2. In Fällen, in denen Sie mehr als ein Plug-in aktivieren müssen, addieren Sie deren Zahlenwerte und geben die Summe als neuen MBCODE-Wert ein. Wenn Sie den Wert auf 0 setzen, werden alle Plug-ins deaktiviert.

Bluebeam Plug-ins werden nur aktiviert, wenn die Anwendung des Drittanbieters installiert ist. Überprüfen Sie anhand der Kompatibilitätstabelle für Revu, ob Ihre Drittanbieteranwendungen unterstützt werden.

Plug-ins von Revu und ihre Zahlenwerte:

Alle Plug-ins deaktiviert = 0 Microsoft Outlook = 128
AutoCAD = 2 ProjectWise = 64
AutoCAD LT (32- und 64-Bit) = 4 Revit und Navisworks = 16
Internet Explorer = 32 SolidWorks = 8
Microsoft Office = 1

Änderung der Sprache

Sie können Installationen in einer anderen Sprache als Ihrer Windows-Standardsprache bereitstellen, indem Sie die Eigenschaft „TRANSFORMS“ auf einen der unten aufgeführten Sprachcodes setzen. Ansonsten wird Revu in der vom Host-Betriebssystem verwendeten Sprache installiert.

Befehlszeilenbeispiele für MST– und MSI-Installationen finden Sie an späterer Stelle in dieser Anleitung.

Codes zur Änderung der Sprache von Revu:
Dänisch = 1030 Italienisch = 1040
Niederländisch = 1043 Japanisch = 1041
Englisch = 1033 Koreanisch = 1042
Finnisch = 1035 Norwegisch = 1044
Französisch (Standard) = 1036 Spanisch = 1034
Deutsch = 1031 Schwedisch = 1053

Bereitstellungsmethoden

In diesem Abschnitt werden Themen wie Windows Installer-Schalter und das Schreiben von Skripten für MSI-Installationen behandelt.

Hinweis zu Windows Installer-Schaltern

Es gibt drei wichtige Windows Installer-Schalter, die beim Schreiben eines Skripts für MST- oder MSI-Installationen zu beachten sind:

Weist den Windows Installer an, zur Ausführung einer Installation msiexec.exe aufzurufen.

/i

Mit diesem Schalter können Sie unbeaufsichtigte und stumme Installationen durchführen.

/qn

Wird verwendet, wenn Sie eine MST-Datei erstellt haben, die aufgerufen werden muss. Dazu geben Sie den Ordnerpfad, in dem sich die MST-Datei befindet, sowie den Dateinamen der MST-Datei ein. Mit „TRANSFORMS“ können Sie Revu zudem in verschiedenen Sprachen installieren.

TRANSFORMS

Schreiben eines Installationsskripts

Im Folgenden werden die verschiedenen Methoden für die Bereitstellung von Revu beschrieben, wobei jede Methode die Befehlszeile auf leicht unterschiedliche Weise nutzt.

Verwenden einer MST-Datei

Mit einer MST-Datei (Microsoft Transform) können Sie Tippfehler minimieren, da alle Eigenschafts-/Parameteränderungen in der MST-Datei vorgenommen werden, die über ein kurzes Befehlszeilenskript aufgerufen wird. Sie können also Ihre Änderungen an der Eigenschaftstabelle noch einmal überprüfen, bevor sie während der Installationen übernommen werden.

Wichtiger Hinweis zu „TRANSFORMS“

Szenario 1: Änderung der Sprache mit „TRANSFORMS“

Bei der Änderung der Sprache mit „TRANSFORMS“ sollte sich die MST-Datei im selben Stammverzeichnis wie die MSI-Datei befinden. Geben Sie keinen Pfad zu der MST-Datei an, sondern nur deren Namen. Der Name der MST-Datei darf KEINE Leerzeichen enthalten und NICHT in Anführungszeichen gesetzt werden.

TRANSFORMS=:1031;MyTransforms.mst
TRANSFORMS=:1031;<Geben Sie nicht den Dateipfad der MST-Datei an, sondern nur deren Dateinamen.>

Szenario 2: Standardnutzung von „TRANSFORMS“

Bei der Verwendung von „TRANSFORMS“ sollte sich die MST-Datei im selben Stammverzeichnis wie die MSI-Datei befinden. Setzen Sie die Pfadangabe zur MST-Datei in Anführungszeichen.

TRANSFORMS="C:\Deployment Folder\MyTransforms.mst"
TRANSFORMS=<In Anführungszeichen gesetzter Pfad zur MST-Datei>
Erstellen und Bearbeiten einer MST-Datei

Falls Sie dies noch nicht getan haben, müssen Sie einen MSI-Editor wie InstEd herunterladen und installieren. Führen Sie anschließend die unten aufgeführten Schritte aus:

  1. Starten Sie InstEd, klicken Sie auf das Menü File und öffnen Sie die ursprüngliche MSI-Datei.
  2. Klicken Sie auf das Menü Transform und wählen Sie die Option New Transform.
  3. Wenn das Dialogfeld „New Transform“ geöffnet wird, benennen Sie die MST-Datei und klicken Sie dann auf „Save“.
    Die Datei sollte nicht „Transforms.mst“ heißen und muss im selben Ordner wie das ursprüngliche MSI-Installationsprogramm gespeichert werden.
  4. Klicken Sie links auf die Registerkarte Tables und wählen Sie in der Liste Tables die Option Property aus. An dieser Stelle kann es hilfreich sein, auf die Spaltenüberschrift Property zu klicken, um die Liste Properties alphabetisch zu sortieren.
  5. Bearbeiten Sie die Eigenschaften nach Ihren Anforderungen.
    Bearbeiten Sie KEINE anderen Eigenschaften als jene in der Tabelle der MSI-Eigenschaften.
  6. Klicken Sie auf das Menü File und dort auf „Save the file“, um die Datei zu speichern.
Schreiben eines Befehlszeilenskripts, das Ihre MST-Datei verwendet

Hier sind einige Beispiele für Installationsskripte, die eine MST-Datei aufrufen:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=YourMSTFile.mst /qn

Eine stumme deutsche Sprachinstallation:

msiexec.exe /i "Bluebeam Revu x64 21.msi" TRANSFORMS=:1031;MyTransforms.mst /qn

Es ist sehr wichtig, dass Sie Ihr Skript in einer Eingabeaufforderung mit erweiterten Berechtigungen auf einem Testcomputer testen, bevor Sie die Installation bereitstellen, um sicherzugehen, dass es korrekt ausgeführt wird.

Doppelklicken Sie nicht auf die MSI-Datei. Dadurch würde Revu ohne die erforderlichen erweiterten Berechtigungen und ohne die in den MSI-Eigenschaften festgelegten Anpassungen installiert werden.
Direkte Verwendung der MSI-Eigenschaften

Eine weitere Methode zur Erstellung Ihrer Bereitstellung besteht darin, ein vollständiges Installationsskript zu schreiben, das die MSI-Datei von Revu aufruft und alle Eigenschaftsänderungen auflistet.

Werte für einen MSI-Schalter (gekennzeichnet durch einen Schrägstrich) müssen wie unten dargestellt in Anführungszeichen gesetzt werden. Bei Eigenschaften, die für Bluebeam spezifisch sind, müssen Leerzeichen durch Fragezeichen ersetzt werden.
Wir empfehlen Ihnen, Ihr Skript vor der Bereitstellung von Revu in einem Texteditor zu schreiben, zu überprüfen und auf einem Testcomputer in einer Eingabeaufforderung mit erweiterten Berechtigungen auszuführen.

Beispiele für MSI-Skripts

Die folgenden Beispiele sollen Ihnen eine bessere Vorstellung davon vermitteln, wie Befehlszeilenskripte für verschiedene Installationsanforderungen und Konfigurationen geschrieben werden können:

Stumme Basisinstallation mit zusätzlicher Bereitstellung der Datei RevuPreferences.xml

Beachten Sie die unterschiedlichen Pfade der MSI-Datei und der XML-Datei:

msiexec.exe /i "\\MyServer\Bluebeam?Deployment\Bluebeam Revu x64 21.msi" BB_REVUPREFERENCES=\\MyServer\Bluebeam?Deployment\RevuPreferences.xml /qn

Ein Skript, das stumm die MSI-Datei von OCR und die MSI-Datei von Revu unter Verwendung einer TRANSFORMS-Datei kombiniert:

START /WAIT msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\BluebeamOCR x64 21.msi" /qb && msiexec.exe /i "C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.msi" TRANSFORMS="C:\Users\<USERNAME>\Desktop\MSIBluebeamRevu21x64\Bluebeam Revu x64 21.mst" /qn

Ausführung und Fehlerbehebung bei einer Bereitstellung

Wenn Sie Ihr Skript geschrieben und in einer Eingabeaufforderung mit erweiterten Berechtigungen auf einem Testcomputer getestet haben, können Sie es anschließend in einem Bereitstellungstool Ihrer Wahl ausführen, z. B. SCCM, Dell KACE oder Gruppenrichtlinie.

Wenn die Installationen nicht wie vorgesehen verlaufen oder aus anderen Gründen fehlgeschlagen sind, müssen Sie Ihre Arbeit erneut überprüfen. Wenn Ihr Skript eine MST-Datei aufruft, öffnen Sie sie erneut mit dem MSI-Editor und stellen Sie sicher, dass Sie die Eigenschaften korrekt festgelegt haben.

Nachdem Sie sich vergewissert haben, dass Sie die richtige Syntax im Skript verwendet haben, führen Sie die Validierung erneut in einer Eingabeaufforderung mit erweiterten Berechtigungen auf einem Testcomputer durch.

Das MSI-Installationsprogramm erstellt eine ausführliche Protokolldatei im Verzeichnis %TEMP% auf dem lokalen Laufwerk des Computers, auf dem Revu installiert wird. Die Namenskonvention lautet MSIxxxxx.log„, wobei xxxxx für beliebige Zeichen wie MSIjfb1d6.log steht. Überprüfen Sie dieses Protokoll auf häufige Windows-Installationsfehler.

Wenn Sie SCCM verwenden, finden Sie die Protokolldatei unter C:\windows\temp, sofern die Installation über das Konto „SYSTEM“ erfolgt.
Eine Liste mit den Fehlercodes des Windows Installer und ihrer Definitionen finden Sie auf der Website von Microsoft.

Aktualisierung vorhandener Installationen

Der neue MSI-Prozess entfernt die aktuell installierte Version von Revu 21 und ersetzt sie durch das neueste Update von Revu 21, das Sie gerade bereitstellen. Bei diesem Prozess ist auch keine erneute Verteilung der MSI-Datei von OCR erforderlich. Da das OCR-Modul in neueren Updates von Revu 21 nicht mehr benötigt wird, wird Ihr Revu-Bereitstellungspaket kleiner werden.

Nachfolgend finden Sie einige Beispielskripte, die für die Aktualisierung einer vorhandenen Installation von Revu 21 verwendet werden können:

MSI-Erstinstallation mit optionalem Parameter:

msiexec /i "Bluebeam Revu x64 21.0.0 msi" DISABLE_WELCOME=1 
Sie benötigen alle anderen Parameter, die Sie bereits bei der ersten Bereitstellung verwendet haben.

Aktualisieren Sie die MSI-Installation mit optionalem Parameter wie folgt:

msiexec /i "Bluebeam Revu x64 21.0.X msi" DISABLE_WELCOME=1

Nach der Installation: Optionale Bereitstellung von Anpassungen

Bluebeam Administratorkonsole

Mit der Administratoranwendung (PbMngr5.exe) können Sie die folgenden Funktionen nach der Installation über die Windows-Befehlszeile ausführen:

  • Plug-ins installieren
  • PDF-Drucker von Bluebeam neu installieren/deinstallieren
  • Standard-DPI des PDF-Druckers von Bluebeam festlegen
  • Netzwerkkonfiguration einrichten
  • Sichern, Zurücksetzen und Wiederherstellen der Benutzereinstellungen von Revu

Weitere Informationen zu den verfügbaren Funktionen erhalten Sie in der Hilfe zu PbMngr5.exe, die Sie über die Windows-Eingabeaufforderung aufrufen können. Klicken Sie dazu auf Start > Suche und geben Sie CMD ein.

Geben Sie cd „C:\Program Files\Bluebeam Software\Bluebeam Revu\21\Revu und dann PbMngr5.exe /help in die geöffnete Eingabeaufforderung ein und drücken Sie schließlich die Eingabetaste.
Alternativ finden Sie weitere Informationen in der Hilfe für Bluebeam Administrator:innen.

Einstellungen von Revu

Es gibt zwei Bluebeam Konfigurationsdateien mit Anwendungseinstellungen, die bereitgestellt werden können: die Datei RevuPreferences.xml, die jederzeit bereitgestellt werden kann, und die Datei UserPreferences.xml, die nur bereitgestellt werden kann, wenn eine neue Installation von Revu abgeschlossen wurde.

RevuPreferences.xml

Diese Datei enthält alle Einstellungen, die im Revu-Dialog „Einstellungen“ (Strg+K) vorgenommen wurden. Wenn Sie im Dialogfenster auf „Exportieren“ klicken, können Sie die Datei RevuPreferences.xml an einem beliebigen Ort speichern, z. B. in einem zentralen Ordner auf einem Server.

Obwohl sie als Teil einer MST-Datei oder als MSI-Befehlszeile bereitgestellt werden kann, können Sie auch nach der Installation eine Befehlszeilenoption verwenden, die den Bluebeam Administrator aufruft, mit dem Sie Änderungen automatisieren können.

Hier ist ein Beispiel für die Bereitstellung von aktualisierten Revu-Einstellungen, bei denen alle Plug-ins mit Ausnahme des Plug-ins für den Internet Explorer aktiviert bleiben müssen:

"%ProgramFiles%\Bluebeam Software\Bluebeam Revu\21\Revu\PbMngr5.exe" /setup /PREFSPATH:"G:\Bluebeam Software\Settings\RevuPreferences.xml"

Sie können die Datei RevuPreferences.xml auch in den folgenden Ordner kopieren oder verschieben:

C:\ProgramData\Bluebeam Software\Bluebeam Revu\21\Revu
Wenn Revu gestartet wird, sucht das Programm nach der Datei RevuPreferences.xml. Wenn diese Datei neuer ist als die Datei UserPreferences.xml im Ordner %appdata% des oder der Benutzer:in, wird der Inhalt mit der vorhandenen Datei UserPreferences.xml zusammengeführt. Um das Änderungsdatum zu bearbeiten, müssen Sie eine Änderung in der Datei RevuPreferences.xml vornehmen. Dazu genügt es, ein Leerzeichen am Anfang des Textes einzufügen.

Festlegen einer Offline-PIN-Aufforderung

Benutzer:innen können eine Offline-PIN einrichten, mit der sie auch dann auf Studio-Dateien zugreifen können, wenn sie nicht mit Bluebeam Studio verbunden sind. Obwohl dies keine Standardaufforderung ist, kann sie im Abschnitt „Studio“ der Datei RevuPreferences.xml auf Ihrem Staging-Computer bearbeitet werden. Sie kann dann an einen Staging-Ort in Ihrem Netzwerk exportiert werden.Normalerweise ist dies derselbe Ort, an dem die MSI-Datei gespeichert ist, die Sie bereitstellen.

Die Änderung von RevuPreferences.xml besteht aus:

         <Studio> <RequireOfflinePIN>True</RequireOfflinePIN> </Studio>

Diese kann mit der MSI-Eigenschaft „BB_REVUPREFERENCES“ bereitgestellt werden.

Wenn diese Einstellung gesetzt ist, müssen alle neuen und bestehenden Benutzer:innen von Studio eine Offline-PIN erstellen. Erst danach können sie sich bei Bluebeam Studio anmelden.

UserPreferences.xml

Diese Datei enthält Einstellungen für eine:n einzelne:n Benutzer:in von Revu. Diese Datei kann zwar nicht für vorhandene Installationen bereitgestellt werden. Eine Bereitstellung für neue Installationen ist jedoch vor dem ersten Start möglich, indem eine geänderte Version der Datei UserPreferences.xml auf jedem Computer an den folgenden Ort verschoben wird:

C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu
Wenn Sie bei der Planung Ihrer Bereitstellung bereits Ihre benutzerdefinierten Assets wie Profile und Werkzeugsets zusammengeführt haben, können Sie diese ebenfalls an diesen Ort kopieren.
Beim ersten Start von Revu werden die Dateien automatisch an den folgenden Ort in ihrem Roaming-Windows-Benutzerprofil kopiert:
%APPDATA%\Bluebeam Software\Revu\21

Zusammenführen von Einstellungen in Revu

Wenn Sie nur neue Einstellungen hinzufügen möchten, sollten Sie zunächst die Datei RevuPreferences.xml in einem Texteditor öffnen und vor dem Staging für die Bereitstellung Merge=“True“ am Anfang der Datei hinzufügen (siehe unten). Weitere Informationen finden Sie in der Anleitung zu Revu für Administrator:innen. Bei der Zusammenführung werden die Daten ersetzt, die in der Datei RevuPreferences.xml aktualisiert oder bearbeitet werden sollen.

Beispiel für eine bearbeitete Version der Datei RevuPreferences.xml

Die folgenden Revu-Einstellungen bieten eine Revu-Installation, die diese Einstellungen in eine vorhandene Version der Datei UserPreference.xml (Merge=“True“) einfügt und die URL für den SharePoint-Server eines Unternehmens bereitstellt:

<?xml version="1.0" encoding="utf-8"?>
<RevuPreferenceDictionary Version="2" Merge="True">
<DocManSys>
<ActiveIndexx64.>0</ActiveIndexx64.>
<CacheSharePointFilesx64.>False</CacheSharePointFilesx64.>
<CheckcoutOnOpenFromHyperlinks.x64.0>False</CheckcoutOnOpenFromHyperlinks.x64.0>
<CheckcoutOnOpenFromHyperlinks.x64.1>False</CheckcoutOnOpenFromHyperlinks.x64.1>
<CheckoutOnOpen.x64.0>False</CheckoutOnOpen.x64.0>
<CheckoutOnOpen.x64.1>False</CheckoutOnOpen.x64.1>
<ClaimsSupported.x64.0>False</ClaimsSupported.x64.0>
<ClaimsSupported.x64.1>True</ClaimsSupported.x64.1>
<Countx64.>2</Countx64.>
<DefaultFileFilterPDF>True</DefaultFileFilterPDF>
<DocumentLibrary.x64.0></DocumentLibrary.x64.0>
<DocumentLibrary.x64.1></DocumentLibrary.x64.1>
<LastAccessedLibraryPath.x64.0>Test</LastAccessedLibraryPath.x64.0>
<LastAccessedLibraryPath.x64.1></LastAccessedLibraryPath.x64.1>
<LoginName.x64.0>sa</LoginName.x64.0>
<LoginName.x64.1>sa</LoginName.x64.1>
<PromptForCheckinCommentsx64.>True</PromptForCheckinCommentsx64.>
<PromptForCheckoutFromIEx64.>True</PromptForCheckoutFromIEx64.>
<RegKey.x64.0>SharePoint2007</RegKey.x64.0>
<RegKey.x64.1>SharePoint2007</RegKey.x64.1>
<SelectionDialogx64.>False</SelectionDialogx64.>
<SharePointUseExistingCookies>True</SharePointUseExistingCookies>
<Site.x64.0>http://sharepointserver1</Site.x64.0>
<Site.x64.1>http://sharepointserver2</Site.x64.1>
<SiteAlias.x64.0>SharePoint</SiteAlias.x64.0>
<SiteAlias.x64.1 />
<StoreLastAccessedFolderx64.>True</StoreLastAccessedFolderx64.>
<TestIfSharePointPathx64.>True</TestIfSharePointPathx64.>
<ToolbarIntegrationOnlyx64.>True</ToolbarIntegrationOnlyx64.>
<UseDefaultCredentialsx64.>True</UseDefaultCredentialsx64.>
</DocManSys>
</RevuPreferenceDictionary>

* Diese SharePoint-Server-URLs ändern sich, wenn die Daten mit der Revu-Einstellungsdatei zusammengeführt werden.

Bereitstellen von benutzerdefinierten Erweiterungen über die Befehlszeile von Revu.exe

Befehlszeilen-Schalter von Revu.exe

Mit den folgenden Schaltern können Sie festlegen, wie der Importprozess abläuft und welche Assets in den standardmäßigen lokalen Revu-Roaming-Ordner %appdata% der Benutzer:innen kopiert werden sollen:

Beim Importieren von Assets oder Einstellungen werden diese wie oben beschrieben kopiert, während beim „Hinzufügen“ ein Verweis (Link) auf ein freigegebenes Asset auf einem Netzlaufwerk oder einem anderen nicht standardmäßigen Speicherort erstellt wird.
Beim Erstellen und Exportieren von benutzerdefinierten Profilen sollten Sie alle Abhängigkeiten wie benutzerdefinierte Werkzeugsets, Füllmuster, Linienstile, benutzerdefinierte Spalten oder benutzerdefinierte Status einbeziehen. Wenn diese benutzerdefinierten Ressourcen auf diese Weise in das Profil eingebettet werden, wird ihre gemeinsame Nutzung in einem Unternehmen erheblich erleichtert.
  • /bpximport:[File] – Importiert und aktiviert ein Profil.
  • /bpxdir:[Path] – Hier können Sie einen Ordnerpfad angeben, wenn Sie ein neues Profilverzeichnis festlegen wollen. Dies ist der Pfad zu einem freigegebenen Ort im Netzwerk, an dem Profile gespeichert sind, die von dort innerhalb einer Organisation geteilt werden.
    Um zu verhindern, dass Benutzer:innen Änderungen an den Profilen in diesem Verzeichnis vornehmen, setzen Sie die Ordnerberechtigungen auf „Schreibgeschützt“.
  • /bpxactive:[Name] – Richtet ein bestimmtes Profil als „Aktiv“ im lokalen Roaming-Ordner %appdata% von Revu der Benutzer:innen oder in einem gemeinsam genutzten Profil fest. Wenn Sie /bpxdir: verwendet haben, um ein gemeinsam genutztes Profilverzeichnis an einem Netzwerkstandort anzugeben, stellen Sie sicher, dass sich das Profil, das Sie als Aktiv einrichten, in dem angegebenen Verzeichnis befindet.
  • /btxadd:[File] – Damit wird eine Revu-Installation angewiesen, ein Werkzeugset zu verwenden, das sich an einem anderen als dem Standardspeicherort befindet, ohne es zu importieren.
  • /btximport:[File] – Importiert ein Werkzeugset in das aktuelle Profilverzeichnis.
  • /bhxadd:[File] – Weist Revu an, eine Füllmustergruppe zu verwenden, die sich an einem anderen Ort als dem Standardspeicherort befindet, ohne sie zu importieren.
  • /bhximport:[File] – Importiert eine Füllmustergruppe in das aktuelle Profilverzeichnis.
  • /blxadd:[File] – Weist Revu an, einen Linienstil zu verwenden, der sich an einem anderen Ort als dem Standardspeicherort befindet, ohne ihn zu importieren.
  • /blximport:[File] – Importiert ein Linieneigenschaftsset in das aktuelle Profilverzeichnis.

Verwendungsbeispiele

Das folgende Skript importiert stumm das Power-Profil sowie die Dateien toolset1.btx und dimensions.btx in dieses Profil:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu\Revu.exe" /s /bpximport:"U:\netProfiles\Power.bpx" /bpxactive:Power/btximport:"U:\netProfiles\Revu\toolset1.btx" /btximport:"U:\netProfiles\Revu\dimensions.btx"
  • /s – Im obigen Beispiel ist ein Schalter zu sehen, mit dem alle Bildschirmaufforderungen, die normalerweise während des Importvorgangs erscheinen, deaktiviert werden.
Der Schalter /s macht die Installation nicht „stumm“.

Importiert ein Profil und setzt es auf „Aktiv“:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bpximport:"U:\Temp\Name_Profile.bpx" /bpxactive:Name_Profile

Importiert ein Werkzeugset:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /btximport:"U:\Temp\name_Toolset.btx"

Importiert ein Füllmuster:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /bhximport:"U:\Temp\name_Hatch.bhx"

Importiert einen Linienstil:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\<RevuVersion#>\Revu\Revu.exe" /blximport:"U:\Temp\name_Line.blx"

Bluebeam, Revu, and Bluebeam Studio are trademarks or registered trademarks of Bluebeam, Inc. Microsoft, SharePoint, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

AutoCAD is a registered trademark of Autodesk in the United States and/or other countries.

© 2020 Bluebeam, Inc. All Rights Reserved.

All other trademarks or registered trademarks are the property of their respective owners.

How-To

Revu 20

Deployment


Introduction
Typically, large organizations face a wide range of challenges, such as finding the most efficient deployment method, and properly configuring an application for use in networked, multi-user settings. We have presented guidelines in the following pages for planning and implementing your Bluebeam Revu deployment.
This guide was written for IT Administrators, under the assumption that the reader has a firm understanding of fundamental concepts, such as software installation, the Windows Command Line, as well as writing and running batch files.

You can find guidelines for post-installation management of your deployment in the Revu 21 Administration Guide
If you’re looking for information about using Revu in your Citrix environment, please refer to Bluebeam Revu in a Citrix Environment

Planning Your Deployment
Compatibility & System Requirements
The latest compatibility information can be found in the Bluebeam Revu 21 Compatibility & System Requirement

Related Articles