Revu 2019 Deployment Guide | Revu 2019

revu
Bluebeam® Revu® Deployment Guide – Version 2019

Introduction

Typically, large organizations face a wide range of challenges, such as finding the most efficient deployment method, and properly configuring an application for use in networked, multi-user settings. We have presented guidelines in the following pages for planning and implementing your Bluebeam Revu deployment.

This guide was written for IT Administrators, under the assumption that the reader has a firm understanding of fundamental concepts, such as software installation, the Windows Command Line, as well as writing and running batch files.

You can find guidelines for post-installation management of your deployment in the Revu 2019 Enterprise Administration Guide.

If you’re looking for information about using Revu in your Citrix environment, please refer to Bluebeam Revu in a Citrix® Environment.

Planning Your Deployment

Compatibility & System Requirements

The latest compatibility information can be found in the Bluebeam Revu 2019 Compatibility & System Requirements.

The Revu 2019 Enterprise Administration Guide

The Revu 2019 Enterprise Administration Guide covers various post-installation topics such as the Bluebeam Administrator Console application, Revu Preferences and settings, license management, Bluebeam Studio, as well as electronic and digital signatures.

The Revu Configuration Editor

The Revu Configuration Editor is an optional tool that allows you to easily configure scripts for your Revu MSI deployment, MSP patch update, or creating scripts for post-installation deployments of custom assets, such as Profiles, Tool Sets, Hatch Patterns, and Line Styles.

As a best practice we highly recommend using this configuration tool for creating all of your deployment scripts, which can be used with your deployment tool or other method of choice. You can still create your deployment scripts manually as described in the Deployment Process section.

The Enterprise Deployment Packages

There are two different packages available for download from our Enterprise Deployment page. The one you choose depends on whether you’re doing a full installation or patching an existing installation.

Both installers utilize the Microsoft Windows Installer framework (msiexec.exe), so it’s very important that the correct Windows Installer version is already installed on your machines.

The MSI Package

This is the file you’ll use for deploying a full installation of any Revu Edition.

It is very important that you download the correct Enterprise deployment package for your environment. Once you have done that, open the .zip file and become familiar with its contents, which are:

The .NET Framework 4.7.1 installation under Windows 10 requires either the Windows 10 Anniversary or Windows 10 Creators Update. For more information, please refer to the Microsoft website.
  • A Visual C++ Redistributable for Visual Studio 2015.
If this is not already installed on the machines, it must be deployed prior to deploying the MSI.
  • A script for removing older Revu versions. (Uninstall Previous Version.txt – Please change the file extension to .bat before running it. Once the file is changed from a text file to a batch file, run it with elevated privileges. This batch file will unregister and uninstall Revu (any version) on the machine).
  • An Add-Remove-Programs (ARP) Modifier, in case you want to display the Edition of your Revu software, in addition to the product name and version number.

The process for running this installer is covered later in this guide, and you should carefully follow the instructions. Please do not take shortcuts or otherwise change the workflow.

The MSP Package

This is used for patch updates from one point release to another within a major version number. The advantage of the MSP file is that it does not need any added configuration because it is being applied to an existing installation of the same major version and Edition, using the same license.

Please make sure you look at the ReadMe file included in the MSP package.

Custom Settings and Assets

If your organization uses custom or shared settings and assets, such as Preferences, Profiles, Tool Sets, and Stamps, please refer to the Revu 2019 Enterprise Administration Guide for the best practices for exporting, gathering and staging these items.

Setting Up a Staging Computer

If you do need to create custom settings and assets as mentioned above, you’ll need to manually install Revu on a machine so you can create and stage these assets, as described in the Managed Net Configuration section of the Revu 2019 Enterprise Administration Guide.

For this single installation, you can download the installer from our Downloads and Updates page.

The Deployment Process

Best Practices

Before we get into the actual steps of the deployment process there are some important details which must be considered:

  • Bluebeam does not support manually editing the MSI (or MSP) file, as it will invalidate the files’ digital signature.
  • We strongly recommend using the Bluebeam Revu Configuration Editor for configuring your deployment options and scripts.
  • If you are upgrading to Revu 2019 from a pre-existing installation of an older Revu version, you must remove the older software first by pushing out the “Uninstall Previous Versions” script included in the Revu 2019 MSI Deployment Package. Any account you use to unregister Revu requires internet access.
    If you’re using SCCM, the Uninstall Previous Version script can be pushed out through a Task Sequence. If you need assistance with the SCCM process, please refer to the Microsoft SCCM documentation.
  • We strongly recommend setting up a pilot group of end-users to test new Revu versions before deploying it throughout your organization.

    If don’t have the new license information at the time, you can deploy Revu to the pilot group as a fully-functional 30-day trial by setting the TRIAL toggle on.

    You can also achieve this by manually setting the BB_SERIALNUMBER property to “TRIAL” (BB_SERIALNUMBER=TRIAL) in your MST file or directly in the deployment script.

  • The MSI file must be run with elevated privileges, regardless of whether the account used is part of the local machines Administrative Group. Windows 10 users should refer to Windows User Account Control for reference. Typically the Windows SYSTEM account is used to install the MSI, since this account has the necessary permissions to install software. However, this account typically does not have Internet Access. If this account is used to uninstall previous versions of Revu, be sure this account can access the Internet, so that it can unregister Revu during the uninstallation process.
  • When Using SCCM

    When creating an MSI Applications Package, selecting the Install for user behavior can be used instead of the SYSTEM account (Install for system). This method of installation allows the user logged in on the client machine to install Revu.

    The user must have access to the internet in order to register and unregister Revu.

Deployment Tools

Regardless of which package or deployment tool you use, your Command Line script will launch the Windows Installer (msiexec.exe) during your installations.

There are various deployment tools which utilize the command line for running an MSI or MSP installer, such as System Center Configuration Manager (SCCM), Quest KACE (formerly Dell KACE), and Microsoft Windows Group Policy.

It is important to note that we only provide support for the use of the command line scripts, and not the deployment tools themselves.

 

When creating an MSI Applications Package, selecting the Install for user behavior can be used instead of the SYSTEM account (Install for system). This method of installation allows the user logged in on the client machine to install Revu.

Authorization

To make sure your software is successfully authorized, your firewall or proxy server must be configured to allow access to our licensing servers listed below, via HTTPS on port 443.

Delayed Authorization

Delayed Authorization is the supported registration method when using deployment tools such as SCCM, and/or in situations where the System account does not have access to the internet. In this instance, Revu will not try to communicate with the licensing servers until the end-user opens Revu post-installation and tries to save a document. The registration process runs “silently” in the background and requires access.

To enable Delayed Authorization you will need to use the DA property found in the MSI Properties Table.

If you are using a Revu Open License with your installations, Delayed Authorizations is not necessary. In fact, it’s highly recommended that you do not use Delayed Authorization.

License Information

In Revu 2019 and above, the full set of features in the eXtreme edition are installed and enabled by default. The edition is determined by the serial number and product key. Once a Standard or CAD license is registered, the feature set for each edition is enabled. Please make sure the licensing information you use matches the Revu edition (Standard, CAD, or eXtreme) you are deploying.  See the Edition Overview page for detailed information about the features in each edition.

The MSI Properties Table

The MSI Properties table lists the properties that allow you to configure and customize the Revu installation.

Required Properties

These properties are needed for successful authorization of the software.

In Revu 2019 and above, the edition of the software made available to your users is determined by the serial number and product key used, which version and edition listed on your License Certificate.

Please contact us if you have lost your License Certificate.

BB_SERIALNUMBER Enter the Revu Serial Number. Enter TRIAL to install as a 30-day trial.
BB_PRODUCTKEY Enter the Revu Product Key. All upper-case characters.

Supported Optional Properties

BB_AUTO_UPDATE Enable or Disable in-app update notification updates: Enabled (default) = 1, Disabled = 0. See notes.
BB_DISABLEANALYTICS Enable or disable sending application usage info to Bluebeam. Send (default) = 0, don’t send = 1. See notes.
BB_DEFAULTVIEWER Set as the default application (default) = 1, Do not change the default = 0. See notes.
BB_DESKSHORTCUT Bluebeam Revu desktop shortcut (default) = 1, No shortcut = 0
BB_DESKSTAPLER Bluebeam Stapler desktop shortcut = 1, No shortcut (default) = 0
BB_FEATURES Disables various Revu features: All Features Enabled = 65535 (default). See Enabling and Disabling Revu Features with BB_FEATURES for more information.
BB_IE_PLUGIN Install and enable = 1, Disable (default) = 0
BB_JOBOPTIONS Enter the UNC or fully-qualified path to your custom. jobOptions file.
BB_NETCONFIG Enter the UNC or fully-qualified path to your managed NetConfig folder.
BB_PAGESIZE Enter “A4” to override default page size for the Bluebeam PDF printer.
DISABLE_WELCOME

Disables the Revu HTML Welcome page and Workflow Training Videos page. Enable (Default) = 0, Disable = 1

Creates a registry entry Computer\HKEY_CURRENT_USER\Software\Bluebeam Software\2018\Revu and DWORD named WorkflowsInitialized“.

BB_REVUPREFERENCES Enter the UNC or fully-qualified path to your RevuPreferences.xml file.
DA Delayed Authorization = 1, Normal Standard Authorization (default) = 0
IGNORE_RBT Disable Check for Pending Reboot = 1, Check for Pending Reboot = 0. See notes.
MBCODE Determines which of the Bluebeam plugins are enabled. The default value of 1023 enables all of them. See Enabling the Bluebeam Plugins with MBCODE for more information
The BB_AUTO_UPDATE Property

When enabled, users will receive an in-app notification when a new Revu update is available.

The BB_DISABLEANALYTICS Property

By default, Revu sends usage data to Bluebeam in order help improve the application. This information is anonymous and is not shared with third parties. Bluebeam will not collect personal information about you. If you want to disable this, deploy your installations with the BB_DISABLEANALYTICS property set to One (BB_DISABLEANALYTICS=1) in your MSI command line script or MST file.

Setting the Default PDF Program with BB_DEFAULTVIEWER

Microsoft has changed how default applications are selected in Windows 8 and above, which result in the BB_DEFAULTVIEWER setting being overridden. This means that your users will have to follow the steps in Changing the Default PDF Viewer. Further information can be found on the Microsoft website.

Enabling and Disabling Revu Features with BB_FEATURES

Each Revu feature has an assigned numerical value as shown in the table below. To disable a feature, subtract its numerical value from the default value of the BB_FEATURES property (65535) shown in the table of Supported Optional Properties above, and enter the answer as the new value for the BB_FEATURES property.

For example, to disable the Redaction feature in a Revu eXtreme deployment, you would subtract the value of that feature (2) from 65535, and then enter the balance (65533) as the new value for BB_FEATURES.

Revu Features and Their Numeric Values:

Administrator Button (Revu Menu) = 128 Product Updates Button (Help menu) = 16
AllFeatures = 255 Redaction in eXtreme (Includes Cut Content & Erase Content in all Editions) = 2
DigitalSignatures = 4 Registration Button (Revu Menu) = 256
EditText = 1 SelfSignCertificates = 8
EditText = 1 SelfSignCertificates = 8
ExportToOffice = 64 TranslateMarkups = 32
Session Following Feature = 512  
More information about the Session Following Feature

Some users may need the ability to prevent other users from following them in a Studio Session in order to comply with privacy and labor regulations. The following scenarios illustrate what happens when this feature is turned off:

User X tries to follow User Y
– User X’s screen will still show as if they are following User Y, but they will not receive any position updates from User Y.

User X sends a “Follow Me” request to all users
– User Y will not display the request dialog

User Y tries to follow User X
– User Y will not be able to follow another user (all Session following UI elements are removed)

Disabling “Check for Pending Reboot”

Setting the IGNORE_RBT to 1 is only required if Microsoft .Net Framework version 4.6.1 or above is already installed on the end-user’s machine, and if it was not restarted after the .Net installation.

For Revu to function correctly the pending reboot must occur at some point after the installation has completed.

Enabling the Bluebeam Plugins with MBCODE

Each of the Bluebeam plugins for supported third-party software has an assigned numerical value, as shown in the table below. If you only want to enable a single plugin – for example, the plugin for AutoCAD— you would replace the default MBCODE value of 1023 (all plugins enabled) with the number 2. In cases where you need to enable more than one plugin, you would add up their numerical values and enter the total as the new MBCODE value. Changing the value to 0 disables all of the plugins.

Bluebeam plugins are only enabled if the third-party application is installed. Refer to the Revu Compatibility Chart to ensure that your third-party applications are supported.

Revu Plugins and Their Numeric Values

All Plugins Disabled = 0 Microsoft Outlook = 128
AutoCAD = 2 ProjectWise = 64
AutoCAD LT (32 & 64-bit) = 4 Revit & Navisworks = 16
Internet Explorer = 32 SketchUp Pro = 256
Microsoft Office = 1 SolidWorks = 8

Markup & View Modes

Revu 2018.x offers two modes of operation: Markup Mode and View Mode. By default, the software is installed in Markup mode, and can be switched between the two from within the Revu menu. In Revu 2018.1 and above, this is also achieved by pushing out the Windows Registry edit described below via Group Policy.

Restricting Users to View Mode Only

To set any or all of your Revu installations View Mode (Revu 2018.1 and above):

  1. Create a new DWORD registry key called ViewModeOnly in HKEY_CURRENT_USER\Software\Bluebeam Software\2019.
  2. Set the value to 1.

When Revu launches in this state, the Markup Mode and Register/Unregister options in the Revu menu will be hidden.

Setting the key Value to 0 or deleting it all together switches the Revu installation back to Markup Mode.

Language Transforms

You can deploy installations in a different language from what Windows uses by setting the TRANSFORMS property to one of the language codes listed below. Otherwise, Revu is installed in the language used by the host operating system by default.

Command line examples for MST and MSI installations can be found later in this guide.

Revu Language Transform Codes:
Danish = 1030 Italian = 1040
Dutch = 1043 Japanese = 1041
English = 1033 Korean = 1042
Finnish = 1035 Norwegian = 1044
French Standard = 1036 Spanish = 1034
German = 1031 Swedish = 1053

Optional Pre-Installation Check

If you’re unsure about which Revu editions are already installed in your user community, it may be a good idea to consider writing a script which queries the following Windows Registry keys. This information is useful if you want to deploy multiple editions of Revu:

HKLM\SOFTWARE\Bluebeam Software\<RevuVersion#>

RevuVersion or RevuBuildNo – Key Data values show the current release version of Revu installed.

HKLM\SOFTWARE\Bluebeam Software\<RevuVersion#>\Licenses

Registered – Key Data value displays the Revu Serial Number.

Edition – String Data value displays the Revu Edition that corresponds to the License that Revu is currently registered with. This value updates when Revu is launched. Possible values are Extreme, Standard, or CAD.

HKEY_LOCAL_MACHINE\SOFTWARE\Bluebeam Software\<RevuVersion#>\BBProduct\Revu

InstalledVer – Key Data value shows the current release version of Revu installed.

PowerShell Scripts

Get-ItemProperty -Path HKLM:\SOFTWARE\Bluebeam?Software\<RevuVersion#>

RevuBuildNo – Key Data values show the current release version of Revu installed

Get-ItemProperty -Path HKLM:\SOFTWARE\Bluebeam?Software\<RevuVersion#>\BBProduct\Revu

InstallVer – Key Data value shows the current release version of Revu installed.

Get-ItemProperty -Path HKLM:\SOFTWARE\Bluebeam?Software\<RevuVersion#>\licenses

Registered – Key Data value displays the Revu Serial Number.

Command Line Scripts

Version:

REG QUERY "HKLM\SOFTWARE\Bluebeam Software\2018\BBProduct\Revu" /v "InstalledVer"

Edition:

REG QUERY "HKLM\SOFTWARE\Bluebeam Software\2018" /v "Edition"

Serial Number:

REG QUERY "HKLM\SOFTWARE\Bluebeam Software\2018\Licenses" /v "Registered"

Deployment Methods

This section covers topics such as Windows Installer Switches, how to write scripts for either full installations using the MSI or patch updates using the MSP, as well as how to deploy multiple Revu Editions – or in different languages within your environment.

A Note about Windows Installer Switches

There are four important Windows Installer switches to be aware of when writing a script for MST, MSI, or MSP installations:

/i

Tells the Windows Installer to call up msiexec.exe to run an installation

/p

Tells the Windows Installer to call up msiexec.exe to run a patch

/qn

This switch lets you run unattended and silent installations

TRANSFORMS

Used if you’ve created an MST that needs to be called up. This is done by entering the folder path to where the MST file is located and the filename of the MST. TRANSFORMS also lets you install Revu in different languages.

Writing an Installation Script

Let’s look at the different methods for deploying your Revu software, each of which utilizes the command line in slightly different ways.

Using a Microsoft Transform (MST) file

This is the preferred method of deploying your installations because:

  • It minimizes typographical errors, as all property/parameter changes are done in the MST file, which is called up by a short command line script. This means you can double-check your changes to the Properties table before they’re passed on during the installations.
  • It allows you to hide the licensing information from your end-users.
Creating and Editing an MST File

If you haven’t done so already, you’ll need to download and install an MSI editor such as InstEd. Once you’ve done that, please follow the steps listed below:

    1. Launch InstEd, click the File menu, and open the original MSI file.
    2. Click the Transform menu and select New Transform.
    3. When the New Transforms dialog opens, name the MST file then click Save.
      The file should not be called “Transforms.mst,” and must be saved in the same folder as the original MSI installer.
    4. Click the Tables tab on the left, select Property in the Tables list. At this point, it might help to click the Property column heading to alphabetically sort the Properties list.
    5. Edit the Properties to suit your requirements.
      DO NOT edit any properties other than the ones listed in the MSI Properties Table
    6. Click the File menu and Save the file.
Writing a Command Line Script that Uses Your MST File

Here are a couple of installation script examples that call up an MST file:

msiexec.exe /i "Bluebeam Revu x64 18.msi" TRANSFORMS=YourMSTFile.mst /qn

A silent German Language Installation:

msiexec.exe /i "Bluebeam Revu x64 18.msi" TRANSFORMS=:1031;MyTransforms.mst /qn

It’s very important that you test your script in an elevated command prompt on a test machine, before deploying the installation to ensure that it runs correctly.

Do not double-click the MSI file. Doing so will install Revu without the required elevated privileges, or any customizations you may have set in the MSI Properties.

Important Note About Transforms

When using a Language TRANSFORMS, the MST file should be in the same root as the MSI. Do not use a path to the MST; just the MST name. Also there should be NO spaces in the name of the MST file and NO quotes around the MST file name.

TRANSFORMS=:1031;MyTransforms.mst
TRANSFORMS=:1031;<do not use path to mst, just the mst file name>

When using TRANSFORMS, the MST file should be in the same root as the MSI. Use quotes around the pathing to the MST file.

TRANSFORMS="C:\Deployment Folder\MyTransforms.mst"
TRANSFORMS=<path with quotes to mst file name>
Using the MSI Properties Directly

Another method of building your deployment is to write a complete installation script which calls up the Revu MSI file and lists all relevant mandatory and optional property changes.

BB_EDITION no longer needs to be passed since the edition is determined by the serial number and product key.

To get an idea of how this is done, look at the following example of a basic installation script written so that Revu Standard installs silently, with Delayed Authorization:

The Revu Serial Number and Product Key must be included in all MSI installation scripts, and the quotation marks must be included in the MSI filename.
Values for an MSI switch (signified by a forward slash) must be enclosed on quotation marks as shown below. For Bluebeam specific properties, spaces must be replaced by question marks.
Before deploying Revu, we recommend writing and proofreading your script in a text editor and running it on a test machine in an elevated command prompt.
msiexec.exe /i "Bluebeam Revu x64 19.msi" BB_SERIALNUMBER=YourRevuSerialNumber BB_PRODUCTKEY=YourRevuProdKey DA=1 /qn

Additional MSI Script Examples

To help give you a better idea of how command line scripts can be written for various installation requirements and configurations please refer to the following examples:

Basic silent installation of CAD Edition:

msiexec.exe /i "Bluebeam Revu x64 19.msi" BB_SERIALNUMBER=YourRevuSerialNumber BB_PRODUCTKEY=YourRevuProdKey /qn

Basic silent installation that also deploys a specific RevuPreferences.xml file

Notice the difference in pathing between the .msi and .xml file:

msiexec.exe /i "\\MyServer\BluebeamDeployment\Bluebeam Revu x64 19.msi" BB_SERIALNUMBER=YourRevuSerialNumber BB_PRODUCTKEY=YourRevuProdKey BB_REVUPREFERENCES=\\MyServer\Bluebeam?Deployment\RevuPreferences.xml /qn

Deploying Multiple Editions of Revu

As the MSI installer includes Revu Standard, CAD, and eXtreme, a single MSI can deploy multiple Editions within your end-user community by staging a single MSI file in a shared location,” which can be called up by any of the three installation scripts (one for each Revu Edition) that you’ll need to write. Each script must include the corresponding values for the BB_SERIALNUMBER and BB_PRODUCTKEY Properties. The edition of Revu is automatically determined by the Serial Number when the machine is registered. Each script must use the correct Serial number for the edition of Revu you want to install.

Once you’ve written and checked your scripts in an elevated command prompt on a test machine, you can use Group Policy or a task sequence in your deployment tool to determine the Revu Edition they should be running, and then automatically run the correct deployment script.

An alternative method of confirming the Edition and Serial Number of an existing Revu installation is to write a script which queries the Windows Registry keys in the section titled “Optional Pre-Installation Check

Updating Existing Installations with an MSP File

This installation file is used for patch updates from one dot release to another within a major version number, while using the same licensing information.

When writing your command line script,” it’s important to note that REINSTALLMODE=omus and REINSTALL=ALL are both required parameters and are case-sensitive. Additional information about Msiexec.exe command line options can be found on the Microsoft website.

We recommend writing and proofreading your script in a text editor, and then running it in an elevated command prompt on a test machine, before deploying the update to your end-users.

To deploy a basic patch update you’ll need to use the following format:

msiexec.exe /p <path to .msp> REINSTALLMODE=omus REINSTALL=ALL

Additional MSP Script Examples Basic silent update:

Msiexec.exe /p <path to .msp> REINSTALLMODE=omus REINSTALL=ALL /qn

Basic silent update with a suppressed reboot:

Msiexec.exe /p <path to .msp> REINSTALLMODE=omus REINSTALL=ALL REBOOT=ReallySuppress /qn
When patching an installation that was originally deployed with modified Properties, you’ll need to include them in your MSP script. Not doing so will reset them to their default values.

Running and Troubleshooting a Deployment

Assuming you have written your script and tried it out in an elevated command prompt on a test machine, you can now run it in a deployment tool of your choice, such as SCCM, Dell KACE, or Group Policy.

If the installations do not go as intended, or otherwise fail,” you’ll need to go back and check your work. If your script is calling up an MST file, reopen it with MSI editor and make sure you’ve correctly set the Properties. After that, confirm that you’ve used the correct syntax in the script you have written which calls up the MST file, and test again in an elevated command prompt on a test machine.

In the case of an MSI or MSP script, check the syntax again to make sure it’s formatted correctly, and that you’ve included the relevant Properties with the correct settings. Once you’ve done that, you should run it on your test machine as described earlier.

The MSI installer creates a verbose log file in %TEMP% directory on the local drive of the machine on which Revu is installed. The naming convention is MSIxxxxx.log” where xxxxx” are random characters like MSIjfb1d6.log.” Review this log for common Windows installation errors.

If you’re using SCCM the log file can be found in C:\windows\temp when installed via the SYSTEM account.
A list of Windows Installer error codes and their definitions on the Microsoft website. website.

Post-Installation: Optional Customization Deployment

Bluebeam Administrator Console

The Administrator application (PbMngr5.exe) lets you perform the following post-installation functions, via the Windows Command line:

  • Install Plugins
  • Set Revu as the Default Application
  • Reinstall/Uninstall our Bluebeam PDF Printer
  • Set default DPI for the Bluebeam PDF Printer
  • Setup Net Config
  • Register License
  • Update License Server with new computer name
  • Expire Trial
  • Backup, Reset, Restore Revu user settings

For more information about the available features you can access the PbMngr5.exe help information from the Windows Command Prompt by clicking Start > Search and typing CMD.

When the Command Prompt opens type cd “C:\Program Files\Bluebeam Software\Bluebeam Revu\2019\Revu followed by PbMngr5.exe /help, and then the Enter key.
Alternatively please refer to the Bluebeam Administrator Help.

Revu Preferences

There are two Bluebeam configuration files containing application settings which can be deployed: the RevuPreferences.xml file which can be deployed at any time, and the UserPreferences.xml which can only be deployed once a new Revu installation has been finished.

There is an issue in 2019.0 that may prevent certain users from opening the Preferences menu after upgrading to Revu 2019 from an older version. See Revu preferences aren’t opening for more information about the issue and how to resolve it.

RevuPreferences.xml

This file contains all settings configured in the Revu Preferences dialog (Ctrl+K). Clicking Export in the dialog window lets you save the RevuPreferences.xml file to any location, such as a centralized folder on a server.

Although it can be deployed as part of an MST or passed as an MSI Command Line, you can also do so post-installation using a command line option that calls up the Bluebeam Administrator. This allows you to automate changes within the Bluebeam Administrator.

Here’s an example of how to deploy an updated set of Revu Preferences where all plugins except the one for Internet Explorer need to remain enabled:

"%ProgramFiles%\Bluebeam Software\Bluebeam Revu\2019\Revu\PbMngr5.exe" /setup /PREFSPATH:"G:\Bluebeam Software\Settings\RevuPreferences.xml"
You can also disable the message asking if Revu should be the default PDF viewer by adding the /DVOFF switch.

You can also copy or push the RevuPreferences.xml file to:

C:\ProgramData\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu
When Revu launches, it will search for the RevuPreferences.xml. When it finds that it’s newer than the UserPreferences.xml file in the user’s %appdata% folder, it will merge the contents into the existing UserPreferences.xml. To change the Modified Date, you will have to make a change to the RevuPreferences.xml file. This can be as simple as adding a space to the start of the text.

Setting an Offline PIN Requirement

Revu 2018 lets users setup and Offline PIN for accessing Studio files when they’re not connected to Bluebeam Studio. Although this isn’t a default requirement, you can make it so by editing the Studio section of the RevuPreferences.xml file on your staging and export it to a staging location on your network. Typically this is the same location as the MSI you are deploying.

The RevuPreferences.xml modification consists of:

         <Studio>
         <RequireOfflinePIN>True</RequireOfflinePIN>
         </Studio>

This can be deployed using the BB_REVUPREFERENCES MSI property.

When this preference is set, Offline PIN creation will be required for all new and existing Studio users. They will not be able to log into Bluebeam Studio without doing so.

UserPreferences.xml

This file contains settings for an individual Revu user. Although this file cannot be deployed to existing installations, it can be deployed to a new one, prior to their initial launch, by pushing a modified UserPreferences.xml to the following location on each machine:

C:\Program Files\Common Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu
Assuming you have already gathered your custom assets such as Profiles and Tool Sets while planning your deployment, you can also copy them to this location.
The first time Revu is launched, the files are automatically copied to the following location in their roaming Windows User Profile:
%APPDATA%\Roaming\Bluebeam Software\<RevuVersion#>\Revu

Merging Revu Preferences

If you only want to add new settings, you should first open the RevuPreferences.xml file in a text editor and add Merge=”True” to the beginning of the file as shown below, before staging it for deployment. After you have made all your edits, delete all the other settings that you do not want to change. Refer to the Revu Enterprise Administration Guide for more information. The Merge process is a replacement of the data to be updated or edited in the RevuPreferences.xml file.

Example of an Edited RevuPreferences.xml File

The following set of Revu Preferences provides a Revu installation which merges these settings into an existing UserPreference.xml file (Merge=”True”), provides the URL for an organization’s SharePoint server:

<?xml version="1.0" encoding="utf-8"?>
<RevuPreferenceDictionary Version="2" Merge="True">
<DocManSys>
<ActiveIndexx64.>0</ActiveIndexx64.>
<AdvancedTestIfSharePointPathx64.>False</AdvancedTestIfSharePointPathx64.>
<AutoDetectProjectWisex64.>False</AutoDetectProjectWisex64.>
<CacheSharePointFilesx64.>False</CacheSharePointFilesx64.>
<CertificateAuthentication.x64.0>False</CertificateAuthentication.x64.0>
<CertificateAuthentication.x64.1>False</CertificateAuthentication.x64.1>
<CheckcoutOnOpenFromHyperlinks.x64.0>False</CheckcoutOnOpenFromHyperlinks.x64.0>
<CheckcoutOnOpenFromHyperlinks.x64.1>False</CheckcoutOnOpenFromHyperlinks.x64.1>
<CheckoutOnOpen.x64.0>False</CheckoutOnOpen.x64.0>
<CheckoutOnOpen.x64.1>False</CheckoutOnOpen.x64.1>
<ClaimsSupported.x64.0>False</ClaimsSupported.x64.0>
<ClaimsSupported.x64.1>True</ClaimsSupported.x64.1>
<Countx64.>2</Countx64.>
<DefaultFileFilterPDF>True</DefaultFileFilterPDF>
<DocumentHiddenLibrary.x64.0></DocumentHiddenLibrary.x64.0>
<DocumentHiddenLibrary.x64.1></DocumentHiddenLibrary.x64.1>
<DocumentLibrary.x64.0></DocumentLibrary.x64.0>
<DocumentLibrary.x64.1></DocumentLibrary.x64.1>
<LastAccessedLibraryPath.x64.0>Test</LastAccessedLibraryPath.x64.0>
<LastAccessedLibraryPath.x64.1></LastAccessedLibraryPath.x64.1>
<LoginName.x64.0>sa</LoginName.x64.0>
<LoginName.x64.1>sa</LoginName.x64.1>
<Password.x64.0></Password.x64.0>
<Password.x64.1></Password.x64.1>
<PromptForCheckinCommentsx64.>True</PromptForCheckinCommentsx64.>
<PromptForCheckoutFromIEx64.>True</PromptForCheckoutFromIEx64.>
<RegKey.x64.0>SharePoint2007</RegKey.x64.0>
<RegKey.x64.1>SharePoint2007</RegKey.x64.1>
<SelectionDialogx64.>False</SelectionDialogx64.>
<SharePointUseExistingCookies>True</SharePointUseExistingCookies>
<SharePointXmlDebug>False</SharePointXmlDebug>
<Site.x64.0>http://sharepointserver1</Site.x64.0>
<Site.x64.1>http://sharepointserver2</Site.x64.1>
<SiteAlias.x64.0>SharePoint</SiteAlias.x64.0>
<SiteAlias.x64.1 />
<SiteAlias.x64.2></SiteAlias.x64.2>
<SiteAlias.x64.3></SiteAlias.x64.3>
<StoreLastAccessedFolderx64.>True</StoreLastAccessedFolderx64.>
<TestIfSharePointPathx64.>True</TestIfSharePointPathx64.>
<ToolbarIntegrationOnlyx64.>True</ToolbarIntegrationOnlyx64.>
<UseDefaultCredentialsx64.>True</UseDefaultCredentialsx64.>
</DocManSys>
</RevuPreferenceDictionary>

*These Sharepoint server URLs will change when the data is merged with the Revu Preferences file.

Deploying Revu in View Mode While Allowing Users to Switch to Markup Mode

For example, if you only were concerned with pushing out Revu in View Mode but allow users to be able to switch to Markup Mode, these are the only six lines you would need in your RevuPreferences.xml file. Note this example uses Merge=”True” for merging this setting into a users existing RevuPreferences, without changing any of their existing settings.

<?xml version="1.0" encoding="utf-8"?>
<RevuPreferenceDictionary Version="2" Merge="True">
<General>
<RevuAppDefaultModeInt>2</RevuAppDefaultModeInt>
</General>
</RevuPreferenceDictionary>

Restricting Users to View Mode Only

Please refer to Markup & View Modes if you are interested in restricting users to View Mode only.

Deploying Custom Extensions via the Revu.exe Command Line

Revu.exe Command Line Switches

The following switches allow you to determine how the import process runs and which assets to copy into a user’s default local %appdata% Revu roaming folder:

Importing assets or settings copies them as described above, whereas “Adding” them creates a reference (link) to a shared asset located on a network drive or other non-default location.
  • /s – You’ll notice this switch in the example shown above, which turns off any on-screen prompts that normally appear during the import process.
    The /s switch does not make the installation “silent.”
  • /bpximport:[File] – Imports and activates a profile.
  • /bpxdir:[Path] – Lets you specify a folder path if you want to designate a new profile directory. This is the path to a network shared location where Profiles are located and shared across an organization.
    To prevent users from making changes to the Profiles in this directory, set its Folder Permissions to “Read Only.”
  • /bpxactive:[Name] – Designates a specific Profile as “Active in either the users local %appdata% Revu roaming folder or in a shared Profile directly if you have used /bpxdir: to specify a shared Profile directory in a network location. Make sure the Profile you set as Active is in the specified directory.
    Setting a Profile as Active suppresses the initial “Select a Revu Profile and “Studio Sign-in” dialogs that appear the first time a new Revu installation is opened.
  • /btxadd:[File] – This tells a Revu installation to use a Tool Set located in a non-default location without importing it.
  • /btximport:[File] – Imports a Tool Set into the current profile directory.
  • /bhxadd:[File] – Tells Revu to use a Hatch Pattern set located in a non-default location without importing it.
  • /bhximport:[File] – Imports a Hatch Pattern set into the current profile directory.
  • /blxadd:[File] – Tells Revu to use a Line Style located in a non-default location without importing it.
  • /blximport:[File] – Imports a Line Style set into the current profile directory.

Usage Examples

The following script silently imports the Power Profile, as well as the “toolset1.btx” and dimensions.btx files, into that profile:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\RevuVersion#\Revu\Revu.exe"
/s /bpximport:"U:\netProfiles\Power.bpx"
/bpxactive:Power/btximport:"U:\netProfiles\Revu\toolset1.btx"
/btximport:"U:\netProfiles\Revu\dimensions.btx"
When creating and exporting custom Profiles, it best to include any dependencies such as custom Tool Sets, Hatch Patterns, Line Styles, Custom Columns, or Custom Statuses. Embedding them into the Profile in this manner makes it a lot easier to share these custom resources across an organization.

Imports a profile and makes it active:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\< RevuVersion#>\Revu\Revu.exe" /bpximport:"U:\Temp\Name_Profile.bpx" /bpxactive:Name_Profile

Imports tool set:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\< RevuVersion#>\Revu\Revu.exe" /btximport:"U:\Temp\name_Toolset.btx"

Imports hatch pattern:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\< RevuVersion#>\Revu\Revu.exe" /bhximport:"U:\Temp\name_Hatch.bhx"

Imports line style:

"C:\Program Files\Bluebeam Software\Bluebeam Revu\< RevuVersion#>\Revu\Revu.exe" /blximport:"U:\Temp\name_Line.blx"

ARP Modifier

As mentioned earlier in this guide, the MSI Installation package includes an Add-Remove Programs (ARP) Modifier, in case you want to display the Edition of your Revu software, in addition to the product name and version number.

ARP renaming is determined by the Revu license information that that was passed during the installation process.

Examples:

ARP_Modifier_<version>.exe
ARP_Modifier_<version>.exe <parameter>

Calls up the file from a script where the ARP Modifier is located on a network drive:

"\\MyServer\Bluebeam Software\ARP_Modifier_<version>.exe

Calls up the file from a script passing the parameter of 1 for the CAD edition :

"\\MyServer\Bluebeam Software\ARP_Modifier_<version>.exe" 1

Accepted parameters are either a value or a string as shown below:

Value String
0 = Standard standard
1 = CAD cad
2 = Extreme extreme
-1 = Clear clear
The value of -1 = Clear” or the string clear” hides the Revu edition.

Using the Revu Configuration Editor

With the release of Revu 2019, our MSI packages include our new Bluebeam Revu Configuration Editor, which was designed to simplify the Bluebeam Revu deployment process.

The main screen lets you select and configure a New Deployment using our MSI installer, Patch (update) an existing Deployment using a Revu MSP installer, or add any Extensions (Profiles, Tool Sets, etc.). You can also visit our License Key Lookup page to confirm that your license information is accurate.

The Revu Configuration Editor only supports the MSI and MSP files for Revu 2019 and above.

The Analytics opt-in check box, which allows collection of usage data to improve the application is checked by default. When enabled, Revu usage data is automatically captured and sent to Bluebeam servers. This does not capture or transmit Individual user data, and you can opt out by unchecking the box.

New Deployment (MSI)

New Deployment Location

 width=

Start by selecting the Bluebeam Revu 2019 MSI file you want to deploy and specify its Deployment Folder. It’s important that this location is on a centrally located network drive that will be able to reach all users during deployment. You also have the option clicking “Use configuration from a previous deployment” to add an MST file to utilize any pre-configured custom parameters.

License Information

 width=

Because the BB_EDITION property is no longer necessary in Revu 2019 and above, the Edition (Standard, CAD, or eXtreme) will be determined by the Serial Number and Product Key entered. This automatically occurs during the installation process.

As a best practice, we strongly recommend setting up a pilot group of end-users to test any new Revu version before deploying it throughout your organization.

If don’t have the licensing information at that time, you can deploy Revu as a fully-functional 30-day trial by switching on “Use Trial.”

Deployment Configuration

 width=

This page offers options for configuring various MSI properties such as:

  • Delayed Authorization
  • Set Revu as Default PDF Viewr
  • In-App Update
  • Language Update
  • Default Page Size
  • Job Options Path
  • Net Config

Please refer to the MSI Properties Table for further information.

If you’re going to use a RevuPreferences.xml file it should be located on a central network drive that can reach all users during the deployment. This would be the same Deployment Folder you specified as the New Deployment Location earlier.

Revu Features

All features on this page are switched on by default. Before making your final decision about which one should remain “Off,” please contact a Project Manager or someone in your organization who has a deep knowledge of all end-user workflows, and the Revu features required to complete them. Their advice will help mitigate end-user reports of missing features within their Revu installations.

Bluebeam Plugins

All features on this page are switched on by default. This page is where you can activate our plugins for various third-party applications.

Internet Explorer, Microsoft Office, Microsoft Outlook, and ProjectWise are available in all Revu editions (Standard, CAD, or eXtreme).

All other plugins listed require Revu CAD or eXtreme.

Create Deployment Package

This dialog is where your Deployment Script is generated.

 data-attachment=

The Deployment Folder field will auto-populate based on the folder you specified while setting the New Deployment Location.

Once you’ve configured the Skip Pending Reboot and Silent Install Properties, click Create to generate your Deployment Script and save it in the Deployment Folder along with any files you may have designated earlier.

A reboot may be required for files that were in use during installation. You can prevent a forced reboot, but the pending reboot must occur at some point after the installation has completed for Revu to function correctly.

A silent installation is a Windows Installer command line option represented by /qn in your deployment script.

Patching an Existing Deployment (MSP)

This deployment method is used when updating from one point-release to another within the same major version. For example, updating from 2019.0 to 2019.x.

In this scenario the MSP installation is applied to an existing installation of the same version. In other words, the MSP will update any Revu edition (Standard, CAD, or Extreme), but the features available to the user are determined by the licensing information from the original installation being updated.

Deployment Location

Start by selecting the Bluebeam Revu MSP file you want to deploy and specify its Deployment Folder. It’s important that this location is on a centrally located network drive that can reach all users during deployment. You also have the option to add an MST file to utilize any previously configured custom parameters.

Use configuration from a previous deployment

This optional setting lets you select a pre-existing MST file from a previous MSI deployment and reapply its properties during the MSP deployment.

You also will need to select the MSI file that was used to create the MST file selected above.

The properties used in the MST will be extracted and used in the MSP deployment script. If you don’t have the original MSI file you can download another copy, but it must be that same version.

Deployment Configuration

When setting the parameters on this page, it’s important to set up the same configuration used in the original MSI deployment that you’re updating.

For example,” if the original MSI was deployed with “Set As Default PDF Viewer” (BB_DEFAULTVIEWER) and “Revu Desktop Shortcut” (BB_DESKSHORTCUT) switched on, you need to make sure these options are also switched on for this MSP deployment, otherwise these values revert back to their default settings.

A reboot may be required for files that were in use during installation. You can prevent a forced reboot, but the pending reboot must occur at some point after the installation has completed for Revu to function correctly.

Revu Features

All Revu features will be enabled by default. As with the Deployment Configuration settings above, it’s important to set up the same configuration used in the original MSI deployment that you’re updating, otherwise your end-users will find that the wrong features have been disabled or enabled.

Although a Patch (MSP) deployment does not create an MST file, it does add the associated Property settings to the Deployment script.

Bluebeam Plugins

If any of these plugins were enabled during your initial MSI deployment, you need to enable the same plugins here, to ensure they remain active after the patch is installed.

Although a Patch (MSP) deployment does not create an MST file it does add the associated Properties settings to the Deployment script.

Create Deployment Package

This dialog is where your Deployment Script is generated.

The Deployment Folder field will auto-populate based on the folder you specified while setting the Patch Deployment Location.

Once you’ve configured the Skip Pending Reboot, Silent Install,” and Suppresses Reboot Properties, click Create to generate your Deployment Script and save it in the Deployment Folder along with any files you may have designated earlier.

REINSTALLMODE=omus and REINSTALL=ALL are both required installer command line options and will automatically output into your command line script.
Additional information about Msiexec.exe command line options can be found on the Microsoft website.

Deploying Extensions

This is a post-installation process in which custom or shared settings and assets, such as Preferences, Profiles, and Tool Sets are deployed using a separate script.

If you need to create custom settings and assets you’ll need to manually install Revu on a machine, and refer to the Revu Enterprise Administration Guide for the best practices for exporting, gathering and staging these items.

For further details on Post Installation scripting command line options refer to Revu.exe Command Line Switches.

Deploy Profiles

Custom Profiles can be added here by clicking the plus sign in the lower-left corner,” navigating to the server location you’d designated as described in the Revu Enterprise Administration Guide, selecting the items, and clicking Add.

 width=

Deploy Tool Sets, Hatch Patterns & Line Styles

 width=

To include any custom Tool Sets, Hatch Patterns, and Line Styles in the deployment, click the plus sign in the lower-left corner,” navigate to the server location you’d designated as described in the Revu Enterprise Administration Guide, select the items and then click Add.

As a best practice when creating Profiles for a deployment we suggest embedding Tool Sets, Hatch Patterns & Line Styles into them so that these additional items are deployed with the Profile, allowing you to skip this section.

Create Custom Assets & Settings Scripts

 width=

On this final window, you can Designate a New Profile Directory on your network, where Profiles are located and shared across an organization. Leaving this switched off results in all assets being copied to each end-user’s machine.

Any assets previously selected, prior to this screen, are also copied into the Deployment folder.

The Silent Import option is switched on by default, but you can turn it off if you would like the end-users to see any prompts that may appear during the deployment.

Checking Your Licenses

License Key Lookup

 width=

Selecting the Check Licenses option on the Welcome page takes you to the License Key Lookup page, where once you’ve entered the Serial Number, Product Key, and Primary Contact Email address, you will see all information attached to your license.

This includes a list of all machines names using the software, and the number of available seats.

You can also look up and manage your Revu licenses in the Bluebeam Gateway.


Bluebeam, Revu, and Bluebeam Studio are trademarks or registered trademarks of Bluebeam, Inc. Microsoft, SharePoint, and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

AutoCAD is a registered trademark of Autodesk in the United States and/or other countries.

© 2019 Bluebeam, Inc. All Rights Reserved.

All other trademarks or registered trademarks are the property of their respective owners.

Related Articles