Utilisez l’ Administrateur Bluebeam

Applicable à :

  • Rév 21

L’administrateur Bluebeam vous permet de configurer Revu via les différents onglets décrits dans les sections suivantes.

L’ Administrateur Bluebeam doit pouvoir être exécuté avec des privilèges élevés, et votre pare-feu et serveur proxy ne doivent pas l’empêcher de se connecter à Internet.

Onglet Plug-ins

Cet onglet affiche une liste des applications installées prises en charge par notre plug-in PDF, détectées par le « Bluebeam Admin User.exe » qui se lance au démarrage de la machine du client.

All formules Bluebeam will list the plugins for Microsoft Office (Word, Excel, Power Point, and Outlook). Plugins for AutoCAD, Revit, SolidWorks, and Navisworks will be available for Core, Complete, or Max plan.

Activer un plug-in

Vous pouvez trouver plus d'informations sur la résolution des problèmes de plug-in sur cette page, mais si un plug-in est manquant dans une application prise en charge, vous pouvez l'activer en suivant les étapes ci-dessous :

Pour activer les plugins, vous devez disposer des droits d'administrateur sur l'ordinateur.
  1. Fermez Revu, s’il est ouvert.
  2. Sélectionnez le bouton Démarrer de la barre des tâches de Windows et recherchez Administrateur Bluebeam .
  3. Cliquez avec le bouton droit sur Bluebeam Administrator et sélectionnez Exécuter en tant qu’administrateur.
  4. Lorsque vous y êtes invité, entrez vos informations d’identification d’administrateur.
  5. Sélectionnez l’onglet Plugins .
  6. Sélectionnez l’application que vous souhaitez activer.
  7. Sélectionnez OK.
  8. Ouvrez Revu.

Onglet Configurations Net (Net Config)

Cet onglet vous permet de définir l’emplacement de divers paramètres et ressources Revu. Ils peuvent rester dans les dossiers locaux par défaut répertoriés dans la section Non gérée, ou ils peuvent être accessibles à partir d’un emplacement de serveur centralisé que vous pouvez définir dans la section Configuration réseau gérée. Vous pouvez également configurer Revu pour utiliser une combinaison d’emplacements locaux et réseau en fonction des chemins de dossiers que vous définissez dans la section Non gérée.

Configurations Net non gérées

Dans une installation typique de Revu, l’option Unmanaged est activée par défaut. Les ressources et les paramètres se trouvent à différents emplacements du profil Windows de l’utilisateur sous C:\ProgramData.

Email Templates uses a different default folder: C:\Users\Documents\Bluebeam\E-mail

Configuration Net gérée

Pour configurer vos installations de Revu afin qu’elles accèdent à tous les paramètres et à toutes les ressources à partir d’un emplacement de serveur centralisé, sélectionnez un ordinateur à utiliser comme machine d’« essai » et copiez tous les paramètres ou ressources personnalisés dans leurs emplacements par défaut correspondants qui sont répertoriés lorsque l’option « Non gérée » est activée.

Ouvrez les emplacements de dossiers par défaut en double-cliquant sur leurs chemins de dossiers correspondants.

  1. Lorsque vous avez terminé de copier les éléments, activez l’option Configuration Net gérée. Une boîte de dialogue s’ouvrira, dans laquelle vous pourrez soit rechercher un dossier réseau existant que vous souhaitez utiliser comme emplacement centralisé, soit créer un nouveau dossier réseau. Sélectionnez le dossier et cliquez sur Sélectionner le dossier.
  2. Lorsque la boîte de dialogue Copy All Files s’ouvre, sélectionnez l’une des options suivantes :
    • Copier tout: crée des dossiers pour le type d’actif ou le paramètre dans l’emplacement du serveur, et copie tout vers l’emplacement correct.
    • Fusionner: prend tous les paramètres et toutes les ressources définis localement et les fusionne avec les éléments existants de l'emplacement partagé.
    • Aucune copie: pointe vers le dossier réseau, mais ne copie ni n’intègre rien dans le dossier. Une fois l’opération terminée, l’onglet Net Config affichera les emplacements de tous les actifs et paramètres.
Pour empêcher vos utilisateurs finaux d'apporter des modifications au dossier réseau centralisé, définissez les autorisations du dossier sur Lecture seule.

Onglet Imprimante

Cet onglet est divisé en quatre sections (Options d'imprimante, Imprimante, Moniteur de port et Résolutions d'image) qui offrent des caractéristiques et des fonctions permettant de contrôler et de réinstaller l'imprimante PDF Bluebeam.

Options de l’imprimante

Ces options déterminent ce qui se passe pendant et après la création d’un PDF à l’aide de l’imprimante PDF ou de Stapler :

  • Demander le nom de fichier: lorsque cette option est activée, une boîte de dialogue Enregistrer sous s’affiche, invitant l’utilisateur à saisir un nom de fichier et, si nécessaire, à choisir une destination pour le nouveau PDF.
  • Delete Source PS File: Cette option est désactivée par défaut. Lorsque cette option est activée, le fichier PostScript sur lequel se base le fichier PDF est supprimé une fois le document généré.
  • Ouvrir dans la liseuse: ce paramètre détermine si le nouveau PDF s’ouvrira dans l’application PDF par défaut sur l’ordinateur de l’utilisateur.
  • Stapler Context Menu: Lorsque cette option est activée, les options Combiner les fichiers dans Revu et Convertir les fichiers dans Revu seront disponibles lorsque l'utilisateur clique avec le bouton droit sur un fichier applicable sur son bureau ou dans l'Explorateur de fichiers.
    L'utilisateur doit disposer des droits d'administrateur sur la machine pour pouvoir modifier ce paramètre.
  • Options du dossier: ouvre la boîte de dialogue Options du dossier, qui vous permet de sélectionner l'emplacement par défaut pour enregistrer les nouveaux fichiers PDF produits à l'aide de Bluebeam Stapler. Les options disponibles sont les suivantes :
    • Dossier source: l’emplacement du fichier source d’origine.
    • Dernier dossier enregistré: le dernier dossier dans lequel un nouveau PDF a été enregistré.
    • Custom Projects Folder : Cette option vous permet de spécifier un emplacement par défaut différent.

Résolutions de l’image

La liste Résolutions affiche les résolutions d'image qui apparaîtront dans la fenêtre Enregistrer sous pour l'imprimante PDF Bluebeam , l'agrafeuse et les plug-ins Bluebeam .

Imprimante

En plus d'afficher le nom de l'imprimante, le pilote et le port de l'imprimante, la section Imprimante vous permet de sélectionner la taille de page par défaut dans la liste des tailles de page disponibles. Vous pouvez également utiliser le bouton Gérer les pages pour modifier la liste des tailles de page comme décrit ci-dessous.

De plus, vous pouvez désinstaller et réinstaller l'imprimante PDF Bluebeam à l'aide du bouton Réinstaller l'imprimante lors du dépannage des problèmes de performances.

Gérer les pages

Sélectionnez Gérer les pages pour accéder à la boîte de dialogue Formats de page, où vous pouvez ajouter, supprimer ou modifier les formats de page utilisés par Revu, l’imprimante PDF, Stapler et les modules externes.

Il s'agit des mêmes paramètres de taille de page (PrtPageSizes.xml) qui sont copiés à partir de leur emplacement par défaut (%ProgramData%\Bluebeam Software\Bluebeam Revu\21\Brewery\V45\Printer Support) lors de la configuration d'une configuration réseau gérée.

Réinstaller l’imprimante

Si un utilisateur rencontre un problème avec l’imprimante PDF Bluebeam ou Stapler, (par exemple, si la boîte de dialogue Enregistrer sous n’apparaît pas lors de la création d’un PDF), sélectionnez Réinstaller l’imprimante afin de réinstaller l’imprimante PDF.

Si cela ne fonctionne pas, vous pouvez également effectuer un clic droit sur le bouton Réinstaller l’imprimante et sélectionner Installer l’imprimante.

Une fois que vous avez installé l’imprimante PDF Bluebeam, rendez-vous dans la section Périphériques et imprimantes du panneau de configuration Windows pour vérifier qu’elle y est également installée.

Moniteur de port

The Port Monitor is based on the BBPrint.exe process, which runs on a per-utilisateur basis, and watches the utilisateur's printer folder (C:\ProgramData\Bluebeam logiciel\Print Jobs\) for files to process.

Assuming that BBPrint.exe is enabled as a Startup item, it's likely that the Port Monitor isn't running if the Save As dialog never appears or un utilisateur is otherwise unable to produce PDFs using the Bluebeam PDF printer or Stapler. Dans ce cas, la boîte de dialogue sur le statut du moniteur de port affichera « <n/a> ». Redémarrez le moniteur de port en suivant les instructions de la section suivante.

Redémarrer le moniteur de port

Si le statut du moniteur de port affiche <n/a> ou si la boîte de dialogue Enregistrer sous ne s’affiche pas lors de la création d’un PDF, redémarrez le moniteur de port. Une fois qu’il est à nouveau en cours d’exécution, le statut doit indiquer « Réponse en cours », et BBPrint.exe doit être répertorié comme un processus en cours d’exécution dans le Gestionnaire des tâches de Windows.

Onglet Formats de pages AutoCAD

Cet onglet est disponible pour les abonnés Core, Complete ou Max sur les machines sur lesquelles un produit AutoCAD compatible est également installé.

Sélectionner les formats de page (ANSI, ARCH ou ISO) que vous souhaitez rendre disponibles sous l'onglet de configuration de page du plugin AutoCAD.

Cases à cocher ANSI, ARCH et ISO

Comme alternative à la sélection des tailles individuelles, vous pouvez utiliser la case à cocher ANSI, ARCH et ISO pour sélectionner ou désélectionner des groupes entiers de types de tailles.

Type de PDF

Le menu déroulant Type de PDF vous permet de décider quel pilote d’imprimante sera utilisé lors de la création de fichiers PDF à partir d’AutoCAD. Vos choix sont soit le pilote PDF par défaut, soit le pilote Heidi (AutoCAD HDI), qui sont expliqués ci-dessous :

Imprimante

Cette option utilise l’imprimante PDF Bluebeam, qui prend en charge les polices TrueType afin de créer des fichiers PDF à partir d’AutoCAD avec du texte consultable. En plus d’offrir une meilleure qualité d’image, ce pilote vous permet également d’ajouter davantage de formats de page et de les synchroniser sur votre réseau pour qu’ils puissent être utilisés par tous vos utilisateurs Core, Complete, et Max.

Heidi

The Heidi option uses the AutoCAD HDI driver, which doesn't support TrueType fonts and "draws" non-searchable text as Vector data. Cependant, vous pouvez créer des tailles de page personnalisées et les synchroniser sur votre réseau afin que tous vos utilisateurs Core, Complete et Max puissent les utiliser.

Synchroniser les formats de page sur votre réseau

Pour centraliser vos tailles de page personnalisées pour tous les utilisateurs Core, Complete et Max, suivez les étapes ci-dessous selon que votre organisation utilise ou non l’imprimante PDF Bluebeam ou le pilote AutoCAD Heidi :

  1. Sélectionnez un ordinateur à utiliser comme machine de transfert et créez vos tailles de page personnalisées dessus.
  2. Accédez à l’onglet Net Config, puis sélectionnez l’ellipse située à droite du chemin d’accès du dossier par défaut du pilote d’imprimante.
  3. Accédez à un dossier réseau existant que vous souhaitez utiliser comme emplacement centralisé ou créez un nouveau dossier réseau.
  4. Sélectionnez le dossier et sélectionnez Sélectionner le dossier.
  5. Lorsque la boîte de dialogue Copier tous les fichiers de format de page d’imprimante s’ouvre, sélectionnez Copier tout.

    Cela copie le fichier prtPages.xml de l'emplacement par défaut sur le lecteur local vers l'emplacement réseau, et le nouveau chemin d'accès au dossier du pilote d'imprimante sera répertorié dans l'onglet Net Config.

  6. Sélectionnez OK.

Configurer d’autres machines pour qu’elles utilisent les formats de page centralisés pour l’imprimante PDF

Ce paramètre peut être distribué à d'autres abonnés Core, Complete et Max dans le cadre d'un déploiement MSI, ou vous pouvez configurer manuellement chaque machine en suivant les étapes indiquées ci-dessous :

Les fichiers PC3 centralisés ne peuvent pas être utilisés lorsque le type PDF est défini sur Imprimante. Ils ne peuvent être utilisés que lorsque le pilote Heidi est sélectionné.

Si cela se produit dans le cadre d’un déploiement MSI, les modifications ne prendront effet qu’après le redémarrage de la machine du client. Un redémarrage n’est pas requis lors de la configuration manuelle d’une machine individuelle.

  1. Ouvrez Bluebeam Administrator et accédez à l’onglet Net Config .
  2. Sélectionner l'ellipse située à droite du chemin du dossier par défaut pour le pilote d'imprimante.
  3. Locate and sélectionner the network folder which contains the prtPages.xml, and select Select Folder.
  4. When the Copy all Printer page Size Files dialog s'ouvre, sélectionner No Copy.
  5. Sélectionnez OK.

Synchroniser les tailles de page pour le pilote Heidi

  1. Sélectionnez un ordinateur à utiliser comme machine d’« essai », et créez vos formats de page personnalisés sur celui-ci.
  2. Sélectionnez l’onglet Net Config, puis double-cliquez sur le chemin du dossier pour le pilote Heidi.
  3. Accédez à un dossier réseau existant que vous souhaitez utiliser comme emplacement centralisé, ou créez un nouveau dossier réseau.
  4. Sélectionnez le dossier et cliquez sur Sélectionner le dossier.
  5. Lorsque la boîte de dialogue Copier tous les fichiers PC3 Bluebeam s’ouvre, sélectionnez Copier tout. Cette opération copie les fichiers PC3 de l’emplacement par défaut sur le lecteur local vers l’emplacement réseau, et le nouveau chemin de dossier pour le pilote Heidi sera répertorié dans l’onglet Net Config.
  6. Sélectionnez OK.

Configurer d'autres machines pour utiliser les fichiers PC3 centralisés

Ce paramètre peut être distribué à vos autres clients Core, Complete et Max dans le cadre d’un déploiement MSI tel que décrit dans le Guide de déploiement de Revu en entreprise, ou vous pouvez configurer manuellement des machines individuelles en suivant les étapes énumérées ci-dessous :

Les fichiers PC3 centralisés ne peuvent être utilisés pour le plugin AutoCAD que si le pilote Heidi est sélectionné. Les fichiers PC3 centralisés ne peuvent pas être utilisés pour l'imprimante PDF Bluebeam .

Si cela est distribué dans le cadre d’un déploiement MSI, la machine cliente doit être redémarrée avant de pouvoir être utilisée.

  1. Ouvrez Bluebeam Administrator et accédez à l’onglet Net Config .
  2. Cliquez sur l'ellipse située à droite du chemin du dossier par défaut du pilote Heidi.
  3. Localiser et sélectionner le dossier réseau qui contient les fichiers PC3, puis cliquer sur Sélectionner Folder.
  4. Lorsque la boîte de dialogue Copier tous les fichiers PC3 Bluebeam s’ouvre, sélectionner No Copy.
  5. Sélectionnez OK.

Clés de registre concernées

Les deux clés de registre suivantes sont modifiées lorsque les tailles de pages de l'imprimante PDF et les fichiers PC3 sont centralisés :

Les chemins de dossiers indiqués ci-dessous sont uniquement à des fins de démonstration.
[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Brewery\V45]"PageSizeConfigFile"="U:\\netconfig\\PtrPageSizes\\"
[HKEY_CURRENT_USER\Software\Bluebeam Software\21\Plugins\AutoCAD]"PC3Path"="U:\\netconfig\\PC3"

Journaux d’assistance

Si vous rencontrez des problèmes avec Revu ou ses plug-in, il existe plusieurs façons d’accéder aux fichiers journaux et, si nécessaire, de les envoyer par e-mail à notre Groupe d’assistance technique.

Pour permettre à l'assistance technique de mieux dépanner votre problème, activez le débogage étendu dans les préférences de Revu .

Pour afficher les fichiers journaux, veuillez sélectionner Aide > Explorer le dossier du journal.

Pour envoyer les journaux par e-mail à l’assistance technique Bluebeam, sélectionnez Aide > Journaux des e-mails envoyés à l’assistance.

Avant d'envoyer les fichiers journaux, veuillez essayer de reproduire le problème.

L’envoi des journaux par e-mail à l’assistance crée de nouvelles entrées de journal spécifiques au problème et crée un fichier zip (logs.zip) contenant l’ensemble complet des fichiers journaux pour Revu.