RDP LoadLibrary Error 126: “The specified module could not be found”

Applies to:

  • Revu 21
  • Revu 20
  • Revu 2019

Problem

You’re attempting to access Revu on a host computer or server using Microsoft Remote Desktop Protocol (RDP), and you encounter the following error:

Cause 

This error could be the result of various compatibility factors when using Revu via RDP, including out-of-date drivers, or a poor network connection. 

Revu is not officially supported in an RDP environment. To learn more about supported virtual environments for Revu 20 and below, see the compatibility section in Bluebeam Revu in a Citrix Environment. Revu 21 has not been tested or certified for use in virtual environments and is not yet supported for Citrix.

Solution

The following are potential solutions to resolve this issue. Depending on your specific environment, all solutions listed may not be viable.

Change the Rendering Engine settings
  1. In Revu, go to Revu > Preferences > Advanced > 2D Rendering.
  2. Under Rendering Engine, select Software. Select OK.
  3. Restart Revu.
    1. If the issue persists, return to the Rendering Engine dropdown, and select Legacy (GDI). Select OK.
    2. Restart Revu.
Check drivers on host and client computers

Ensure that drivers for both the host and client computers are current, especially for graphics cards and connected devices like laptop docks. 

Check your network connection

A faulty network connection can result in significant delays when using Revu via RDP. Restarting the host and client machines may establish a more stable connection.

Transfer your license (Revu 20 & Below)
If you have a Bluebeam Plan, you can sign in to another device that has Revu 21 installed. Bluebeam Plans allow you to access Revu 21, Studio, and Bluebeam Cloud on up to five devices using a single login.

If the preceding steps have not resolved the issue, transferring your license to your local computer will ensure proper functionality.

Troubleshooting

Revu 2019

Revu 2018

Revu 2017 & Below

Error Message

System & Environment

Revu 20

Revu 21

Fix an issue that occurs when you connect to Revu on a host computer or server using Microsoft’s Remote Desktop Protocol (RDP).

Related Articles