Applies to:
- Revu 21
- Revu 20
- Revu 2019
- Revu 2018
Problem
When you attempt to insert pages into a PDF in Revu, or combine PDFs using the Bluebeam Stapler, the insert/combine function fails without displaying an error message. If you try to delete pages from the same PDF in Revu, the following error message appears:
Error occurred while attempting to delete pages. If this issue persists, please contact support@bluebeam.com.
Cause
If you’re encountering these issues, your PDF contains one or more broken bookmarks, hyperlinks, and/or Spaces.
Solution
To restore the ability to insert, combine, and/or delete pages, you must remove any broken bookmarks from your document. If you need to remove broken hyperlinks or Spaces, you’ll need to recreate the PDF.
Audit bookmarks
First, try removing all broken bookmarks from your PDF. To do this, use the Audit Bookmarks feature in Revu:
- Open the PDF encountering issues in Revu.
- Go to the
Bookmarks panel (Alt+B).
- At the top of the panel, select Bookmarks > Audit Bookmarks.
- A pop-up will display how many broken bookmarks were found in your PDF. To close it, select OK.
- After running the audit, broken bookmarks are marked with a red X in the
Bookmarks panel. To remove the broken bookmarks from your PDF, select multiple by holding Ctrl or Shift while clicking them and press Delete.
- Save the PDF (Ctrl+S) and reattempt to insert, combine, or delete pages.
Recreate PDF
If your document doesn’t contain any broken bookmarks, you must recreate the PDF. To do this, follow these steps:
- Make a copy of the document by selecting File >
Save As (Ctrl+Shift+S) and save it with a different file name.
- Open the saved copy of the PDF in Revu.
- If applicable, delete any markups on the PDF. To do this:
- Open the
Markups List (Alt+L).
- Select a markup and press Ctrl+A to select all markups.
- Press Delete.
- Open the
- Save the PDF copy by selecting File >
Save (Ctrl+S) and then close it.
- In Revu, go to File > Create >
From File (Ctrl+N).
- In the File Explorer, choose the PDF copy you just saved. Select Open.
- In the Save As dialog, select Save to recreate the PDF in Revu.
- If you had markups on the original PDF, you can reimport them. To do this:
- Go to the
Markups List > Markups >
Import.
- In the File Explorer, choose the original PDF with all your markups and select Open.
- Go to the
Revu 21
Revu 20
Revu 2019
Revu 2018
Revu 2017 & Below
Troubleshooting
Error Message